hostapd: Fix security problem in EAP-pwd
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Sep 2019 21:27:04 +0000 (23:27 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 10 Sep 2019 19:54:58 +0000 (21:54 +0200)
This fixes:
CVE-2019-11555 "EAP-pwd message reassembly issue with unexpected fragment"
https://w1.fi/security/2019-5/eap-pwd-message-reassembly-issue-with-unexpected-fragment.txt

This should not affect OpenWrt in the default settings as we do not use
EAP-pwd.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 9f34bf51d60a237696b1d4cc9b5f4835b95e7ea2)

package/network/services/hostapd/Makefile
package/network/services/hostapd/patches/065-0001-EAP-pwd-server-Fix-reassembly-buffer-handling.patch [new file with mode: 0644]
package/network/services/hostapd/patches/065-0003-EAP-pwd-peer-Fix-reassembly-buffer-handling.patch [new file with mode: 0644]

index d0866f670c0ba0cae8f85ca7de10490426d4736b..18e4ea44906c9f127db94121a4d0adb577026456 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/patches/065-0001-EAP-pwd-server-Fix-reassembly-buffer-handling.patch b/package/network/services/hostapd/patches/065-0001-EAP-pwd-server-Fix-reassembly-buffer-handling.patch
new file mode 100644 (file)
index 0000000..b98e183
--- /dev/null
@@ -0,0 +1,40 @@
+From fe76f487e28bdc61940f304f153a954cf36935ea Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@codeaurora.org>
+Date: Wed, 17 Apr 2019 01:55:32 +0300
+Subject: [PATCH 1/3] EAP-pwd server: Fix reassembly buffer handling
+
+data->inbuf allocation might fail and if that were to happen, the next
+fragment in the exchange could have resulted in NULL pointer
+dereference. Unexpected fragment with more bit might also be able to
+trigger this. Fix that by explicitly checking for data->inbuf to be
+available before using it.
+
+Signed-off-by: Jouni Malinen <jouni@codeaurora.org>
+---
+ src/eap_server/eap_server_pwd.c | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+--- a/src/eap_server/eap_server_pwd.c
++++ b/src/eap_server/eap_server_pwd.c
+@@ -947,6 +947,12 @@ static void eap_pwd_process(struct eap_s
+        * the first and all intermediate fragments have the M bit set
+        */
+       if (EAP_PWD_GET_MORE_BIT(lm_exch) || data->in_frag_pos) {
++              if (!data->inbuf) {
++                      wpa_printf(MSG_DEBUG,
++                                 "EAP-pwd: No buffer for reassembly");
++                      eap_pwd_state(data, FAILURE);
++                      return;
++              }
+               if ((data->in_frag_pos + len) > wpabuf_size(data->inbuf)) {
+                       wpa_printf(MSG_DEBUG, "EAP-pwd: Buffer overflow "
+                                  "attack detected! (%d+%d > %d)",
+@@ -967,7 +973,7 @@ static void eap_pwd_process(struct eap_s
+        * last fragment won't have the M bit set (but we're obviously
+        * buffering fragments so that's how we know it's the last)
+        */
+-      if (data->in_frag_pos) {
++      if (data->in_frag_pos && data->inbuf) {
+               pos = wpabuf_head_u8(data->inbuf);
+               len = data->in_frag_pos;
+               wpa_printf(MSG_DEBUG, "EAP-pwd: Last fragment, %d bytes",
diff --git a/package/network/services/hostapd/patches/065-0003-EAP-pwd-peer-Fix-reassembly-buffer-handling.patch b/package/network/services/hostapd/patches/065-0003-EAP-pwd-peer-Fix-reassembly-buffer-handling.patch
new file mode 100644 (file)
index 0000000..cc80562
--- /dev/null
@@ -0,0 +1,40 @@
+From d2d1a324ce937628e4d9d9999fe113819b7d4478 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@codeaurora.org>
+Date: Wed, 17 Apr 2019 02:21:20 +0300
+Subject: [PATCH 3/3] EAP-pwd peer: Fix reassembly buffer handling
+
+Unexpected fragment might result in data->inbuf not being allocated
+before processing and that could have resulted in NULL pointer
+dereference. Fix that by explicitly checking for data->inbuf to be
+available before using it.
+
+Signed-off-by: Jouni Malinen <jouni@codeaurora.org>
+---
+ src/eap_peer/eap_pwd.c | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+--- a/src/eap_peer/eap_pwd.c
++++ b/src/eap_peer/eap_pwd.c
+@@ -969,6 +969,13 @@ eap_pwd_process(struct eap_sm *sm, void
+        * buffer and ACK the fragment
+        */
+       if (EAP_PWD_GET_MORE_BIT(lm_exch) || data->in_frag_pos) {
++              if (!data->inbuf) {
++                      wpa_printf(MSG_DEBUG,
++                                 "EAP-pwd: No buffer for reassembly");
++                      ret->methodState = METHOD_DONE;
++                      ret->decision = DECISION_FAIL;
++                      return NULL;
++              }
+               data->in_frag_pos += len;
+               if (data->in_frag_pos > wpabuf_size(data->inbuf)) {
+                       wpa_printf(MSG_INFO, "EAP-pwd: Buffer overflow attack "
+@@ -995,7 +1002,7 @@ eap_pwd_process(struct eap_sm *sm, void
+       /*
+        * we're buffering and this is the last fragment
+        */
+-      if (data->in_frag_pos) {
++      if (data->in_frag_pos && data->inbuf) {
+               wpa_printf(MSG_DEBUG, "EAP-pwd: Last fragment, %d bytes",
+                          (int) len);
+               pos = wpabuf_head_u8(data->inbuf);