package/kernel: remove SetDepends not needed anymore
authorNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 13:11:06 +0000 (13:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 13:11:06 +0000 (13:11 +0000)
SVN-Revision: 28653

package/kernel/modules/001-depends.mk
package/kernel/modules/lib.mk
package/kernel/modules/other.mk

index 238799e2e54c6d4dcd469598e203d8f36e187986..93aaeb33fb6e1d27a8b63597db5f610770da0168 100644 (file)
@@ -1,37 +1,20 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-# XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
-
-define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
-endef
-
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
-endef
-
-
-define SetDepends/hid
-  DEPENDS:= @!TARGET_x86
+  DEPENDS+= +kmod-crc16 $(1)
 endef
 
 define AddDepends/hid
-  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
-
-endef
-
-
-define SetDepends/input
-  DEPENDS:= @!(TARGET_x86_generic||TARGET_x86_kvm_guest)
+  DEPENDS+= +kmod-hid $(1)
 endef
 
 define AddDepends/input
-  DEPENDS+= +!(TARGET_x86_generic||TARGET_x86_kvm_guest):kmod-input-core $(1)
+  DEPENDS+= +kmod-input-core $(1)
 endef
 
 
index 9154b2eade4989940732fd1070c414751239ffee..4b9eed45e2fdd7fd3ec05bd5d316f6f238471a82 100644 (file)
@@ -58,7 +58,6 @@ define KernelPackage/crc16
   KCONFIG:=CONFIG_CRC16
   FILES:=$(LINUX_DIR)/lib/crc16.ko
   AUTOLOAD:=$(call AutoLoad,20,crc16,1)
-  $(call SetDepends/crc16)
 endef
 
 define KernelPackage/crc16/description
index dcab71fa23798dbb09aa4ab70ecf24a35c6543f3..951f7ac9443e5602b598bac9332d7f7c6f5d9268 100644 (file)
@@ -260,7 +260,6 @@ define KernelPackage/hid
   KCONFIG:=CONFIG_HID
   FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
   AUTOLOAD:=$(call AutoLoad,61,hid)
-  $(call SetDepends/hid)
   $(call AddDepends/input,+kmod-input-evdev)
 endef
 
@@ -275,7 +274,6 @@ define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
   KCONFIG:=CONFIG_INPUT
-  $(call SetDepends/input)
   FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
   AUTOLOAD:=$(call AutoLoad,19,input-core)
 endef