* adds arv4518pw mach support * fixes arv4525pw * make sure all mach names have the...
authorJohn Crispin <john@openwrt.org>
Sun, 23 Jan 2011 19:16:33 +0000 (19:16 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 23 Jan 2011 19:16:33 +0000 (19:16 +0000)
SVN-Revision: 25075

target/linux/lantiq/image/Makefile
target/linux/lantiq/patches/104-board_xway.patch
target/linux/lantiq/patches/270-crypto.patch
target/linux/lantiq/patches/400-mach-arv45xx.patch
target/linux/lantiq/patches/700-dwc_otg.patch

index f00c8e753ad9efbd6f3f240f90f7e00b3a523074..2d6acc8d419c71d698105732599b02164188c3a6 100644 (file)
@@ -59,8 +59,11 @@ define Image/BuildKernel
        $(call Image/BuildKernel/Template,EASY4010,$(xway_cmdline))
        $(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
        $(call Image/BuildKernel/Template,EASY50812,$(xway_cmdline))
-       $(call Image/BuildKernel/Template,ARV452,$(xway_cmdline))
-       $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,ARV4510PW,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,ARV4518PW,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,ARV4520PW,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,ARV4525PW,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,NONE)
 endef
@@ -69,8 +72,11 @@ define Image/Build
        $(call Image/Build/$(1),$(1),EASY4010)
        $(call Image/Build/$(1),$(1),EASY50712)
        $(call Image/Build/$(1),$(1),EASY50812)
-       $(call Image/Build/$(1),$(1),ARV452)
-       $(call Image/Build/$(1),$(1),ARV752DPW22)
+       $(call Image/Build/$(1),$(1),ARV4510PW)
+       $(call Image/Build/$(1),$(1),ARV4518PW)
+       $(call Image/Build/$(1),$(1),ARV4520PW)
+       $(call Image/Build/$(1),$(1),ARV4525PW)
+       $(call Image/Build/$(1),$(1),ARV752DPW)
        $(call Image/Build/$(1),$(1),ARV7518PW)
        $(call Image/Build/$(1),$(1),NONE)
        $(CP) $(KDIR)/root.$(1)  $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
index e70ff8007401ab0387ffb57e376e71f76a304ee1..fcd9c0e326c6a7153fafa67f4dfedd444a949d76 100644 (file)
 +}
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/devices.c
-@@ -0,0 +1,278 @@
+@@ -0,0 +1,305 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
 + *  under the terms of the GNU General Public License version 2 as published
 +#include <linux/time.h>
 +#include <linux/io.h>
 +#include <linux/gpio.h>
++#include <linux/gpio_buttons.h>
 +#include <linux/leds.h>
 +
 +#include <asm/bootinfo.h>
 +      platform_device_register(&lq_gpio_leds);
 +}
 +
++/* gpio buttons */
++static struct gpio_buttons_platform_data lq_gpio_buttons_platform_data;
++
++static struct platform_device lq_gpio_buttons_platform_device =
++{
++      .name = "gpio-buttons",
++      .id = 0,
++      .dev = {
++              .platform_data = (void *) &lq_gpio_buttons_platform_data,
++      },
++};
++
++void __init
++lq_register_gpio_buttons(struct gpio_button *buttons, int cnt)
++{
++      lq_gpio_buttons_platform_data.buttons = buttons;
++      lq_gpio_buttons_platform_data.nbuttons = cnt;
++      platform_device_register(&lq_gpio_buttons_platform_device);
++}
++
 +/* serial to parallel conversion */
 +static struct resource lq_stp_resource =
 +{
 +              break;
 +      }
 +}
++
++void __init
++lq_register_crypto(const char *name)
++{
++      platform_device_register_simple(name, 0, 0, 0);
++}
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/devices.h
-@@ -0,0 +1,25 @@
+@@ -0,0 +1,26 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
 + *  under the terms of the GNU General Public License version 2 as published
 +extern void __init lq_register_wdt(void);
 +extern void __init lq_register_ethernet(struct lq_eth_data *eth);
 +extern void __init lq_register_asc(int port);
++extern void __init lq_register_gpio_buttons(struct gpio_button *buttons, int cnt);
 +
 +#endif
 --- /dev/null
index e6ee88585c2544ce5a2ec8742549868f1bde1825..685158029c580bcd407d01a7f118bba657c74ac9 100644 (file)
 +};
 +
 +#endif /* DEU_FALCON_H */
---- a/arch/mips/lantiq/xway/devices.c
-+++ b/arch/mips/lantiq/xway/devices.c
-@@ -277,3 +277,9 @@
-               break;
-       }
- }
-+
-+void __init
-+lq_register_crypto(const char *name)
-+{
-+      platform_device_register_simple(name, 0, 0, 0);
-+}
 --- a/arch/mips/lantiq/xway/devices.h
 +++ b/arch/mips/lantiq/xway/devices.h
-@@ -21,5 +21,6 @@
- extern void __init lq_register_wdt(void);
+@@ -22,5 +22,6 @@
  extern void __init lq_register_ethernet(struct lq_eth_data *eth);
  extern void __init lq_register_asc(int port);
+ extern void __init lq_register_gpio_buttons(struct gpio_button *buttons, int cnt);
 +extern void __init lq_register_crypto(const char *name);
  
  #endif
 --- a/arch/mips/lantiq/xway/mach-easy50712.c
 +++ b/arch/mips/lantiq/xway/mach-easy50712.c
-@@ -72,6 +72,7 @@
+@@ -74,6 +74,7 @@
        lq_register_wdt();
        lq_register_pci(&lq_pci_data);
        lq_register_ethernet(&lq_eth_data);
  MIPS_MACHINE(LANTIQ_MACH_EASY50712,
 --- a/arch/mips/lantiq/xway/mach-easy50812.c
 +++ b/arch/mips/lantiq/xway/mach-easy50812.c
-@@ -71,6 +71,7 @@
+@@ -73,6 +73,7 @@
        lq_register_wdt();
        lq_register_pci(&lq_pci_data);
        lq_register_ethernet(&lq_eth_data);
index 6a7770c01eb571db0b537e489bdb9ab24af9ac47..98ff6803318222cc08a1fd68ab30b0bd17e69f57 100644 (file)
@@ -1,13 +1,17 @@
 --- a/arch/mips/include/asm/mach-lantiq/machine.h
 +++ b/arch/mips/include/asm/mach-lantiq/machine.h
-@@ -11,4 +11,9 @@
+@@ -11,4 +11,13 @@
        LANTIQ_MACH_EASY4010,           /* Twinpass evalkit */
        LANTIQ_MACH_EASY50712,          /* Danube evalkit */
        LANTIQ_MACH_EASY50812,          /* AR9 eval board */
-+      LANTIQ_MACH_ARV4518,            /* Airties WAV-221, SMC-7908A-ISP */
-+      LANTIQ_MACH_ARV452,                     /* Airties WAV-281, Arcor EasyboxA800 */
-+      LANTIQ_MACH_ARV4525,            /* Speedport W502V */
-+      LANTIQ_MACH_ARV752DPW22,        /* Arcor easybox a803 */
++
++      /* Arcadyan */
++      LANTIQ_MACH_ARV4510PW,          /* Wippies Homebox */
++      LANTIQ_MACH_ARV4518PW,          /* Airties WAV-221, SMC-7908A-ISP */
++      LANTIQ_MACH_ARV4520PW,          /* Airties WAV-281, Arcor EasyboxA800 */
++      LANTIQ_MACH_ARV452CPW,          /* Arcor EasyboxA801 */
++      LANTIQ_MACH_ARV4525PW,          /* Speedport W502V */
++      LANTIQ_MACH_ARV752DPW,          /* Arcor easybox a803 */
 +      LANTIQ_MACH_ARV7518PW,          /* ASTORIA */
  };
 --- a/arch/mips/lantiq/xway/Kconfig
@@ -32,7 +36,7 @@
 +obj-$(CONFIG_LANTIQ_MACH_ARV45XX) += mach-arv45xx.o
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/mach-arv45xx.c
-@@ -0,0 +1,299 @@
+@@ -0,0 +1,389 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
 + *  under the terms of the GNU General Public License version 2 as published
 +#include <lantiq_platform.h>
 +
 +#include "devices.h"
++#include "dev-dwc_otg.h"
 +
-+#define ARV452_LATCH_SWITCH           (1 << 10)
-+#define ARV752DPW22_LATCH_DEFAULT     (2)
++#define ARV4520PW_LATCH_SWITCH                (1 << 10)
++#define ARV752DPW_LATCH_DEFAULT               (2)
 +
 +#ifdef CONFIG_MTD_PARTITIONS
 +static struct mtd_partition arv45xx_partitions[] =
 +              .size   = 0x10000,
 +      },
 +};
-+#endif
 +
-+static struct physmap_flash_data arv45xx_flash_data = {
-+#ifdef CONFIG_MTD_PARTITIONS
-+      .nr_parts       = ARRAY_SIZE(arv45xx_partitions),
-+      .parts          = arv45xx_partitions,
-+#endif
++static struct mtd_partition arv4518_partitions[] =
++{
++      {
++              .name   = "uboot",
++              .offset = 0x0,
++              .size   = 0x40000,
++      },
++      {
++              .name   = "uboot_env",
++              .offset = 0x40000,
++              .size   = 0x10000,
++      },
++      {
++              .name   = "linux",
++              .offset = 0x50000,
++              .size   = 0x3a0000,
++      },
++      {
++              .name   = "board_config",
++              .offset = 0x3f0000,
++              .size   = 0x10000,
++      },
 +};
 +
 +static struct mtd_partition arv75xx_partitions[] =
 +      },
 +};
 +
++#endif
++
++static struct physmap_flash_data arv45xx_flash_data = {
++#ifdef CONFIG_MTD_PARTITIONS
++      .nr_parts       = ARRAY_SIZE(arv45xx_partitions),
++      .parts          = arv45xx_partitions,
++#endif
++};
++
++static struct physmap_flash_data arv4518_flash_data = {
++#ifdef CONFIG_MTD_PARTITIONS
++      .nr_parts       = ARRAY_SIZE(arv4518_partitions),
++      .parts          = arv4518_partitions,
++#endif
++};
++
 +static struct physmap_flash_data arv75xx_flash_data = {
 +#ifdef CONFIG_MTD_PARTITIONS
 +      .nr_parts       = ARRAY_SIZE(arv75xx_partitions),
 +};
 +
 +static struct gpio_led
-+arv4518_leds_gpio[] __initdata = {
-+      { .name = "soc:blue:power", .gpio = 3, .active_low = 1, },
-+      { .name = "soc:blue:adsl", .gpio = 4, .active_low = 1, },
-+      { .name = "soc:blue:internet", .gpio = 5, .active_low = 1, },
-+      { .name = "soc:red:power", .gpio = 6, .active_low = 1, },
-+      { .name = "soc:yello:wps", .gpio = 7, .active_low = 1, },
-+      { .name = "soc:red:wps", .gpio = 9, .active_low = 1, },
-+      { .name = "soc:blue:voip", .gpio = 32, .active_low = 1, },
-+      { .name = "soc:blue:fxs1", .gpio = 33, .active_low = 1, },
-+      { .name = "soc:blue:fxs2", .gpio = 34, .active_low = 1, },
-+      { .name = "soc:blue:fxo", .gpio = 35, .active_low = 1, },
-+      { .name = "soc:blue:voice", .gpio = 36, .active_low = 1, },
-+      { .name = "soc:blue:usb", .gpio = 37, .active_low = 1, },
-+      { .name = "soc:blue:wlan", .gpio = 38, .active_low = 1, },
++arv4510pw_leds_gpio[] __initdata = {
++      { .name = "soc:green:foo", .gpio = 4, .active_low = 1, },
 +};
 +
 +static struct gpio_led
-+arv452_leds_gpio[] __initdata = {
++arv4518pw_leds_gpio[] __initdata = {
++      { .name = "soc:green:power", .gpio = 3, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:adsl", .gpio = 4, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:internet", .gpio = 5, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:wlan", .gpio = 6, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:yellow:wps", .gpio = 7, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:red:fail", .gpio = 8, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:usb", .gpio = 19, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:voip", .gpio = 32, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:fxs1", .gpio = 33, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:fxs2", .gpio = 34, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:fxo", .gpio = 35, .active_low = 1, .default_trigger = "default-on" },
++};
++
++static struct gpio_button
++arv4518pw_gpio_buttons[] __initdata = {
++      { .desc = "wlan", .type = EV_KEY, .code = BTN_0, .threshold = 3, .gpio = 28, .active_low = 1, },
++      { .desc = "wps", .type = EV_KEY, .code = BTN_1, .threshold = 3, .gpio = 29, .active_low = 1, },
++      { .desc = "reset", .type = EV_KEY, .code = BTN_2, .threshold = 3, .gpio = 30, .active_low = 1, },
++};
++
++static struct gpio_led
++arv4520pw_leds_gpio[] __initdata = {
 +      { .name = "soc:blue:power", .gpio = 3, .active_low = 1, },
 +      { .name = "soc:blue:adsl", .gpio = 4, .active_low = 1, },
 +      { .name = "soc:blue:internet", .gpio = 5, .active_low = 1, },
 +      { .name = "soc:blue:wlan", .gpio = 38, .active_low = 1, },
 +};
 +
-+static struct gpio_led arv4525_leds_gpio[] __initdata = {
-+      { .name = "soc:green:festnetz", .gpio = 4, .active_low = 1, },
-+      { .name = "soc:green:internet", .gpio = 5, .active_low = 1, },
-+      { .name = "soc:green:dsl", .gpio = 6, .active_low = 1, },
-+      { .name = "soc:green:wlan", .gpio = 8, .active_low = 1, },
-+      { .name = "soc:green:online", .gpio = 9, .active_low = 1, },
++static struct gpio_led
++arv4525pw_leds_gpio[] __initdata = {
++      { .name = "soc:green:festnetz", .gpio = 4, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:internet", .gpio = 5, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:dsl", .gpio = 6, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:wlan", .gpio = 8, .active_low = 1, .default_trigger = "default-on" },
++      { .name = "soc:green:online", .gpio = 9, .active_low = 1, .default_trigger = "default-on" },
 +};
 +
 +static struct gpio_led
-+arv752dpw22_leds_gpio[] __initdata = {
++arv752dpw_leds_gpio[] __initdata = {
 +      { .name = "soc:blue:power", .gpio = 3, .active_low = 1, .default_trigger = "default-on" },
 +      { .name = "soc:red:internet", .gpio = 5, .active_low = 1, .default_trigger = "default-on" },
 +      { .name = "soc:red:power", .gpio = 6, .active_low = 1, .default_trigger = "default-on" },
 +      { .name = "soc:green:eth4", .gpio = 46, .active_low = 1, .default_trigger = "default-on", },
 +};
 +
++static struct gpio_button
++arv752dpw_gpio_buttons[] __initdata = {
++      { .desc = "btn0", .type = EV_KEY, .code = BTN_0, .threshold = 3, .gpio = 12, .active_low = 1, },
++      { .desc = "btn1", .type = EV_KEY, .code = BTN_1, .threshold = 3, .gpio = 13, .active_low = 1, },
++      { .desc = "btn2", .type = EV_KEY, .code = BTN_2, .threshold = 3, .gpio = 28, .active_low = 1, },
++};
++
 +static struct gpio_led
 +arv7518pw_leds_gpio[] __initdata = {
 +      { .name = "soc:green:power", .gpio = 2, .active_low = 1, },
 +      lq_register_ethernet(&lq_eth_data);
 +}
 +
++static void
++bewan_register_ethernet(void)
++{
++#define BEWAN_BRN_MAC                 0x3f0014
++      memcpy_fromio(lq_eth_data.mac,
++              (void *)KSEG1ADDR(LQ_FLASH_START + BEWAN_BRN_MAC), 6);
++      lq_register_ethernet(&lq_eth_data);
++}
++
 +static void __init
-+arv4518_init(void)
++arv4510pw_init(void)
 +{
 +      lq_register_gpio();
-+      lq_register_gpio_ebu(0);
-+      lq_register_gpio_leds(arv4518_leds_gpio, ARRAY_SIZE(arv4518_leds_gpio));
++      lq_register_gpio_stp();
++      lq_register_gpio_leds(arv4510pw_leds_gpio, ARRAY_SIZE(arv4510pw_leds_gpio));
 +      lq_register_asc(0);
 +      lq_register_asc(1);
 +      lq_register_nor(&arv45xx_flash_data);
 +      lq_register_pci(&lq_pci_data);
++      lq_pci_data.irq[15] = (INT_NUM_IM2_IRL0 + 31);
++      lq_pci_data.gpio |= PCI_EXIN1 | PCI_REQ2;
++      lq_register_pci(&lq_pci_data);
++      lq_register_wdt();
++      bewan_register_ethernet();
++}
++
++MIPS_MACHINE(LANTIQ_MACH_ARV4510PW,
++                      "ARV4510PW",
++                      "ARV4510PW - Wippies Homebox",
++                      arv4510pw_init);
++
++static void __init
++arv4518pw_init(void)
++{
++      lq_register_gpio();
++      lq_register_gpio_ebu(0);
++      lq_register_gpio_leds(arv4518pw_leds_gpio, ARRAY_SIZE(arv4518pw_leds_gpio));
++      lq_register_gpio_buttons(arv4518pw_gpio_buttons, ARRAY_SIZE(arv4518pw_gpio_buttons));
++      lq_register_asc(0);
++      lq_register_asc(1);
++      lq_register_nor(&arv4518_flash_data);
++      lq_pci_data.gpio = PCI_GNT2 | PCI_REQ2;
++      lq_register_pci(&lq_pci_data);
 +      lq_register_wdt();
 +      arv45xx_register_ethernet();
++      xway_register_dwc(14);
++      gpio_request(13, "switch-reset");
++      gpio_direction_output(13, 1);
++      gpio_export(13, 0);
 +}
 +
-+MIPS_MACHINE(LANTIQ_MACH_ARV4518,
-+                      "ARV4518",
-+                      "ARV4518 - SMC7908A-ISP",
-+                      arv4518_init);
++MIPS_MACHINE(LANTIQ_MACH_ARV4518PW,
++                      "ARV4518PW",
++                      "ARV4518PW - SMC7908A-ISP, Airties WAV-221",
++                      arv4518pw_init);
 +
 +static void __init
-+arv452_init(void)
++arv4520pw_init(void)
 +{
 +      lq_register_gpio();
-+      lq_register_gpio_ebu(ARV452_LATCH_SWITCH);
-+      lq_register_gpio_leds(arv452_leds_gpio, ARRAY_SIZE(arv452_leds_gpio));
++      lq_register_gpio_ebu(ARV4520PW_LATCH_SWITCH);
++      lq_register_gpio_leds(arv4520pw_leds_gpio, ARRAY_SIZE(arv4520pw_leds_gpio));
 +      lq_register_asc(0);
 +      lq_register_asc(1);
 +      lq_register_nor(&arv45xx_flash_data);
 +      lq_register_pci(&lq_pci_data);
 +      lq_register_wdt();
 +      arv45xx_register_ethernet();
++      xway_register_dwc(28);
 +}
 +
-+MIPS_MACHINE(LANTIQ_MACH_ARV452,
-+                      "ARV452",
-+                      "ARV452 - Airties WAV-281, Arcor A800",
-+                      arv452_init);
++MIPS_MACHINE(LANTIQ_MACH_ARV4520PW,
++                      "ARV4520PW",
++                      "ARV4520PW - Airties WAV-281, Arcor A800",
++                      arv4520pw_init);
 +
 +static void __init
-+arv4525_init(void)
++arv4525pw_init(void)
 +{
 +      lq_register_gpio();
-+      lq_register_gpio_leds(arv4525_leds_gpio, ARRAY_SIZE(arv4525_leds_gpio));
++      lq_register_gpio_leds(arv4525pw_leds_gpio, ARRAY_SIZE(arv4525pw_leds_gpio));
 +      lq_register_asc(0);
 +      lq_register_asc(1);
 +      lq_register_nor(&arv45xx_flash_data);
++      lq_pci_data.clock = PCI_CLOCK_INT;
 +      lq_register_pci(&lq_pci_data);
 +      lq_register_wdt();
 +      lq_eth_data.mii_mode = MII_MODE;
 +      arv45xx_register_ethernet();
 +}
 +
-+MIPS_MACHINE(LANTIQ_MACH_ARV4525,
-+                      "ARV4525",
-+                      "ARV4525 - Speedport W502V",
-+                      arv4525_init);
-+
++MIPS_MACHINE(LANTIQ_MACH_ARV4525PW,
++                      "ARV4525PW",
++                      "ARV4525PW - Speedport W502V",
++                      arv4525pw_init);
 +
 +static void __init
 +arv7518pw_init(void)
 +{
 +      lq_register_gpio();
-+      lq_register_gpio_ebu(ARV452_LATCH_SWITCH);
++      lq_register_gpio_ebu(ARV4520PW_LATCH_SWITCH);
 +      lq_register_asc(0);
 +      lq_register_asc(1);
 +      lq_register_gpio_leds(arv7518pw_leds_gpio, ARRAY_SIZE(arv7518pw_leds_gpio));
 +                      arv7518pw_init);
 +
 +static void __init
-+arv752dpw22_init(void)
++arv752dpw_init(void)
 +{
 +      lq_register_gpio();
-+      lq_register_gpio_ebu(ARV752DPW22_LATCH_DEFAULT);
++      lq_register_gpio_ebu(ARV752DPW_LATCH_DEFAULT);
 +      lq_register_asc(0);
 +      lq_register_asc(1);
-+      lq_register_gpio_leds(arv752dpw22_leds_gpio, ARRAY_SIZE(arv752dpw22_leds_gpio));
++      lq_register_gpio_leds(arv752dpw_leds_gpio, ARRAY_SIZE(arv752dpw_leds_gpio));
++      lq_register_gpio_buttons(arv752dpw_gpio_buttons, ARRAY_SIZE(arv752dpw_gpio_buttons));
 +      lq_register_nor(&arv75xx_flash_data);
 +      lq_pci_data.irq[15] = (INT_NUM_IM2_IRL0 + 31);
 +      lq_pci_data.gpio |= PCI_EXIN1 | PCI_REQ2;
 +      gpio_direction_output(33, 1);
 +}
 +
-+MIPS_MACHINE(LANTIQ_MACH_ARV752DPW22,
-+                      "ARV752DPW22",
-+                      "ARV752DPW22 - Arcor A803",
-+                      arv752dpw22_init);
++MIPS_MACHINE(LANTIQ_MACH_ARV752DPW,
++                      "ARV752DPW",
++                      "ARV752DPW - Arcor A803",
++                      arv752dpw_init);
index b50970350e5a5f883feb1b229ab49c73cb467bb8..ea2a5f7f07a820268036cd2f585dbd5cd7473dba 100644 (file)
 +extern void __init xway_register_dwc(int pin);
 +
 +#endif
---- a/arch/mips/lantiq/xway/mach-arv45xx.c
-+++ b/arch/mips/lantiq/xway/mach-arv45xx.c
-@@ -23,6 +23,7 @@
- #include <lantiq_platform.h>
- #include "devices.h"
-+#include "dev-dwc_otg.h"
- #define ARV452_LATCH_SWITCH           (1 << 10)
- #define ARV752DPW22_LATCH_DEFAULT     (2)
-@@ -195,6 +196,7 @@
-       lq_register_pci(&lq_pci_data);
-       lq_register_wdt();
-       arv45xx_register_ethernet();
-+      xway_register_dwc(14);
- }
- MIPS_MACHINE(LANTIQ_MACH_ARV4518,
-@@ -214,6 +216,7 @@
-       lq_register_pci(&lq_pci_data);
-       lq_register_wdt();
-       arv45xx_register_ethernet();
-+      xway_register_dwc(28);
- }
- MIPS_MACHINE(LANTIQ_MACH_ARV452,