wolfssl: disable broken shipped Job server macro
authorJo-Philipp Wich <jo@mein.io>
Thu, 23 Aug 2018 18:03:29 +0000 (20:03 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 23 Aug 2018 18:14:00 +0000 (20:14 +0200)
The AX_AM_JOBSERVER macro shipped with m4/ax_am_jobserver.m4 is broken on
plain POSIX shells due to the use of `let`.

Shells lacking `let` will fail to run the generated m4sh code and end up
invoking "make" with "-jyes" as argument, fialing the build.

Since there is no reason in the first place for some random package to
muck with the make job server settings and since we do not want it to
randomly override "-j" either, simply remove references to this defunct
macro to let the build succeed on platforms which not happen to use bash
as default shell.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/wolfssl/patches/900-remove-broken-autoconf-macros.patch [new file with mode: 0644]

diff --git a/package/libs/wolfssl/patches/900-remove-broken-autoconf-macros.patch b/package/libs/wolfssl/patches/900-remove-broken-autoconf-macros.patch
new file mode 100644 (file)
index 0000000..f7756b1
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4140,7 +4140,6 @@ AC_CONFIG_FILES([support/wolfssl.pc])
+ AC_CONFIG_FILES([rpm/spec])
+ AX_CREATE_GENERIC_CONFIG
+-AX_AM_JOBSERVER([yes])
+ AC_OUTPUT
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,8 +20,6 @@ dist_noinst_SCRIPTS =
+ noinst_SCRIPTS =
+ check_SCRIPTS =
+-#includes additional rules from aminclude.am
+-@INC_AMINCLUDE@
+ DISTCLEANFILES+= aminclude.am
+ CLEANFILES+= cert.der \