split magicbox patch
authorFelix Fietkau <nbd@openwrt.org>
Wed, 30 Aug 2006 04:09:54 +0000 (04:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 30 Aug 2006 04:09:54 +0000 (04:09 +0000)
SVN-Revision: 4707

openwrt/target/linux/magicbox-2.6/patches/001-magicbox_support.patch
openwrt/target/linux/magicbox-2.6/patches/002-flash_map.patch [new file with mode: 0644]

index 57d3b31081fa9bde85d9c0b1df967161e8aa12e5..b7806da6978e32ca153626937015ec13c7557ab6 100644 (file)
@@ -356,142 +356,6 @@ diff -Nur linux-2.6.17/arch/ppc/platforms/4xx/Makefile linux-2.6.17-owrt/arch/pp
  obj-$(CONFIG_XILINX_ML300)    += xilinx_ml300.o
  obj-$(CONFIG_XILINX_ML403)    += xilinx_ml403.o
  
-diff -Nur linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17-owrt/drivers/mtd/maps/Kconfig
---- linux-2.6.17/drivers/mtd/maps/Kconfig      2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17-owrt/drivers/mtd/maps/Kconfig 2006-08-25 23:33:05.000000000 +0200
-@@ -323,6 +323,15 @@
-         Walnut board. If you have one of these boards and would like to
-         use the flash chips on it, say 'Y'.
-+config MTD_MAGICMAP
-+      tristate "Flash device mapped on IBM 405EP MagicBox"
-+      depends on MTD_CFI && MTD_PARTITIONS && 40x && MAGICBOX
-+      help
-+        This enables access routines for the flash chips on the IBM 405EP
-+        MagicBox board. If you have one of these boards and would like to
-+        use the flash chips on it, say 'Y'.
-+
-+
- config MTD_EBONY
-       tristate "Flash devices mapped on IBM 440GP Ebony"
-       depends on MTD_JEDECPROBE && EBONY
-diff -Nur linux-2.6.17/drivers/mtd/maps/magicmap.c linux-2.6.17-owrt/drivers/mtd/maps/magicmap.c
---- linux-2.6.17/drivers/mtd/maps/magicmap.c   1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.17-owrt/drivers/mtd/maps/magicmap.c      2006-08-25 23:33:05.000000000 +0200
-@@ -0,0 +1,102 @@
-+/*
-+ * magicmap.c: Copyleft 2005  Karol Lewandowski
-+ *
-+ * Mapping for MagicBox flash.
-+ * Based on walnut.c.
-+ *
-+ * Heikki Lindholm <holindho@infradead.org>
-+ *
-+ *
-+ * This program is free software; you can redistribute  it and/or modify it
-+ * under  the terms of  the GNU General  Public License as published by the
-+ * Free Software Foundation;  either version 2 of the  License, or (at your
-+ * option) any later version.
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/types.h>
-+#include <linux/kernel.h>
-+#include <linux/init.h>
-+#include <linux/mtd/mtd.h>
-+#include <linux/mtd/map.h>
-+#include <linux/mtd/partitions.h>
-+#include <linux/config.h>
-+#include <asm/io.h>
-+
-+static struct mtd_info *flash;
-+
-+static struct map_info magic_map = {
-+      .name =         "Magically mapped flash",
-+      .phys =         0xffc00000,
-+      .size =         0x400000,
-+      .bankwidth =    2,
-+};
-+
-+static struct mtd_partition magic_partitions[] = {
-+      {
-+              .name =   "kernel",
-+              .offset = 0x0,
-+              .size =   0x0e0000,
-+      },
-+      {
-+              .name =   "ramdisk",
-+              .offset = 0x0e0000,
-+              .size =   0x2c0000,
-+      },
-+      {
-+              .name =   "persistent",
-+              .offset = 0x3a0000,
-+              .size =   0x020000,
-+      },
-+      {
-+              .name =   "bootloader",
-+              .offset = 0x3c0000,
-+              .size =   0x040000,
-+              .mask_flags = MTD_WRITEABLE,
-+      },
-+};
-+
-+int __init init_magic(void)
-+{
-+      magic_map.virt =
-+              (void __iomem *)ioremap(magic_map.phys, magic_map.size);
-+
-+      if (!magic_map.virt) {
-+              printk("Failed to ioremap flash.\n");
-+              return -EIO;
-+      }
-+
-+      simple_map_init(&magic_map);
-+
-+      flash = do_map_probe("cfi_probe", &magic_map);
-+      if (flash) {
-+              flash->owner = THIS_MODULE;
-+              add_mtd_partitions(flash, magic_partitions,
-+                                      ARRAY_SIZE(magic_partitions));
-+      } else {
-+              printk("map probe failed for flash\n");
-+              return -ENXIO;
-+      }
-+
-+      return 0;
-+}
-+
-+static void __exit cleanup_magic(void)
-+{
-+      if (flash) {
-+              del_mtd_partitions(flash);
-+              map_destroy(flash);
-+      }
-+
-+      if (magic_map.virt) {
-+              iounmap((void *)magic_map.virt);
-+              magic_map.virt = NULL;
-+      }
-+}
-+
-+module_init(init_magic);
-+module_exit(cleanup_magic);
-+
-+MODULE_LICENSE("GPL");
-+MODULE_AUTHOR("Karol Lewandowski");
-+MODULE_DESCRIPTION("MTD map and partitions for IBM 405EP MagicBox boards");
-diff -Nur linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17-owrt/drivers/mtd/maps/Makefile
---- linux-2.6.17/drivers/mtd/maps/Makefile     2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17-owrt/drivers/mtd/maps/Makefile        2006-08-25 23:33:05.000000000 +0200
-@@ -58,6 +58,7 @@
- obj-$(CONFIG_MTD_BEECH)               += beech-mtd.o
- obj-$(CONFIG_MTD_ARCTIC)      += arctic-mtd.o
- obj-$(CONFIG_MTD_WALNUT)        += walnut.o
-+obj-$(CONFIG_MTD_MAGICMAP)      += magicmap.o
- obj-$(CONFIG_MTD_H720X)               += h720x-flash.o
- obj-$(CONFIG_MTD_SBC8240)     += sbc8240.o
- obj-$(CONFIG_MTD_NOR_TOTO)    += omap-toto-flash.o
 diff -Nur linux-2.6.17/include/asm-ppc/ibm4xx.h linux-2.6.17-owrt/include/asm-ppc/ibm4xx.h
 --- linux-2.6.17/include/asm-ppc/ibm4xx.h      2006-06-18 03:49:35.000000000 +0200
 +++ linux-2.6.17-owrt/include/asm-ppc/ibm4xx.h 2006-08-25 23:33:05.000000000 +0200
diff --git a/openwrt/target/linux/magicbox-2.6/patches/002-flash_map.patch b/openwrt/target/linux/magicbox-2.6/patches/002-flash_map.patch
new file mode 100644 (file)
index 0000000..5b45bca
--- /dev/null
@@ -0,0 +1,137 @@
+diff -Nur linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17-owrt/drivers/mtd/maps/Kconfig
+--- linux-2.6.17/drivers/mtd/maps/Kconfig      2006-06-18 03:49:35.000000000 +0200
++++ linux-2.6.17-owrt/drivers/mtd/maps/Kconfig 2006-08-25 23:33:05.000000000 +0200
+@@ -323,6 +323,15 @@
+         Walnut board. If you have one of these boards and would like to
+         use the flash chips on it, say 'Y'.
++config MTD_MAGICMAP
++      tristate "Flash device mapped on IBM 405EP MagicBox"
++      depends on MTD_CFI && MTD_PARTITIONS && 40x && MAGICBOX
++      help
++        This enables access routines for the flash chips on the IBM 405EP
++        MagicBox board. If you have one of these boards and would like to
++        use the flash chips on it, say 'Y'.
++
++
+ config MTD_EBONY
+       tristate "Flash devices mapped on IBM 440GP Ebony"
+       depends on MTD_JEDECPROBE && EBONY
+diff -Nur linux-2.6.17/drivers/mtd/maps/magicmap.c linux-2.6.17-owrt/drivers/mtd/maps/magicmap.c
+--- linux-2.6.17/drivers/mtd/maps/magicmap.c   1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.17-owrt/drivers/mtd/maps/magicmap.c      2006-08-25 23:33:05.000000000 +0200
+@@ -0,0 +1,102 @@
++/*
++ * magicmap.c: Copyleft 2005  Karol Lewandowski
++ *
++ * Mapping for MagicBox flash.
++ * Based on walnut.c.
++ *
++ * Heikki Lindholm <holindho@infradead.org>
++ *
++ *
++ * This program is free software; you can redistribute  it and/or modify it
++ * under  the terms of  the GNU General  Public License as published by the
++ * Free Software Foundation;  either version 2 of the  License, or (at your
++ * option) any later version.
++ */
++
++#include <linux/module.h>
++#include <linux/types.h>
++#include <linux/kernel.h>
++#include <linux/init.h>
++#include <linux/mtd/mtd.h>
++#include <linux/mtd/map.h>
++#include <linux/mtd/partitions.h>
++#include <linux/config.h>
++#include <asm/io.h>
++
++static struct mtd_info *flash;
++
++static struct map_info magic_map = {
++      .name =         "Magically mapped flash",
++      .phys =         0xffc00000,
++      .size =         0x400000,
++      .bankwidth =    2,
++};
++
++static struct mtd_partition magic_partitions[] = {
++      {
++              .name =   "kernel",
++              .offset = 0x0,
++              .size =   0x0e0000,
++      },
++      {
++              .name =   "ramdisk",
++              .offset = 0x0e0000,
++              .size =   0x2c0000,
++      },
++      {
++              .name =   "persistent",
++              .offset = 0x3a0000,
++              .size =   0x020000,
++      },
++      {
++              .name =   "bootloader",
++              .offset = 0x3c0000,
++              .size =   0x040000,
++              .mask_flags = MTD_WRITEABLE,
++      },
++};
++
++int __init init_magic(void)
++{
++      magic_map.virt =
++              (void __iomem *)ioremap(magic_map.phys, magic_map.size);
++
++      if (!magic_map.virt) {
++              printk("Failed to ioremap flash.\n");
++              return -EIO;
++      }
++
++      simple_map_init(&magic_map);
++
++      flash = do_map_probe("cfi_probe", &magic_map);
++      if (flash) {
++              flash->owner = THIS_MODULE;
++              add_mtd_partitions(flash, magic_partitions,
++                                      ARRAY_SIZE(magic_partitions));
++      } else {
++              printk("map probe failed for flash\n");
++              return -ENXIO;
++      }
++
++      return 0;
++}
++
++static void __exit cleanup_magic(void)
++{
++      if (flash) {
++              del_mtd_partitions(flash);
++              map_destroy(flash);
++      }
++
++      if (magic_map.virt) {
++              iounmap((void *)magic_map.virt);
++              magic_map.virt = NULL;
++      }
++}
++
++module_init(init_magic);
++module_exit(cleanup_magic);
++
++MODULE_LICENSE("GPL");
++MODULE_AUTHOR("Karol Lewandowski");
++MODULE_DESCRIPTION("MTD map and partitions for IBM 405EP MagicBox boards");
+diff -Nur linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17-owrt/drivers/mtd/maps/Makefile
+--- linux-2.6.17/drivers/mtd/maps/Makefile     2006-06-18 03:49:35.000000000 +0200
++++ linux-2.6.17-owrt/drivers/mtd/maps/Makefile        2006-08-25 23:33:05.000000000 +0200
+@@ -58,6 +58,7 @@
+ obj-$(CONFIG_MTD_BEECH)               += beech-mtd.o
+ obj-$(CONFIG_MTD_ARCTIC)      += arctic-mtd.o
+ obj-$(CONFIG_MTD_WALNUT)        += walnut.o
++obj-$(CONFIG_MTD_MAGICMAP)      += magicmap.o
+ obj-$(CONFIG_MTD_H720X)               += h720x-flash.o
+ obj-$(CONFIG_MTD_SBC8240)     += sbc8240.o
+ obj-$(CONFIG_MTD_NOR_TOTO)    += omap-toto-flash.o
+