busybox: nslookup_lede: fix compatibility with v1.25
authorJo-Philipp Wich <jo@mein.io>
Tue, 25 Apr 2017 12:03:11 +0000 (14:03 +0200)
committerJo-Philipp Wich <jo@mein.io>
Thu, 27 Apr 2017 13:31:07 +0000 (15:31 +0200)
The ":*" optstring syntax was only recently introduced with BusyBox v1.26,
older versions need a corresponding hint in the "opt_complementary" variable
to denote flag values that should be stored as llist entries.

Add the required opt_complementary entry to fix random SIGBUS, SIGILL or
SIGSEGV related crashes on BusyBox 1.25.x when attempting to use the "-q"
flag of the "nslookup_lede" applet.

Ref: https://forum.lede-project.org/t/nslookup-ipv6-in-lede-17-01-1

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/utils/busybox/Makefile
package/utils/busybox/patches/230-add_nslookup_lede.patch

index fdac78fcf65cd97b0a82e3a300bc23dcab159e2a..a593bc9e9a86b0bbd363900c7976a5e516ee556b 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.25.1
+PKG_VERSION:=1.25.2
 PKG_RELEASE:=3
 PKG_FLAGS:=essential
 
index 51034e6bc4390057f93e77ad7c0d60598220f9e9..f37f4bd8797b7b2ba46162f2daa5a50fdc3e736a 100644 (file)
@@ -1,4 +1,4 @@
-From 2285cd400a10b1bde5472fe1cec3311300ee943c Mon Sep 17 00:00:00 2001
+From 1188f159e0b0a9c07bed835c7313bedf5322a9e3 Mon Sep 17 00:00:00 2001
 From: Jo-Philipp Wich <jo@mein.io>
 Date: Tue, 14 Mar 2017 22:21:34 +0100
 Subject: [PATCH] networking: add LEDE nslookup applet
@@ -12,16 +12,16 @@ and the libresolv primitives to parse received DNS responses.
 
 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 ---
- networking/nslookup_lede.c | 893 +++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 893 insertions(+)
+ networking/nslookup_lede.c | 894 +++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 894 insertions(+)
  create mode 100644 networking/nslookup_lede.c
 
 diff --git a/networking/nslookup_lede.c b/networking/nslookup_lede.c
 new file mode 100644
-index 000000000..6f1f86502
+index 000000000..f3e42d3bb
 --- /dev/null
 +++ b/networking/nslookup_lede.c
-@@ -0,0 +1,893 @@
+@@ -0,0 +1,894 @@
 +/*
 + * nslookup_lede - musl compatible replacement for busybox nslookup
 + *
@@ -760,6 +760,7 @@ index 000000000..6f1f86502
 +      applet_long_options = nslookup_longopts;
 +#endif
 +
++      opt_complementary = "q::";
 +      opts = getopt32(argv, "+q:*p:+r:+t:+s",
 +                      &type_strings, &default_port,
 +                      &default_retry, &default_timeout);