kernel: Added required dependencies for socket match.
authorOldřich Jedlička <oldium.pro@gmail.com>
Tue, 29 Jan 2019 21:25:33 +0000 (22:25 +0100)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 24 Oct 2019 10:30:02 +0000 (10:30 +0000)
This applies to kernel 4.10 and newer.

See https://github.com/torvalds/linux/commit/8db4c5be88f62ffd7a552f70687a10c614dc697b

The above commit added to kernel 4.10 added new dependency
for building the NETFILTER_XT_MATCH_SOCKET (xt_socket.ko)
module. The NF_SOCKET_IPVx options (both of them) need to
be enabled in order to build the NETFILTER_XT_MATCH_SOCKET
module. Without the change the module is not built.

Signed-off-by: Oldřich Jedlička <oldium.pro@gmail.com>
(cherry picked from commit 66e875a07033cdcfd8c4a16940d4acfe63c60202)
(required for fixing FS#2531)
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/kernel/linux/modules/netfilter.mk

index 3a989104d776f833889de718c8dd48de927b8261..f2e10682b40edb0d0656a74f5dae6db9feb8a9af 100644 (file)
@@ -554,6 +554,8 @@ define KernelPackage/ipt-tproxy
   TITLE:=Transparent proxying support
   DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
   KCONFIG:= \
   TITLE:=Transparent proxying support
   DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
   KCONFIG:= \
+       CONFIG_NF_SOCKET_IPV4 \
+       CONFIG_NF_SOCKET_IPV6 \
        CONFIG_NETFILTER_XT_MATCH_SOCKET \
        CONFIG_NETFILTER_XT_TARGET_TPROXY
   FILES:= \
        CONFIG_NETFILTER_XT_MATCH_SOCKET \
        CONFIG_NETFILTER_XT_TARGET_TPROXY
   FILES:= \