mvebu: align device names to vendor_device format
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Sat, 11 May 2019 17:37:33 +0000 (19:37 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 11 May 2019 21:11:04 +0000 (23:11 +0200)
Add vendors in device names and also rename few device names, for easier
identyfying potential firmware to flash. The vendor and device string is
mainly derived from model/compatipble string in dts from particular
device, but since not all devices are well described, some of the renames
follow marketing names.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
package/boot/uboot-mvebu/Makefile
target/linux/mvebu/image/Makefile
target/linux/mvebu/image/cortex-a53.mk
target/linux/mvebu/image/cortex-a72.mk
target/linux/mvebu/image/cortex-a9.mk

index 61547acb27cf9e9ae1e5a4f2e08f846f44d25129..c24bfe3ff0c3644260e982eac3d412386a18a668 100644 (file)
@@ -24,7 +24,7 @@ endef
 
 define U-Boot/clearfog
   NAME:=SolidRun ClearFog A1
 
 define U-Boot/clearfog
   NAME:=SolidRun ClearFog A1
-  BUILD_DEVICES:=armada-388-clearfog-base armada-388-clearfog-pro
+  BUILD_DEVICES:=solidrun_clearfog-base-a1 solidrun_clearfog-pro-a1
   BUILD_SUBTARGET:=cortexa9
   UBOOT_IMAGE:=u-boot-spl.kwb
 endef
   BUILD_SUBTARGET:=cortexa9
   UBOOT_IMAGE:=u-boot-spl.kwb
 endef
index 9084b3e02818f79bbc3f1b3bf0a51ae600bf29c7..f432a37911983db3d12e4f5554cdb92f56322353 100644 (file)
@@ -70,7 +70,6 @@ endef
 
 define Device/Default
   PROFILES := Default
 
 define Device/Default
   PROFILES := Default
-  DEVICE_DTS := $(1)
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | append-dtb | uImage none
index a102f52481986a8bbc93a76f4e736c19c6de2d34..5a3e9b4d077a736298096ba11788dd9445fbcff3 100644 (file)
@@ -1,19 +1,19 @@
 ifeq ($(SUBTARGET),cortexa53)
 
 ifeq ($(SUBTARGET),cortexa53)
 
-define Device/globalscale-espressobin
+define Device/globalscale_espressobin
   $(call Device/Default-arm64)
   DEVICE_TITLE := ESPRESSObin (Marvell Armada 3700 Community Board)
   DEVICE_DTS := armada-3720-espressobin
   SUPPORTED_DEVICES := globalscale,espressobin
 endef
   $(call Device/Default-arm64)
   DEVICE_TITLE := ESPRESSObin (Marvell Armada 3700 Community Board)
   DEVICE_DTS := armada-3720-espressobin
   SUPPORTED_DEVICES := globalscale,espressobin
 endef
-TARGET_DEVICES += globalscale-espressobin
+TARGET_DEVICES += globalscale_espressobin
 
 
-define Device/armada-3720-db
+define Device/marvell_armada-3720-db
   $(call Device/Default-arm64)
   DEVICE_TITLE := Marvell Armada 3720 Development Board DB-88F3720-DDR3
   DEVICE_DTS := armada-3720-db
   SUPPORTED_DEVICES := marvell,armada-3720-db
 endef
   $(call Device/Default-arm64)
   DEVICE_TITLE := Marvell Armada 3720 Development Board DB-88F3720-DDR3
   DEVICE_DTS := armada-3720-db
   SUPPORTED_DEVICES := marvell,armada-3720-db
 endef
-TARGET_DEVICES += armada-3720-db
+TARGET_DEVICES += marvell_armada-3720-db
 
 endif
 
 endif
index 824f6b5d0fb2ece976c9f0c619893736f6082c30..b1069b1f0b5ac6683d5120742c21e083855f1d3e 100644 (file)
@@ -1,30 +1,30 @@
 ifeq ($(SUBTARGET),cortexa72)
 
 ifeq ($(SUBTARGET),cortexa72)
 
-define Device/armada-macchiatobin
+define Device/marvell_macchiatobin
   $(call Device/Default-arm64)
   DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
   DEVICE_PACKAGES += kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
   DEVICE_DTS := armada-8040-mcbin
   SUPPORTED_DEVICES := marvell,armada8040-mcbin
 endef
   $(call Device/Default-arm64)
   DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
   DEVICE_PACKAGES += kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
   DEVICE_DTS := armada-8040-mcbin
   SUPPORTED_DEVICES := marvell,armada8040-mcbin
 endef
-TARGET_DEVICES += armada-macchiatobin
+TARGET_DEVICES += marvell_macchiatobin
 
 
-define Device/armada-8040-db
+define Device/marvell_armada8040-db
   $(call Device/Default-arm64)
   DEVICE_TITLE := Marvell Armada 8040 DB board
   DEVICE_DTS := armada-8040-db
   IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
   SUPPORTED_DEVICES := marvell,armada8040-db
 endef
   $(call Device/Default-arm64)
   DEVICE_TITLE := Marvell Armada 8040 DB board
   DEVICE_DTS := armada-8040-db
   IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
   SUPPORTED_DEVICES := marvell,armada8040-db
 endef
-TARGET_DEVICES += armada-8040-db
+TARGET_DEVICES += marvell_armada8040-db
 
 
-define Device/armada-7040-db
+define Device/marvell_armada7040-db
   $(call Device/Default-arm64)
   DEVICE_TITLE := Marvell Armada 7040 DB board
   DEVICE_DTS := armada-7040-db
   IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
   SUPPORTED_DEVICES := marvell,armada7040-db
 endef
   $(call Device/Default-arm64)
   DEVICE_TITLE := Marvell Armada 7040 DB board
   DEVICE_DTS := armada-7040-db
   IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
   SUPPORTED_DEVICES := marvell,armada7040-db
 endef
-TARGET_DEVICES += armada-7040-db
+TARGET_DEVICES += marvell_armada7040-db
 
 endif
 
 endif
index 252300b942368c1fb6ec367a8f5af47f0a3c4f33..baaeb8ddb6af48f76f2e33401092b8daed49d2e3 100644 (file)
@@ -16,102 +16,108 @@ define Device/linksys
   KERNEL_SIZE := 6144k
 endef
 
   KERNEL_SIZE := 6144k
 endef
 
-define Device/linksys-wrt1200ac
+define Device/linksys_wrt1200ac
   $(call Device/linksys,WRT1200AC (Caiman))
   DEVICE_DTS := armada-385-linksys-caiman
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
   $(call Device/linksys,WRT1200AC (Caiman))
   DEVICE_DTS := armada-385-linksys-caiman
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
-TARGET_DEVICES += linksys-wrt1200ac
+TARGET_DEVICES += linksys_wrt1200ac
 
 
-define Device/linksys-wrt1900acv2
+define Device/linksys_wrt1900acv2
   $(call Device/linksys,WRT1900ACv2 (Cobra))
   DEVICE_DTS := armada-385-linksys-cobra
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
   $(call Device/linksys,WRT1900ACv2 (Cobra))
   DEVICE_DTS := armada-385-linksys-cobra
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
-TARGET_DEVICES += linksys-wrt1900acv2
+TARGET_DEVICES += linksys_wrt1900acv2
 
 
-define Device/linksys-wrt3200acm
+define Device/linksys_wrt3200acm
   $(call Device/linksys,WRT3200ACM (Rango))
   DEVICE_DTS := armada-385-linksys-rango
   DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
 endef
   $(call Device/linksys,WRT3200ACM (Rango))
   DEVICE_DTS := armada-385-linksys-rango
   DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
 endef
-TARGET_DEVICES += linksys-wrt3200acm
+TARGET_DEVICES += linksys_wrt3200acm
 
 
-define Device/linksys-wrt1900acs
+define Device/linksys_wrt1900acs
   $(call Device/linksys,WRT1900ACS (Shelby))
   DEVICE_DTS := armada-385-linksys-shelby
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
   $(call Device/linksys,WRT1900ACS (Shelby))
   DEVICE_DTS := armada-385-linksys-shelby
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
-TARGET_DEVICES += linksys-wrt1900acs
+TARGET_DEVICES += linksys_wrt1900acs
 
 
-define Device/linksys-wrt32x
+define Device/linksys_wrt32x
   $(call Device/linksys,WRT32X (Venom))
   DEVICE_DTS := armada-385-linksys-venom
   DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
   KERNEL_SIZE := 3072k
   KERNEL := kernel-bin | append-dtb
 endef
   $(call Device/linksys,WRT32X (Venom))
   DEVICE_DTS := armada-385-linksys-venom
   DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
   KERNEL_SIZE := 3072k
   KERNEL := kernel-bin | append-dtb
 endef
-TARGET_DEVICES += linksys-wrt32x
+TARGET_DEVICES += linksys_wrt32x
 
 
-define Device/linksys-wrt1900ac
+define Device/linksys_wrt1900ac
   $(call Device/linksys,WRT1900AC (Mamba))
   DEVICE_DTS := armada-xp-linksys-mamba
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
   KERNEL_SIZE := 3072k
 endef
   $(call Device/linksys,WRT1900AC (Mamba))
   DEVICE_DTS := armada-xp-linksys-mamba
   DEVICE_PACKAGES += mwlwifi-firmware-88w8864
   KERNEL_SIZE := 3072k
 endef
-TARGET_DEVICES += linksys-wrt1900ac
+TARGET_DEVICES += linksys_wrt1900ac
 
 
-define Device/openblocks-ax3-4
+define Device/plathome_openblocks-ax3-4
   DEVICE_DTS := armada-xp-openblocks-ax3-4
   DEVICE_DTS := armada-xp-openblocks-ax3-4
-  SUPPORTED_DEVICES := $(1)
+  SUPPORTED_DEVICES := openblocks-ax3-4
   BLOCKSIZE := 128k
   PAGESIZE := 1
   IMAGES += factory.img
   IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
   BLOCKSIZE := 128k
   PAGESIZE := 1
   IMAGES += factory.img
   IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
-TARGET_DEVICES += openblocks-ax3-4
+TARGET_DEVICES += plathome_openblocks-ax3-4
 
 
-define Device/armada-385-db-ap
+define Device/marvell_a385-db-ap
   $(Device/NAND-256K)
   $(Device/NAND-256K)
+  DEVICE_DTS := armada-385-db-ap
   IMAGES += factory.img
   KERNEL_SIZE := 8192k
   DEVICE_TITLE := Marvell Armada 385 DB AP (DB-88F6820-AP)
 endef
   IMAGES += factory.img
   KERNEL_SIZE := 8192k
   DEVICE_TITLE := Marvell Armada 385 DB AP (DB-88F6820-AP)
 endef
-TARGET_DEVICES += armada-385-db-ap
+TARGET_DEVICES += marvell_a385-db-ap
 
 
-define Device/armada-370-db
+define Device/marvell_a370-db
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada 370 DB (DB-88F6710-BP-DDR3)
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada 370 DB (DB-88F6710-BP-DDR3)
+  DEVICE_DTS := armada-370-db
 endef
 endef
-TARGET_DEVICES += armada-370-db
+TARGET_DEVICES += marvell_a370-db
 
 
-define Device/armada-370-rd
+define Device/marvell_a370-rd
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada 370 RD (RD-88F6710-A1)
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada 370 RD (RD-88F6710-A1)
+  DEVICE_DTS := armada-370-rd
 endef
 endef
-TARGET_DEVICES += armada-370-rd
+TARGET_DEVICES += marvell_a370-rd
 
 
-define Device/armada-xp-db
+define Device/marvell_axp-db
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada XP DB (DB-78460-BP)
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada XP DB (DB-78460-BP)
+  DEVICE_DTS := armada-xp-db
 endef
 endef
-TARGET_DEVICES += armada-xp-db
+TARGET_DEVICES += marvell_axp-db
 
 
-define Device/armada-xp-gp
+define Device/marvell_axp-gp
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada XP GP (DB-MV784MP-GP)
   $(Device/NAND-512K)
   DEVICE_TITLE := Marvell Armada XP GP (DB-MV784MP-GP)
+  DEVICE_DTS := armada-xp-gp
 endef
 endef
-TARGET_DEVICES += armada-xp-gp
+TARGET_DEVICES += marvell_axp-gp
 
 
-define Device/armada-388-rd
+define Device/marvell_a388-rd
   DEVICE_TITLE := Marvell Armada 388 RD (RD-88F6820-AP)
   DEVICE_TITLE := Marvell Armada 388 RD (RD-88F6820-AP)
+  DEVICE_DTS := armada-388-rd
   IMAGES := firmware.bin
   IMAGE/firmware.bin := append-kernel | pad-to 256k | append-rootfs | pad-rootfs
 endef
   IMAGES := firmware.bin
   IMAGE/firmware.bin := append-kernel | pad-to 256k | append-rootfs | pad-rootfs
 endef
-TARGET_DEVICES += armada-388-rd
+TARGET_DEVICES += marvell_a388-rd
 
 
-define Device/armada-388-clearfog-pro
+define Device/solidrun_clearfog-pro-a1
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin
   DEVICE_TITLE := SolidRun ClearFog Pro
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin
   DEVICE_TITLE := SolidRun ClearFog Pro
@@ -123,9 +129,9 @@ define Device/armada-388-clearfog-pro
   UBOOT := clearfog-u-boot-spl.kwb
   BOOT_SCRIPT := clearfog
 endef
   UBOOT := clearfog-u-boot-spl.kwb
   BOOT_SCRIPT := clearfog
 endef
-TARGET_DEVICES += armada-388-clearfog-pro
+TARGET_DEVICES += solidrun_clearfog-pro-a1
 
 
-define Device/armada-388-clearfog-base
+define Device/solidrun_clearfog-base-a1
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin
   DEVICE_TITLE := SolidRun ClearFog Base
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin
   DEVICE_TITLE := SolidRun ClearFog Base
@@ -136,17 +142,17 @@ define Device/armada-388-clearfog-base
   UBOOT := clearfog-u-boot-spl.kwb
   BOOT_SCRIPT := clearfog
 endef
   UBOOT := clearfog-u-boot-spl.kwb
   BOOT_SCRIPT := clearfog
 endef
-TARGET_DEVICES += armada-388-clearfog-base
+TARGET_DEVICES += solidrun_clearfog-base-a1
 
 
-define Device/globalscale-mirabox
+define Device/globalscale_mirabox
   $(Device/NAND-512K)
   DEVICE_DTS := armada-370-mirabox
   SUPPORTED_DEVICES := mirabox
   DEVICE_TITLE := Globalscale Mirabox
 endef
   $(Device/NAND-512K)
   DEVICE_DTS := armada-370-mirabox
   SUPPORTED_DEVICES := mirabox
   DEVICE_TITLE := Globalscale Mirabox
 endef
-TARGET_DEVICES += globalscale-mirabox
+TARGET_DEVICES += globalscale_mirabox
 
 
-define Device/turris-omnia
+define Device/cznic_turris-omnia
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin
   KERNEL_INITRAMFS := kernel-bin
   KERNEL_INSTALL := 1
   KERNEL := kernel-bin
   KERNEL_INITRAMFS := kernel-bin
@@ -161,6 +167,6 @@ define Device/turris-omnia
   IMAGE_NAME = $$(2)
   DEVICE_DTS := armada-385-turris-omnia
 endef
   IMAGE_NAME = $$(2)
   DEVICE_DTS := armada-385-turris-omnia
 endef
-TARGET_DEVICES += turris-omnia
+TARGET_DEVICES += cznic_turris-omnia
 
 endif
 
 endif