ar71xx:add support for E750G v8
author张鹏 <sd20@qxwlan.com>
Tue, 17 Jul 2018 10:14:25 +0000 (18:14 +0800)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 12:02:41 +0000 (14:02 +0200)
Qxwlan E750G v8 is based on Qualcomm QCA9344.

Specification:

 - 560/450/225 MHz (CPU/DDR/AHB)
 - 128 MB of RAM (DDR2)
 - 8/16 MB of FLASH (SPI NOR)
 - 2T2R 2.4G GHz (AR9344)
 - 2x 10/100 Mbps Ethernet (PoE support)
 - 2x 10/100/1000 Mbps Ethernet
 - 7x LED (6 driven by GPIO)
 - 1x button (reset)
 - 1x DC jack for main power input (9-48 V)
 - UART (J23) and LEDs (J2) headers on PCB

Flash instruction (using U-Boot CLI and tftp server):

 - Configure PC with static IP 192.168.1.10 and tftp server.
 - Rename "sysupgrade" filename to "firmware.bin" and place it in tftp
   server directory.
 - Connect PC with one of RJ45 ports, power up the board and press
   "enter" key to access U-Boot CLI.
 - Use the following command to update the device to OpenWrt: "run lfw".

Flash instruction (using U-Boot web-based recovery):

 - Configure PC with static IP 192.168.1.xxx(2-254)/24.
 - Connect PC with one of RJ45 ports, press the reset button, power up
   the board and keep button pressed for around 6-7 seconds, until LEDs
   start flashing.
 - Open your browser and enter 192.168.1.1, select "sysupgrade" image
   and click the upgrade button.

Signed-off-by: 张鹏 <sd20@qxwlan.com>
(cherry picked from commit 53a45020135b504cb4bee0fa8d98c8eaf6391066)

12 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-e750g-v8.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/generic/config-default
target/linux/ar71xx/image/generic.mk

index 3b986c3403ed93d9c575440ab476301ee388879c..858d6750082ecacefc00a8d6cfce0b264c8e06bd 100755 (executable)
@@ -67,7 +67,7 @@ cpe870|\
 dr531|\
 e600g-v2|\
 e600gac-v2|\
-e750a-v2)
+e750a-v4)
        ucidef_set_led_netdev "lan" "LAN" "$board:green:lan" "eth0"
        ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
 
@@ -373,7 +373,8 @@ e1700ac-v2)
        ucidef_set_led_usbdev "usb" "USB" "$board:green:usb" "1-1"
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "$board:green:wlan2g" "phy1tpt"
        ;;
-e558-v2)
+e558-v2|\
+e750g-v8)
        ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
        ;;
 esr900)
index 9d8c1f2214e2fae0cff513d4735b82c9f586ef52..b0076366bc505d578f2daa7b83987f788dbda2f4 100755 (executable)
@@ -380,6 +380,7 @@ ar71xx_setup_interfaces()
                ucidef_add_switch_attr "switch0" "enable" "false"
                ;;
        e1700ac-v2|\
+       e750g-v8|\
        unifiac-pro|\
        xd3200)
                ucidef_add_switch "switch0" \
index 98d58987ca24f4ccc36782b8325a79ebd71b77de..4eb2abb26ca2676576babb14eb1baa38a2f0de2b 100644 (file)
@@ -27,6 +27,7 @@ get_status_led() {
        e558-v2|\
        e600gac-v2|\
        e750a-v4|\
+       e750g-v8|\
        eap120|\
        minibox-v1|\
        packet-squirrel|\
index fb7328875f2ddc8b2e797b1fc751ac820bcd21a0..3af2eee2bd5f28dd1b1ffd2f212f79ff392b811a 100755 (executable)
@@ -687,6 +687,9 @@ ar71xx_board_detect() {
        *"E750A v4")
                name="e750a-v4"
                ;;
+       *"E750G v8")
+               name="e750g-v8"
+               ;;
        *"EAP120")
                name="eap120"
                tplink_pharos_board_detect "$(tplink_pharos_get_model_string | tr -d '\r')"
index f171aa667c6ed50fdd0e8a4c2f2e94c7b9d4b8a7..ca1270b7fdc84c53f8417c226f18ca4fff1f27d8 100755 (executable)
@@ -254,6 +254,7 @@ platform_check_image() {
        e600g-v2|\
        e600gac-v2|\
        e750a-v4|\
+       e750g-v8|\
        ebr-2310-c1|\
        ens202ext|\
        epg5000|\
index 70111e2eb194976e28225b1f47182da501e182b1..8aa0b41ae961d2aa34513b7456520265f14ef5b5 100644 (file)
@@ -104,6 +104,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_E558_V2 is not set
 # CONFIG_ATH79_MACH_E600G_V2 is not set
 # CONFIG_ATH79_MACH_E750A_V4 is not set
+# CONFIG_ATH79_MACH_E750G_V8 is not set
 # CONFIG_ATH79_MACH_EAP120 is not set
 # CONFIG_ATH79_MACH_EAP300V2 is not set
 # CONFIG_ATH79_MACH_EAP7660D is not set
index 14cd19f1f24b64f4aa1e908d84a365b356cffbf9..e7655b3c026ca8d3367b48c14f7263267c923008 100644 (file)
@@ -744,6 +744,17 @@ config ATH79_MACH_E750A_V4
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_E750G_V8
+       bool "Qxwlan E750G v8 support"
+       select SOC_AR934X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_ESR900
        bool "EnGenius ESR900 board support"
        select SOC_QCA955X
index 84b61dff9cd94e459286caf27832a47471706b44..8800a7de1020062cbf4f25cf507ed9b1fbe78da0 100644 (file)
@@ -115,6 +115,7 @@ obj-$(CONFIG_ATH79_MACH_E1700AC_V2)         += mach-e1700ac-v2.o
 obj-$(CONFIG_ATH79_MACH_E558_V2)               += mach-e558-v2.o
 obj-$(CONFIG_ATH79_MACH_E600G_V2)              += mach-e600g-v2.o
 obj-$(CONFIG_ATH79_MACH_E750A_V4)              += mach-e750a-v4.o
+obj-$(CONFIG_ATH79_MACH_E750G_V8)              += mach-e750g-v8.o
 obj-$(CONFIG_ATH79_MACH_EAP120)                        += mach-eap120.o
 obj-$(CONFIG_ATH79_MACH_EAP300V2)              += mach-eap300v2.o
 obj-$(CONFIG_ATH79_MACH_EAP7660D)              += mach-eap7660d.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-e750g-v8.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-e750g-v8.c
new file mode 100644 (file)
index 0000000..72d1349
--- /dev/null
@@ -0,0 +1,151 @@
+/*
+ *  Qxwlan E750G v8 board support
+ *
+ *  Copyright (C) 2017 Peng Zhang <sd20@qxwlan.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/phy.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-usb.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define E750G_V8_GPIO_LED_SYS  14
+#define E750G_V8_GPIO_LED_DS20 15
+#define E750G_V8_GPIO_LED_DS10 20
+#define E750G_V8_GPIO_LED_WLAN 21
+
+#define E750G_V8_GPIO_BTN_RESET        12
+
+#define E750G_V8_KEYS_POLL_INTERVAL    20      /* msecs */
+#define E750G_V8_KEYS_DEBOUNCE_INTERVAL        (3 * E750G_V8_KEYS_POLL_INTERVAL)
+
+static struct gpio_led e750g_v8_leds_gpio[] __initdata = {
+       {
+               .name           = "e750g-v8:green:system",
+               .gpio           = E750G_V8_GPIO_LED_SYS,
+               .active_low     = 1,
+       },
+       {
+               .name           = "e750g-v8:green:ds10",
+               .gpio           = E750G_V8_GPIO_LED_DS10,
+               .active_low     = 1,
+       },
+       {
+               .name           = "e750g-v8:green:ds20",
+               .gpio           = E750G_V8_GPIO_LED_DS20,
+               .active_low     = 1,
+       },
+       {
+               .name           = "e750g-v8:green:wlan",
+               .gpio           = E750G_V8_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button e750g_v8_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = E750G_V8_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = E750G_V8_GPIO_BTN_RESET,
+               .active_low     = 1,
+       },
+};
+
+static const struct ar8327_led_info e750g_v8_leds_qca8334[] = {
+       AR8327_LED_INFO(PHY1_0, HW, "e750g-v8:green:lan"),
+       AR8327_LED_INFO(PHY2_0, HW, "e750g-v8:green:wan"),
+};
+
+static struct ar8327_pad_cfg e750g_v8_ar8327_pad0_cfg = {
+       .mode = AR8327_PAD_MAC_RGMII,
+       .txclk_delay_en = true,
+       .rxclk_delay_en = true,
+       .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+       .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+       .mac06_exchange_dis = true,
+};
+
+static struct ar8327_led_cfg e750g_v8_ar8327_led_cfg = {
+       .led_ctrl0 = 0x00000000,
+       .led_ctrl1 = 0xc737c737,
+       .led_ctrl2 = 0x00000000,
+       .led_ctrl3 = 0x00c30c00,
+       .open_drain = true,
+};
+
+static struct ar8327_platform_data e750g_v8_ar8327_data = {
+       .pad0_cfg = &e750g_v8_ar8327_pad0_cfg,
+       .port0_cfg = {
+               .force_link = 1,
+               .speed = AR8327_PORT_SPEED_1000,
+               .duplex = 1,
+               .txpause = 1,
+               .rxpause = 1,
+       },
+       .led_cfg = &e750g_v8_ar8327_led_cfg,
+       .leds = e750g_v8_leds_qca8334,
+       .num_leds = ARRAY_SIZE(e750g_v8_leds_qca8334),
+};
+
+static struct mdio_board_info e750g_v8_mdio0_info[] = {
+       {
+               .bus_id = "ag71xx-mdio.0",
+               .phy_addr = 0,
+               .platform_data = &e750g_v8_ar8327_data,
+       },
+};
+
+static void __init e750g_v8_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f050400);
+       u8 *art = (u8 *) KSEG1ADDR(0x1f061000);
+
+       ath79_register_m25p80(NULL);
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(e750g_v8_leds_gpio),
+                                e750g_v8_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, E750G_V8_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(e750g_v8_gpio_keys),
+                                       e750g_v8_gpio_keys);
+
+       mdiobus_register_board_info(e750g_v8_mdio0_info,
+                                       ARRAY_SIZE(e750g_v8_mdio0_info));
+
+       ath79_register_mdio(0, 0x0);
+       ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0 |
+                                  AR934X_ETH_CFG_SW_ONLY_MODE);
+
+       /* GMAC0 is connected to an AR8327 switch */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth0_data.phy_mask = BIT(0);
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+       ath79_eth0_pll_data.pll_1000 = 0x06000000;
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+       ath79_register_eth(0);
+
+       ath79_register_pci();
+       ath79_register_usb();
+       ath79_register_wmac(art, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_E750G_V8, "E750G-V8", "Qxwlan E750G v8",
+               e750g_v8_setup);
index c33c02037d9e7d02c49625d463f2016f1e1ea2b6..390ec0b2c38d9af99e215f75009eed9b2e4c0b01 100644 (file)
@@ -109,6 +109,7 @@ enum ath79_mach_type {
        ATH79_MACH_E600G_V2,                    /* Qxwlan E600G v2 */
        ATH79_MACH_E600GAC_V2,                  /* Qxwlan E600GAC v2 */
        ATH79_MACH_E750A_V4,                    /* Qxwlan E750A v4 */
+       ATH79_MACH_E750G_V8,                    /* Qxwlan E750G v8 */
        ATH79_MACH_EAP120,                      /* TP-LINK EAP120 */
        ATH79_MACH_EAP300V2,                    /* EnGenius EAP300 v2 */
        ATH79_MACH_EAP7660D,                    /* Senao EAP7660D */
index 2f9e1b700d8e4d02cf1fa8cb1e858cd2a2c68216..da331d38db7acc5a46f84201410afb13dde3fdae 100644 (file)
@@ -77,6 +77,7 @@ CONFIG_ATH79_MACH_E2100L=y
 CONFIG_ATH79_MACH_E558_V2=y
 CONFIG_ATH79_MACH_E600G_V2=y
 CONFIG_ATH79_MACH_E750A_V4=y
+CONFIG_ATH79_MACH_E750G_V8=y
 CONFIG_ATH79_MACH_EAP120=y
 CONFIG_ATH79_MACH_EAP300V2=y
 CONFIG_ATH79_MACH_EAP7660D=y
index ba7374ecc3530299def6edf9589563ff70c975d6..640557532c8a02f37bc6f84ade8cb34e7172162d 100644 (file)
@@ -411,6 +411,25 @@ define Device/e750a-v4-8M
 endef
 TARGET_DEVICES += e750a-v4-8M
 
+define Device/e750g-v8-16M
+  DEVICE_TITLE := Qxwlan E750G v8 (16MB flash)
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+  BOARDNAME := E750G-V8
+  SUPPORTED_DEVICES := e750g-v8
+  IMAGE_SIZE := 15936k
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e750g-v8-16M
+
+define Device/e750g-v8-8M
+  $(Device/e750g-v8-16M)
+  DEVICE_TITLE := Qxwlan E750G v8 (8MB flash)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e750g-v8-8M
+
 define Device/ew-balin
   DEVICE_TITLE := Embedded Wireless Balin Platform
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea