shat from Georg Lukas
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 2 May 2005 12:46:32 +0000 (12:46 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 2 May 2005 12:46:32 +0000 (12:46 +0000)
SVN-Revision: 785

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/shat/Config.in [new file with mode: 0644]
openwrt/package/shat/Makefile [new file with mode: 0644]
openwrt/package/shat/shat.control [new file with mode: 0644]

index 835001c1abf7561f0d7d1255c44441a25274e6ce..cec59679d3f752af24e8020a88233924e7a33a00 100644 (file)
@@ -36,6 +36,7 @@ source "package/ez-ipupdate/Config.in"
 source "package/portmap/Config.in"
 source "package/nfs-server/Config.in"
 source "package/ser/Config.in"
 source "package/portmap/Config.in"
 source "package/nfs-server/Config.in"
 source "package/ser/Config.in"
+source "package/shat/Config.in"
 source "package/wol/Config.in"
 source "package/chillispot/Config.in"
 source "package/nocatsplash/Config.in"
 source "package/wol/Config.in"
 source "package/chillispot/Config.in"
 source "package/nocatsplash/Config.in"
index 7a2e9622494d254c664661826121cdc449be2500..5560d4c3a7142c2f4890727faa264ab1ab0c72c0 100644 (file)
@@ -58,6 +58,7 @@ package-$(BR2_PACKAGE_RADVD) += radvd
 package-$(BR2_PACKAGE_SDK) += sdk
 package-$(BR2_PACKAGE_SER) += ser
 package-$(BR2_PACKAGE_SETSERIAL) += setserial
 package-$(BR2_PACKAGE_SDK) += sdk
 package-$(BR2_PACKAGE_SER) += ser
 package-$(BR2_PACKAGE_SETSERIAL) += setserial
+package-$(BR2_PACKAGE_SHAT) += shat
 package-$(BR2_PACKAGE_SHFS) += shfs
 package-$(BR2_PACKAGE_SNORT) += snort
 package-$(BR2_PACKAGE_SPEEX) += speex
 package-$(BR2_PACKAGE_SHFS) += shfs
 package-$(BR2_PACKAGE_SNORT) += snort
 package-$(BR2_PACKAGE_SPEEX) += speex
diff --git a/openwrt/package/shat/Config.in b/openwrt/package/shat/Config.in
new file mode 100644 (file)
index 0000000..a7d3887
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_SHAT
+       tristate "shat (Source Hardware Address Translation)"
+       default m if CONFIG_DEVEL
+       help
+               A tool which allows hosts with arbitrary IP configuration
+               to connect to the internet over a SHAT gateway.
diff --git a/openwrt/package/shat/Makefile b/openwrt/package/shat/Makefile
new file mode 100644 (file)
index 0000000..4b84505
--- /dev/null
@@ -0,0 +1,50 @@
+#############################################################
+#
+# shat
+#
+#############################################################
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=shat
+PKG_VERSION:=0.9.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=9784cbee03529e6dab5fda683233dc32
+PKG_SOURCE_URL:=http://world.maxina.de/src/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/src
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/shatd: $(PKG_BUILD_DIR)/.unpacked
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
+               CFLAGS="$(TARGET_CFLAGS) -Wall -I$(PKG_BUILD_DIR)/include/linux/include -I$(PKG_BUILD_DIR)/include -DVERSION=\\\"$(PKG_VERSION)\\\" -DDROP_NETBIOS"
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/shatd
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin
+       cp $(PKG_BUILD_DIR)/shatd $(PKG_IPK_DIR)/usr/sbin/
+       cp $(PKG_BUILD_DIR)/shatc $(PKG_IPK_DIR)/usr/sbin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/shat.list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/shat.list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/shat/shat.control b/openwrt/package/shat/shat.control
new file mode 100644 (file)
index 0000000..bbbf074
--- /dev/null
@@ -0,0 +1,8 @@
+Package: shat
+Priority: optional
+Section: net
+Version: 0.9.3-1
+Architecture: mipsel
+Maintainer: Georg Lukas <georg@boerde.de>
+Source: buildroot internal
+Description: Source Hardware Address Translation - a tool for "nomadic routing"