usign: Activate LTO compile option
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Oct 2019 21:38:53 +0000 (22:38 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 29 Nov 2019 23:18:50 +0000 (00:18 +0100)
This decreases the size of the usign application by 16% on MIPS BE.

old:
24,597 /usr/bin/usign

new:
20,501 /usr/bin/usign

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 6ffd8a8f92ab5337ab967ab2922d7de7f0480bc9)

package/system/usign/Makefile

index a2c97a8d7ccc72b4c9e9057ff881f2599b6aff12..b27282698f9644fff04000484224276ef0a1a3b3 100644 (file)
@@ -30,6 +30,9 @@ define Package/usign
   TITLE:=OpenWrt signature verification utility
 endef
 
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto=jobserver
+
 CMAKE_OPTIONS += \
        -DUSE_LIBUBOX=on