ar71xx: change image version for ubiquiti devices
authorMatthias Fritzsche <txt.file@txtfile.eu>
Wed, 17 May 2017 03:44:49 +0000 (05:44 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 25 May 2017 07:22:37 +0000 (09:22 +0200)
changes the image version from hardcoded OpenWrt to
$VERSION_DIST. AirOS shows a notification with the image version
during a firmware upgrade.

fixes #582

Signed-off-by: Matthias Fritzsche <txt.file@txtfile.eu>
target/linux/ar71xx/image/ubnt.mk

index 84eaaaa9652d8d1799a466752a358988d8fd3553..62c8d457621c8c189efc8eff90868c68da6f877d 100644 (file)
@@ -6,7 +6,7 @@
 # routerboard creates partitions out of the ubnt header
 define Build/mkubntimage
        -$(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
+               -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
                -k $(IMAGE_KERNEL) \
                -r $@ \
                -o $@
@@ -19,7 +19,7 @@ define Build/mkubntimage-split
        dd if=$@ of=$@.old1 bs=1024k count=1; \
        dd if=$@ of=$@.old2 bs=1024k skip=1; \
        $(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
+               -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
                -k $@.old1 \
                -r $@.old2 \
                -o $@; \
@@ -28,7 +28,7 @@ endef
 
 define Build/mkubntimage2
        -$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
-               -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
+               -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
                -p jffs2:0x50000:0xf60000:0:0:$@ \
                -o $@.new
        @mv $@.new $@