nasm: disable LTO, remove host specific workarounds
authorFelix Fietkau <nbd@nbd.name>
Tue, 10 Jul 2018 11:08:30 +0000 (13:08 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 10 Jul 2018 11:09:57 +0000 (13:09 +0200)
The recent build failures on various platforms were apparently caused by
the fact that LTO build support in the configure script does not check
if it has a suitable version of gcc and simply assumes that gcc-ar is
available and can be used for intermediate files.

Since we really don't need to build nasm with LTO, simply disable it and
keep the whole build more portable

Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/nasm/Makefile

index 31166358fd963ec01240bf8a4b97d65b7ce4cbc0..53b7848caf7409d191ec061451063c04ba8c305b 100644 (file)
@@ -19,17 +19,11 @@ include $(INCLUDE_DIR)/toolchain-build.mk
 HOST_CONFIGURE_ARGS+= \
                --target=$(REAL_GNU_TARGET_NAME) \
                --with-sysroot=$(TOOLCHAIN_DIR) \
-               --enable-lto \
+               --disable-lto \
                --disable-werror \
                --disable-gdb \
                $(SOFT_FLOAT_CONFIG_OPTION) \
 
-ifeq ($(HOST_OS),Darwin)
-       HOST_MAKE_FLAGS = \
-               AR=ar \
-               RANLIB=ranlib
-endif
-
 define Host/Prepare
        $(call Host/Prepare/Default)
        ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)