linux/modules: add ksmbd support for 5.15
authorRosen Penev <rosenp@gmail.com>
Thu, 19 May 2022 03:11:38 +0000 (20:11 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 May 2023 14:52:05 +0000 (16:52 +0200)
5.15 is the first version to come with ksmbd. Use it instead of the
module as the linux one is better maintained.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/kernel/linux/modules/fs.mk

index c3c56864b77e7ae271c94b0e2c6848ffe4723b1d..1dddebfed736986363149ba81d6fd3c6c45d91d3 100644 (file)
@@ -345,6 +345,43 @@ endef
 
 $(eval $(call KernelPackage,fs-jfs))
 
+
+define KernelPackage/fs-ksmbd
+  SUBMENU:=$(FS_MENU)
+  TITLE:=SMB kernel server support
+  DEPENDS:= \
+         +kmod-nls-base \
+         +kmod-nls-utf8 \
+         +kmod-crypto-md4 \
+          +kmod-crypto-md5 \
+         +kmod-crypto-hmac \
+         +kmod-crypto-ecb \
+         +kmod-crypto-des \
+         +kmod-crypto-sha256 \
+         +kmod-crypto-cmac \
+         +kmod-crypto-sha512 \
+         +kmod-crypto-aead \
+         +kmod-crypto-ccm \
+         +kmod-crypto-gcm \
+         +kmod-asn1-decoder \
+         +kmod-oid-registry \
+         +kmod-fs-smbfs-common
+  KCONFIG:= \
+       CONFIG_SMB_SERVER \
+       CONFIG_SMB_SERVER_SMBDIRECT=n \
+       CONFIG_SMB_SERVER_CHECK_CAP_NET_ADMIN=n \
+       CONFIG_SMB_SERVER_KERBEROS5=n
+  FILES:=$(LINUX_DIR)/fs/ksmbd/ksmbd.ko
+  AUTOLOAD:=$(call AutoLoad,41,ksmbd)
+endef
+
+define KernelPackage/fs-ksmbd/description
+ Kernel module for SMB kernel server support
+endef
+
+$(eval $(call KernelPackage,fs-ksmbd))
+
+
 define KernelPackage/fs-minix
   SUBMENU:=$(FS_MENU)
   TITLE:=Minix filesystem support