kernel: kmod-hwmon-tmp102: add dependency to kmod-thermal
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 13 Dec 2016 23:15:33 +0000 (00:15 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 13 Dec 2016 23:15:33 +0000 (00:15 +0100)
Depend on the kmod-thermal package when it is activated, this fixes
compile problems on some targets.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/hwmon.mk

index a6e5b225079c0790b73ea1f298100087eb084e25..0c52f03d0b791ef677da3f1c96d995bf1fdea211 100644 (file)
@@ -333,7 +333,7 @@ define KernelPackage/hwmon-tmp102
   KCONFIG:=CONFIG_SENSORS_TMP102
   FILES:=$(LINUX_DIR)/drivers/hwmon/tmp102.ko
   AUTOLOAD:=$(call AutoProbe,tmp102)
-  $(call AddDepends/hwmon,+kmod-i2c-core)
+  $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
 endef
 
 define KernelPackage/hwmon-tmp102/description