kernel: assume modules.builtin is always present
authorJonas Gorski <jogo@openwrt.org>
Sun, 5 Jul 2015 21:31:34 +0000 (21:31 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 5 Jul 2015 21:31:34 +0000 (21:31 +0000)
We do not support old kernel versions not generating modules.builtin
anymore, so assume it will always be present and check for modules
to be built in first.

This prevents old modules being packages up after changing the kernel
config to include them in the kernel without cleaning the kernel tree.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46182

include/kernel.mk

index 300da0d50b7df82f678cc447ebaf872aa9d63f2c..7a0a170c35f024088e40089afc40816225b4d772 100644 (file)
@@ -181,18 +181,14 @@ $(call KernelPackage/$(1)/config)
     ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
       define Package/kmod-$(1)/install
                  @for mod in $$(call version_filter,$$(FILES)); do \
     ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
       define Package/kmod-$(1)/install
                  @for mod in $$(call version_filter,$$(FILES)); do \
-                       if [ -e $$$$$$$$mod ]; then \
+                       if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
+                               echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
+                       elif [ -e $$$$$$$$mod ]; then \
                                mkdir -p $$(1)/$(MODULES_SUBDIR) ; \
                                $(CP) -L $$$$$$$$mod $$(1)/$(MODULES_SUBDIR)/ ; \
                                mkdir -p $$(1)/$(MODULES_SUBDIR) ; \
                                $(CP) -L $$$$$$$$mod $$(1)/$(MODULES_SUBDIR)/ ; \
-                       elif [ -e "$(LINUX_DIR)/modules.builtin" ]; then \
-                               if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \
-                                       echo "NOTICE: module '$$$$$$$$mod' is built-in."; \
-                               else \
-                                       echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
-                                       exit 1; \
-                               fi; \
                        else \
                        else \
-                               echo "WARNING: module '$$$$$$$$mod' missing and modules.builtin not available, assuming built-in." >&2; \
+                               echo "ERROR: module '$$$$$$$$mod' is missing." >&2; \
+                               exit 1; \
                        fi; \
                  done;
                  $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
                        fi; \
                  done;
                  $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))