patch: other tools might depend on this one
authorLuka Perkov <luka@openwrt.org>
Fri, 27 Sep 2013 12:49:34 +0000 (12:49 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 27 Sep 2013 12:49:34 +0000 (12:49 +0000)
Signed-off-by: Markus Stenberg <markus.stenberg@iki.fi>
SVN-Revision: 38236

tools/Makefile

index 6b846f8ef1504d5b742ee438963cac1b376c448e..b167a6054438eff8c7c41fda106d2e3c4c8f5ca8 100644 (file)
@@ -74,6 +74,10 @@ $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache
 tools-y += ccache
 endif
 
+# in case there is no patch tool on the host we need to make patch tool a
+# dependency for tools which have patches directory
+$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
+
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)