Add kernel package for the mv_cesa crypto module
authorLars-Peter Clausen <lars@metafoo.de>
Fri, 3 Sep 2010 01:03:22 +0000 (01:03 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Fri, 3 Sep 2010 01:03:22 +0000 (01:03 +0000)
SVN-Revision: 22877

target/linux/kirkwood/modules.mk [new file with mode: 0644]

diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
new file mode 100644 (file)
index 0000000..ed7fe88
--- /dev/null
@@ -0,0 +1,11 @@
+
+define KernelPackage/crypto-mv_cesa
+   TITLE:=Marvell crypto engine
+   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+   FILES:=$(LINUX_DIR)/crypto/mv_cesa.ko
+   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+   SUBMENU:=Cryptographic API modules
+   DEPENDS:=kmod-crypto-core
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))