mvebu: Switch to the generic mkuimage macro
authorImre Kaloz <kaloz@openwrt.org>
Wed, 14 Jan 2015 11:39:20 +0000 (11:39 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Wed, 14 Jan 2015 11:39:20 +0000 (11:39 +0000)
The mvebu image makefile define something almost identical to the generic
implementation found in include/image.mk.

Switch to this implementation.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
SVN-Revision: 43969

target/linux/mvebu/image/Makefile

index f265dc43d25d0163679533ec8b3b71ce7414eda6..6e00346fe29ae41ac32b77a60f76fb909053855d 100644 (file)
@@ -24,15 +24,12 @@ KDIR_TMP:=$(KDIR)/tmp
 
 UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
 
 
 UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
 
-define Image/Build/MkuImage
-       mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
-       -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
-endef
-
 define Image/Build/DTB
        cp $(KDIR)/zImage$(2) $(KDIR)/zImage$(2)-$(1);
        cat $(DTS_DIR)/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
 define Image/Build/DTB
        cp $(KDIR)/zImage$(2) $(KDIR)/zImage$(2)-$(1);
        cat $(DTS_DIR)/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
-       $(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
+       $(call Image/BuildKernel/MkuImage, \
+               none, $(LOADADDR), $(LOADADDR), \
+               $(KDIR)/zImage$(2)-$(1), $(KDIR)/uImage$(2)-$(1))
        cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
 endef
 
        cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
 endef