kernel: add kmod-lib-842
authorTony Butler <spudz76@gmail.com>
Wed, 7 Dec 2022 00:39:27 +0000 (16:39 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 28 Jan 2023 20:19:17 +0000 (21:19 +0100)
"842" is a compression scheme and this is the software implementation
which is too slow to really use beyond a proof of concept.  It can be
selected in ZRAM, ZSWAP, or `fs/pstore`, and is here for completeness.
In general you need a Power8 or better with 842-in-hardware for it to
be fast, but other 842-accelerators are emerging.

Signed-off-by: Tony Butler <spudz76@gmail.com>
package/kernel/linux/modules/lib.mk
target/linux/generic/config-5.15

index d4d44ad8f0ac87bea4f488040dbb4556547e25b9..299c5a8c3541fbf4bb5bda5b761fba2982009af9 100644 (file)
@@ -170,6 +170,28 @@ endef
 $(eval $(call KernelPackage,lib-lz4))
 
 
+define KernelPackage/lib-842
+  SUBMENU:=$(LIB_MENU)
+  TITLE:=842 support
+  DEPENDS:=+kmod-crypto-acompress +kmod-crypto-crc32
+  KCONFIG:= \
+       CONFIG_CRYPTO_842 \
+       CONFIG_842_COMPRESS \
+       CONFIG_842_DECOMPRESS
+  FILES:= \
+       $(LINUX_DIR)/crypto/842.ko \
+       $(LINUX_DIR)/lib/842/842_compress.ko \
+       $(LINUX_DIR)/lib/842/842_decompress.ko
+  AUTOLOAD:=$(call AutoProbe,842 842_compress 842_decompress)
+endef
+
+define KernelPackage/lib-842/description
+ Kernel module for 842 compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-842))
+
+
 define KernelPackage/lib-raid6
   SUBMENU:=$(LIB_MENU)
   TITLE:=RAID6 algorithm support
index 878a60e66bc6ae56b551a24d76e9da041c899644..bd27f74d73cc4e854e6051362fbe7eac6074c2a0 100644 (file)
@@ -7562,6 +7562,7 @@ CONFIG_ZONE_DMA=y
 # CONFIG_ZPA2326 is not set
 # CONFIG_ZPOOL is not set
 # CONFIG_ZRAM is not set
+# CONFIG_ZRAM_DEF_COMP_842 is not set
 # CONFIG_ZRAM_DEF_COMP_LZ4 is not set
 # CONFIG_ZRAM_DEF_COMP_LZ4HC is not set
 # CONFIG_ZRAM_DEF_COMP_LZO is not set