build: make Host/Install/Default use Host/Compile/Default with an extra argument
authorFelix Fietkau <nbd@nbd.name>
Thu, 9 Feb 2017 12:34:21 +0000 (13:34 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 13:24:59 +0000 (14:24 +0100)
Allows parallelizing compile steps that might be necessary during install

Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry picked from commit fe1e3622a271386ea0413c97d9884e9935e17f11)

include/host-build.mk

index b5f1a6bfa79f5a2a7b442506d72b6192191018a2..cb4d45e9c1ee08727106bd9e19fd1d1b58177cf3 100644 (file)
@@ -110,7 +110,7 @@ define Host/Compile
 endef
 
 define Host/Install/Default
-       $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Compile/Default,install)
 endef
 
 define Host/Install