Change pcre packaging
authorNicolas Thill <nico@openwrt.org>
Wed, 30 Mar 2005 22:14:48 +0000 (22:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 30 Mar 2005 22:14:48 +0000 (22:14 +0000)
SVN-Revision: 485

openwrt/package/pcre/Makefile
openwrt/package/pcre/ipkg/libpcre-dev/CONTROL/control [new file with mode: 0644]
openwrt/package/pcre/ipkg/libpcre/CONTROL/control [new file with mode: 0644]
openwrt/package/pcre/ipkg/rules [new file with mode: 0644]
openwrt/package/pcre/ipkg/version [new file with mode: 0644]
openwrt/package/pcre/pcre-5.0-3.diff [deleted file]

index 31be6b894c9a01ff59ddc24c19288ec09655410d..d68f5f171a1b834e47d0ff0f571f13736f190569 100644 (file)
@@ -22,15 +22,15 @@ $(DL_DIR)/$(PKG_SOURCE_FILE):
 $(PKG_BUILD_DIR)/ipkg/rules: $(DL_DIR)/$(PKG_SOURCE_FILE)
        mkdir -p $(TOOL_BUILD_DIR)
        $(PKG_SOURCE_CAT) $(DL_DIR)/$(PKG_SOURCE_FILE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) . $(PKG_NAME)-\*.diff
+#      $(PATCH) $(PKG_BUILD_DIR) ./patches
+       cp -fpR ./ipkg $(PKG_BUILD_DIR)/
        chmod a+x $(PKG_BUILD_DIR)/ipkg/rules
 
 $(PKG_IPK): $(PKG_BUILD_DIR)/ipkg/rules
        cd $(PKG_BUILD_DIR); \
-       ipkg/rules \
-         TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
-         INSTALL_DIR="$(STAGING_DIR)" \
-        package
+       TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
+       INSTALL_DIR="$(STAGING_DIR)" \
+       ipkg/rules package
 
 $(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list: $(PKG_IPK)
        $(IPKG) install $(PKG_IPK)
@@ -42,9 +42,8 @@ install: $(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
 
 clean:
        -cd $(PKG_BUILD_DIR); \
-       ipkg/rules \
-         TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
-         INSTALL_DIR="$(STAGING_DIR)" \
-        clean
+       TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
+       INSTALL_DIR="$(STAGING_DIR)" \
+       ipkg/rules clean
        rm -rf $(PKG_BUILD_DIR)
        rm -r $(PKG_IPK)
diff --git a/openwrt/package/pcre/ipkg/libpcre-dev/CONTROL/control b/openwrt/package/pcre/ipkg/libpcre-dev/CONTROL/control
new file mode 100644 (file)
index 0000000..1718885
--- /dev/null
@@ -0,0 +1,8 @@
+Package: libpcre-dev
+Priority: optional
+Section: devel
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/pcre/
+Description: a Perl Compatible Regular Expression library (development)
diff --git a/openwrt/package/pcre/ipkg/libpcre/CONTROL/control b/openwrt/package/pcre/ipkg/libpcre/CONTROL/control
new file mode 100644 (file)
index 0000000..2bda390
--- /dev/null
@@ -0,0 +1,8 @@
+Package: libpcre
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/pcre/
+Description: a Perl Compatible Regular Expression library
diff --git a/openwrt/package/pcre/ipkg/rules b/openwrt/package/pcre/ipkg/rules
new file mode 100644 (file)
index 0000000..c5d1d33
--- /dev/null
@@ -0,0 +1,139 @@
+#!/usr/bin/make -f
+
+ifneq ($(strip ${IPKG_RULES_INC}),)
+ include $(IPKG_RULES_INC)
+endif
+
+##
+
+PKG_VERSION := $(shell cat ./ipkg/version)
+CURRENT_DIR := $(shell pwd)
+INSTALL_DIR ?= $(CURRENT_DIR)/ipkg-install
+
+unexport INSTALL_DIR
+
+I_LIBPCRE := ipkg/libpcre
+I_LIBPCRE_DEV := ipkg/libpcre-dev
+
+BUILD_DEPS := \
+
+CONFIGURE_OPTS = \
+       --enable-shared \
+       --enable-static \
+       --enable-utf8 \
+
+##
+
+all: package
+
+
+.stamp-configured: $(BUILD_DEPS)
+
+       rm -rf config.cache
+       $(TARGET_CONFIGURE_OPTS) \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       ./configure \
+         --target=$(GNU_TARGET_NAME) \
+         --host=$(GNU_TARGET_NAME) \
+         --build=$(GNU_HOST_NAME) \
+         --prefix=/usr \
+         --exec-prefix=/usr \
+         --bindir=/usr/bin \
+         --datadir=/usr/share \
+         --includedir=/usr/include \
+         --infodir=/usr/share/info \
+         --libdir=/usr/lib \
+         --libexecdir=/usr/lib \
+         --localstatedir=/var \
+         --mandir=/usr/share/man \
+         --sbindir=/usr/sbin \
+         --sysconfdir=/etc \
+         $(DISABLE_LARGEFILE) \
+         $(DISABLE_NLS) \
+         $(CONFIGURE_OPTS) \
+
+       touch .stamp-configured
+
+
+.stamp-built: .stamp-configured
+
+       $(MAKE) \
+         CC_FOR_BUILD="$(HOSTCC)" \
+         LINK_FOR_BUILD="$(HOSTCC)" \
+         CFLAGS_FOR_BUILD="" \
+        dftables
+
+       $(MAKE) \
+         $(TARGET_CONFIGURE_OPTS) \
+         CFLAGS="$(TARGET_CFLAGS)" \
+         
+       touch .stamp-built
+
+
+$(INSTALL_DIR)/usr/include/pcre.h: .stamp-built
+
+       mkdir -p $(INSTALL_DIR)
+
+       $(MAKE) \
+         DESTDIR="$(INSTALL_DIR)" \
+        install
+
+
+configure: .stamp-configured
+
+
+build: .stamp-built
+
+
+install: $(INSTALL_DIR)/usr/include/pcre.h
+
+
+package: $(INSTALL_DIR)/usr/include/pcre.h
+
+       mkdir -p $(I_LIBPCRE)/usr/lib
+       cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.so.* $(I_LIBPCRE)/usr/lib/
+       $(STRIP) $(I_LIBPCRE)/usr/lib/lib*.so.*
+
+       mkdir -p $(I_LIBPCRE_DEV)/usr/bin
+       cp -fpR $(INSTALL_DIR)/usr/bin/pcre-config  $(I_LIBPCRE_DEV)/usr/bin/
+       mkdir -p $(I_LIBPCRE_DEV)/usr/include
+       cp -fpR $(INSTALL_DIR)/usr/include/pcre*.h $(I_LIBPCRE_DEV)/usr/include/
+       mkdir -p $(I_LIBPCRE_DEV)/usr/lib
+       cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.a $(I_LIBPCRE_DEV)/usr/lib/
+       cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.so* $(I_LIBPCRE_DEV)/usr/lib/
+
+       chmod 0755 ipkg/*/CONTROL/
+       chmod 0644 ipkg/*/CONTROL/control
+       
+       perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
+ifneq ($(strip $(PKG_VERSION)),)
+       perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
+endif
+
+       $(IPKG_BUILD) $(I_LIBPCRE) $(IPKG_TARGET_DIR)
+       $(IPKG_BUILD) $(I_LIBPCRE_DEV) $(IPKG_TARGET_DIR)
+
+
+clean:
+
+       -$(MAKE) clean
+
+       rm -rf .stamp-* \
+         $(INSTALL_DIR)/usr/bin/pcre* \
+         $(INSTALL_DIR)/usr/include/pcre* \
+         $(INSTALL_DIR)/usr/lib/libpcre* \
+         $(INSTALL_DIR)/usr/lib/pkgconfig/libpcre.pc \
+         $(INSTALL_DIR)/usr/share/man/man*/pcre* \
+         $(I_LIBPCRE)/usr \
+        $(I_LIBPCRE_DEV)/usr \
+
+
+control:
+
+       @cat $(I_LIBPCRE)/CONTROL/control
+       @echo
+       @cat $(I_LIBPCRE_DEV)/CONTROL/control
+       @echo
+       
+
+.PHONY: configure build install package clean control
diff --git a/openwrt/package/pcre/ipkg/version b/openwrt/package/pcre/ipkg/version
new file mode 100644 (file)
index 0000000..2f5e55b
--- /dev/null
@@ -0,0 +1 @@
+5.0-3
diff --git a/openwrt/package/pcre/pcre-5.0-3.diff b/openwrt/package/pcre/pcre-5.0-3.diff
deleted file mode 100644 (file)
index 4d71ff7..0000000
+++ /dev/null
@@ -1,167 +0,0 @@
-diff -ruN pcre-5.0-orig/ipkg/libpcre/CONTROL/control pcre-5.0-3/ipkg/libpcre/CONTROL/control
---- pcre-5.0-orig/ipkg/libpcre/CONTROL/control 1970-01-01 01:00:00.000000000 +0100
-+++ pcre-5.0-3/ipkg/libpcre/CONTROL/control    2005-03-08 03:33:59.000000000 +0100
-@@ -0,0 +1,8 @@
-+Package: libpcre
-+Priority: optional
-+Section: libs
-+Version: [TBDL]
-+Architecture: [TBDL]
-+Maintainer: Nico <nthill@free.fr>
-+Source: http://nthill.free.fr/openwrt/sources/pcre/
-+Description: a Perl Compatible Regular Expression library
-diff -ruN pcre-5.0-orig/ipkg/pcre-dev/CONTROL/control pcre-5.0-3/ipkg/pcre-dev/CONTROL/control
---- pcre-5.0-orig/ipkg/pcre-dev/CONTROL/control        1970-01-01 01:00:00.000000000 +0100
-+++ pcre-5.0-3/ipkg/pcre-dev/CONTROL/control   2005-03-08 03:34:14.000000000 +0100
-@@ -0,0 +1,8 @@
-+Package: pcre-dev
-+Priority: optional
-+Section: devel
-+Version: [TBDL]
-+Architecture: [TBDL]
-+Maintainer: Nico <nthill@free.fr>
-+Source: http://nthill.free.fr/openwrt/sources/pcre/
-+Description: a Perl Compatible Regular Expression library (development)
-diff -ruN pcre-5.0-orig/ipkg/rules pcre-5.0-3/ipkg/rules
---- pcre-5.0-orig/ipkg/rules   1970-01-01 01:00:00.000000000 +0100
-+++ pcre-5.0-3/ipkg/rules      2005-03-08 03:47:50.000000000 +0100
-@@ -0,0 +1,134 @@
-+#!/usr/bin/make -f
-+
-+ifneq ($(strip ${IPKG_RULES_INC}),)
-+  include $(IPKG_RULES_INC)
-+endif
-+
-+##
-+
-+PKG_VERSION := $(shell cat ./ipkg/version)
-+CURRENT_DIR := $(shell pwd)
-+INSTALL_DIR = $(CURRENT_DIR)/ipkg-install
-+
-+I_LIBPCRE := ipkg/libpcre
-+I_PCRE_DEV := ipkg/pcre-dev
-+
-+BUILD_DEPS := \
-+
-+CONFIGURE_OPTS = \
-+      --enable-shared \
-+      --enable-static \
-+      --enable-utf8 \
-+
-+##
-+
-+all: package
-+
-+
-+.stamp-configured: $(BUILD_DEPS)
-+
-+      rm -rf config.cache
-+      $(TARGET_CONFIGURE_OPTS) \
-+      CFLAGS="$(TARGET_CFLAGS)" \
-+      ./configure \
-+        --target=$(GNU_TARGET_NAME) \
-+        --host=$(GNU_TARGET_NAME) \
-+        --build=$(GNU_HOST_NAME) \
-+        --prefix=/usr \
-+        --exec-prefix=/usr \
-+        --bindir=/usr/bin \
-+        --datadir=/usr/share \
-+        --includedir=/usr/include \
-+        --infodir=/usr/share/info \
-+        --libdir=/usr/lib \
-+        --libexecdir=/usr/lib \
-+        --localstatedir=/var \
-+        --mandir=/usr/share/man \
-+        --sbindir=/usr/sbin \
-+        --sysconfdir=/etc \
-+        $(DISABLE_NLS) \
-+
-+      touch .stamp-configured
-+
-+
-+.stamp-built: .stamp-configured
-+
-+      $(MAKE) \
-+        CC_FOR_BUILD="$(HOSTCC)" \
-+        LINK_FOR_BUILD="$(HOSTCC)" \
-+        CFLAGS_FOR_BUILD="" \
-+       dftables
-+
-+      $(MAKE) \
-+        $(TARGET_CONFIGURE_OPTS) \
-+        CFLAGS="$(TARGET_CFLAGS)" \
-+        
-+      touch .stamp-built
-+
-+
-+$(INSTALL_DIR)/usr/include/pcre.h: .stamp-built
-+
-+      mkdir -p $(INSTALL_DIR)
-+
-+      $(MAKE) \
-+        DESTDIR="$(INSTALL_DIR)" \
-+       install
-+
-+
-+configure: .stamp-configured
-+
-+
-+build: .stamp-built
-+
-+
-+install: $(INSTALL_DIR)/usr/include/pcre.h
-+
-+
-+package: $(INSTALL_DIR)/usr/include/pcre.h
-+
-+      mkdir -p $(I_LIBPCRE)/usr/lib
-+      cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.so.* $(I_LIBPCRE)/usr/lib/
-+      $(STRIP) $(I_LIBPCRE)/usr/lib/lib*.so.*
-+
-+      mkdir -p $(I_PCRE_DEV)/usr/bin
-+      cp -fpR $(INSTALL_DIR)/usr/bin/pcre-config  $(I_PCRE_DEV)/usr/bin/
-+      mkdir -p $(I_PCRE_DEV)/usr/include
-+      cp -fpR $(INSTALL_DIR)/usr/include/pcre*.h $(I_PCRE_DEV)/usr/include/
-+      mkdir -p $(I_PCRE_DEV)/usr/lib
-+      cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.a $(I_PCRE_DEV)/usr/lib/
-+      cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.so* $(I_PCRE_DEV)/usr/lib/
-+
-+      chmod 0755 ipkg/*/CONTROL/
-+      chmod 0644 ipkg/*/CONTROL/control
-+      
-+      perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
-+ifneq ($(strip $(PKG_VERSION)),)
-+      perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
-+endif
-+
-+      $(IPKG_BUILD) $(I_LIBPCRE) $(IPKG_TARGET_DIR)
-+      $(IPKG_BUILD) $(I_PCRE_DEV) $(IPKG_TARGET_DIR)
-+
-+
-+clean:
-+
-+      -$(MAKE) clean
-+      rm -rf .stamp-*
-+      rm -rf $(INSTALL_DIR)/usr/bin/pcre*
-+      rm -rf $(INSTALL_DIR)/usr/include/pcre*
-+      rm -rf $(INSTALL_DIR)/usr/lib/libpcre*
-+      rm -rf $(INSTALL_DIR)/usr/lib/pkgconfig/libpcre.pc
-+      rm -rf $(INSTALL_DIR)/usr/share/man/man*/pcre*
-+      rm -rf $(I_LIBPCRE)/usr
-+      rm -rf $(I_PCRE_DEV)/usr
-+
-+
-+control:
-+
-+      @cat $(I_LIBPCRE)/CONTROL/control
-+      @echo
-+      @cat $(I_PCRE_DEV)/CONTROL/control
-+      @echo
-+      
-+
-+.PHONY: configure build install package clean control
-diff -ruN pcre-5.0-orig/ipkg/version pcre-5.0-3/ipkg/version
---- pcre-5.0-orig/ipkg/version 1970-01-01 01:00:00.000000000 +0100
-+++ pcre-5.0-3/ipkg/version    2005-03-08 03:32:54.000000000 +0100
-@@ -0,0 +1 @@
-+5.0-3