tools/bc: update to 1.07.1
authorNick Hainke <vincent@systemli.org>
Fri, 21 Oct 2022 20:23:47 +0000 (22:23 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Oct 2022 20:50:37 +0000 (22:50 +0200)
Changes:
  Fixed ibase extension causing problems for read()
  Fixed parallel make problem.

Remove the "003-bc-fix-hang.patch" because the hang is fixed upstream.

Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/bc/Makefile
tools/bc/patches/003-bc-fix-hang.patch [deleted file]

index ac6609e00837b4133df00fc7e2c55ac5cbd5da73..2c29e094e23b2eacc7d3a8fb41c0043d77e538f1 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bc
-PKG_VERSION:=1.07
+PKG_VERSION:=1.07.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/bc
-PKG_HASH:=55cf1fc33a728d7c3d386cc7b0cb556eb5bacf8e0cb5a3fcca7f109fc61205ad
+PKG_HASH:=62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a
 
 PKG_FIXUP := autoreconf
 PKG_CPE_ID:=cpe:/a:gnu:bc
diff --git a/tools/bc/patches/003-bc-fix-hang.patch b/tools/bc/patches/003-bc-fix-hang.patch
deleted file mode 100644 (file)
index ba29705..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/bc/execute.c
-+++ b/bc/execute.c
-@@ -595,7 +595,7 @@ input_char (void)
-   if (in_ch == '.' || in_ch == '+' || in_ch == '-')
-     return (in_ch);
-   if (in_ch <= ' ')
--    return (' ');
-+    return (':');
-   
-   return (':');
- }