kernel: bump 4.14 to 4.14.106
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 14 Mar 2019 13:22:10 +0000 (14:22 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 18 Mar 2019 09:02:51 +0000 (10:02 +0100)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
12 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/backport-4.14/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/pending-4.14/308-mips32r2_tune.patch
target/linux/generic/pending-4.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/layerscape/patches-4.14/711-dpaa-bqman-support-layerscape.patch
target/linux/mvebu/patches-4.14/408-sfp-move-module-eeprom-ethtool-access-into-netdev-co.patch
target/linux/mvebu/patches-4.14/409-sfp-use-netdev-sfp_bus-for-start-stop.patch
target/linux/oxnas/patches-4.14/060-fix-oxnas-rps-dt-match.patch
target/linux/ramips/patches-4.14/0031-uvc-add-iPassion-iP2970-support.patch

index da1f56b023fcd85ab8078cadb1d2bf3d4118b0c1..9ea94a840c4f2d96cea592e9736242caffca0832 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .163
-LINUX_VERSION-4.14 = .105
+LINUX_VERSION-4.14 = .106
 LINUX_VERSION-4.19 = .25
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.163 = c27cf9962c17b91275ab9e74b43c1269f726f79e7a85421be7c5c73d267eef91
-LINUX_KERNEL_HASH-4.14.105 = 398bdb98b4e4d0ad0e60f4fa530f3f8451ef8dafdf512b7754aa29953263f6e9
+LINUX_KERNEL_HASH-4.14.106 = a0e2af6add699d86cf15e1ee31ad408aa28dbab82f4462450eba51f90e7d2760
 LINUX_KERNEL_HASH-4.19.25 = 7ec71d90d6e96e6f741676d157ac06f30c75be4eaf1649143a3c8b7d4f919731
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 0797bf7ba23b34e1da2f948ffa18fed2e6680902..f22806abc546aba87bb5e0dd8e695e9ecc2b19ca 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -223,6 +223,7 @@ cflags-$(toolchain-virt)           += -DTOOLCHAIN
+@@ -228,6 +228,7 @@ cflags-$(toolchain-virt)           += -DTOOLCHAIN
  #
  libs-$(CONFIG_FW_ARC)         += arch/mips/fw/arc/
  libs-$(CONFIG_FW_CFE)         += arch/mips/fw/cfe/
index 93ca8331e3b7956b15d7fb56de8ed5bc99709659..9f07fddc65f07796ccd63aa7649229fab5d41790 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1934,7 +1934,8 @@ static const struct usb_device_id option
+@@ -1936,7 +1936,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 7788dd14349942f36464b95dc2209522a9a4ebff..00303f90a1ae1e54ba70890b2f46888512015e42 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  };
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -901,6 +901,9 @@ static unsigned int early_drop_list(stru
+@@ -917,6 +917,9 @@ static unsigned int early_drop_list(stru
        hlist_nulls_for_each_entry_rcu(h, n, head, hnnode) {
                tmp = nf_ct_tuplehash_to_ctrack(h);
  
@@ -57,7 +57,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                if (nf_ct_is_expired(tmp)) {
                        nf_ct_gc_expired(tmp);
                        continue;
-@@ -978,6 +981,18 @@ static bool gc_worker_can_early_drop(con
+@@ -994,6 +997,18 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1014,6 +1029,11 @@ static void gc_worker(struct work_struct
+@@ -1030,6 +1045,11 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index e17b4b62049bcdf4aa6daf440f2ccccd858664ee..166b7219d592b5d653775056c96f30ae9fc6d0a3 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -981,18 +981,6 @@ static bool gc_worker_can_early_drop(con
+@@ -997,18 +997,6 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1029,10 +1017,8 @@ static void gc_worker(struct work_struct
+@@ -1045,10 +1033,8 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 39167bf4ae27048a7ee07b22e6b9b0b0436c052c..a67306031c2a3464dc66358fad00110cdbea9be0 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -161,7 +161,7 @@ cflags-$(CONFIG_CPU_VR41XX)        += -march=r4
+@@ -166,7 +166,7 @@ cflags-$(CONFIG_CPU_VR41XX)        += -march=r4
  cflags-$(CONFIG_CPU_R4X00)    += -march=r4600 -Wa,--trap
  cflags-$(CONFIG_CPU_TX49XX)   += -march=r4600 -Wa,--trap
  cflags-$(CONFIG_CPU_MIPS32_R1)        += -march=mips32 -Wa,--trap
index 03bb755619087765bc50dddc3cc03b7b49298c85..e4fdd6c58b4129ddedce25f02caf0870cba1b65c 100644 (file)
@@ -181,7 +181,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -3502,6 +3536,9 @@ static int rt6_fill_node(struct net *net
+@@ -3506,6 +3540,9 @@ static int rt6_fill_node(struct net *net
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
@@ -191,7 +191,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                case -EAGAIN:
                        rtm->rtm_type = RTN_THROW;
                        break;
-@@ -3820,6 +3857,8 @@ static int ip6_route_dev_notify(struct n
+@@ -3824,6 +3861,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -200,7 +200,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -3831,6 +3870,7 @@ static int ip6_route_dev_notify(struct n
+@@ -3835,6 +3874,7 @@ static int ip6_route_dev_notify(struct n
                in6_dev_put_clear(&net->ipv6.ip6_null_entry->rt6i_idev);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                in6_dev_put_clear(&net->ipv6.ip6_prohibit_entry->rt6i_idev);
@@ -208,7 +208,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                in6_dev_put_clear(&net->ipv6.ip6_blk_hole_entry->rt6i_idev);
  #endif
        }
-@@ -4047,6 +4087,17 @@ static int __net_init ip6_route_net_init
+@@ -4051,6 +4091,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
@@ -226,7 +226,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -4065,6 +4116,8 @@ out:
+@@ -4069,6 +4120,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -235,7 +235,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -4082,6 +4135,7 @@ static void __net_exit ip6_route_net_exi
+@@ -4086,6 +4139,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
@@ -243,7 +243,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -4155,6 +4209,9 @@ void __init ip6_route_init_special_entri
+@@ -4159,6 +4213,9 @@ void __init ip6_route_init_special_entri
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 89ace283b9bdd211e578448316b6e23736d60522..7946d3cbc1527a1252ea78139bdc92b25c5cd3a7 100644 (file)
@@ -270,7 +270,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  }
  
  static inline int fq_isset(struct qman_fq *fq, u32 mask)
-@@ -1566,7 +1604,7 @@ void qman_p_irqsource_add(struct qman_po
+@@ -1567,7 +1605,7 @@ void qman_p_irqsource_add(struct qman_po
        unsigned long irqflags;
  
        local_irq_save(irqflags);
@@ -279,7 +279,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        qm_out(&p->p, QM_REG_IER, p->irq_sources);
        local_irq_restore(irqflags);
  }
-@@ -1589,7 +1627,7 @@ void qman_p_irqsource_remove(struct qman
+@@ -1590,7 +1628,7 @@ void qman_p_irqsource_remove(struct qman
         */
        local_irq_save(irqflags);
        bits &= QM_PIRQ_VISIBLE;
index f5506a8bdf831190a7b334db68951f137f0e91e9..540ef51ba476028925d8bdbdab38b8d04f742df3 100644 (file)
@@ -49,7 +49,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  };
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -1054,34 +1054,6 @@ int phylink_ethtool_set_pauseparam(struc
+@@ -1058,34 +1058,6 @@ int phylink_ethtool_set_pauseparam(struc
  }
  EXPORT_SYMBOL_GPL(phylink_ethtool_set_pauseparam);
  
index c2cf554281df65129d66de1f0838ce41b8ebad4c..4db3867c4ec58d02d3eede7c80515530dc5ef63c 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
 
 --- a/drivers/net/phy/phylink.c
 +++ b/drivers/net/phy/phylink.c
-@@ -771,8 +771,8 @@ void phylink_start(struct phylink *pl)
+@@ -775,8 +775,8 @@ void phylink_start(struct phylink *pl)
        clear_bit(PHYLINK_DISABLE_STOPPED, &pl->phylink_disable_state);
        phylink_run_resolve(pl);
  
@@ -21,7 +21,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
        if (pl->phydev)
                phy_start(pl->phydev);
  }
-@@ -784,8 +784,8 @@ void phylink_stop(struct phylink *pl)
+@@ -788,8 +788,8 @@ void phylink_stop(struct phylink *pl)
  
        if (pl->phydev)
                phy_stop(pl->phydev);
index 669a90168349c4050627d7013491ce4648a77fc3..4cc622b19e2407aadd687d6efa7834b9d7979fe9 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/drivers/clocksource/timer-oxnas-rps.c b/drivers/clocksource/timer-oxnas-rps.c
-index eed6feff8b5f..30c6f4ce672b 100644
 --- a/drivers/clocksource/timer-oxnas-rps.c
 +++ b/drivers/clocksource/timer-oxnas-rps.c
-@@ -296,4 +296,4 @@ static int __init oxnas_rps_timer_init(struct device_node *np)
+@@ -296,4 +296,4 @@ err_alloc:
  TIMER_OF_DECLARE(ox810se_rps,
                       "oxsemi,ox810se-rps-timer", oxnas_rps_timer_init);
  TIMER_OF_DECLARE(ox820_rps,
index 19bac1f64ff6fb22b84888db3dca39f81b356dd1..3ef607f14b501d8a3d04cb58285029a34ebaa2f4 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/media/usb/uvc/uvc_driver.c
 +++ b/drivers/media/usb/uvc/uvc_driver.c
-@@ -2727,6 +2727,18 @@ static const struct usb_device_id uvc_id
+@@ -2735,6 +2735,18 @@ static const struct usb_device_id uvc_id
          .bInterfaceSubClass   = 1,
          .bInterfaceProtocol   = 0,
          .driver_info          = UVC_QUIRK_FORCE_Y8 },