ltq-xdsl-app: drop esi call
authorMathias Kresin <dev@kresin.me>
Thu, 3 Aug 2017 19:11:57 +0000 (21:11 +0200)
committerMathias Kresin <dev@kresin.me>
Sun, 6 Aug 2017 07:22:03 +0000 (09:22 +0200)
The esi call was added to workaround a race condition between applying
a configured mac address to the wan interface and starting the protocol
(handler) as it was observed in a DHCP over ATM bridge configuration.

Martin Schiller, TDT GmbH was so kind to test with their local
infrastructure if the race condition still exists. The provided package
dumps captured behind the DSLAM shows that it doesn't. It was most
likely fixed with adding carrier support to the lantiq ptm/atm driver.

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/network/config/ltq-adsl-app/files/dsl_control
package/network/config/ltq-vdsl-app/Makefile
package/network/config/ltq-vdsl-app/files/vdsl_cpe_control_wrapper

index dcde6b233820a84c859b0bbb7f76d1cc397d5f25..8218186ef8b1aab0bb6ff80e37f8251eeec3e6af 100644 (file)
@@ -45,8 +45,6 @@ start() {
                return 1
        }
 
                return 1
        }
 
-       esi $(printf '%012X' $((1+0x$(tr -d : </sys/class/net/eth0/address))))
-
        service_start /sbin/dsl_cpe_control -i${xtu} \
                        -n /sbin/dsl_notify.sh \
                        -f ${firmware}
        service_start /sbin/dsl_cpe_control -i${xtu} \
                        -n /sbin/dsl_notify.sh \
                        -f ${firmware}
index 1ddb83a0af9617eb3c6ec4e381beed09252bba00..815f89c0b8ad8250d82393d7f47e8779f4d72380 100644 (file)
@@ -28,7 +28,7 @@ define Package/ltq-vdsl-app
   CATEGORY:=Network
   TITLE:=Lantiq VDSL userland tool
   URL:=http://www.lantiq.com/
   CATEGORY:=Network
   TITLE:=Lantiq VDSL userland tool
   URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt +atm-esi
+  DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt
 endef
 
 define Package/ltq-vdsl-app/description
 endef
 
 define Package/ltq-vdsl-app/description
index cc127f7779c9639fdd4d1d79426f7275d6d94fcc..8e7c1cb4b8ff0adeb3853bafb728ba47392b6b7d 100644 (file)
@@ -7,5 +7,4 @@ for mod in $LOAD; do
        grep -q "$mod " /proc/modules || insmod "$mod"
 done
 
        grep -q "$mod " /proc/modules || insmod "$mod"
 done
 
-esi $(printf '%012X' $((1+0x$(tr -d : </sys/class/net/eth0/address))))
 exec /sbin/vdsl_cpe_control "$@"
 exec /sbin/vdsl_cpe_control "$@"