image-commands.mk: Use ERROR_MESSAGE for imagesize fails
authorPaul Spooren <mail@aparcar.org>
Mon, 28 Feb 2022 09:20:53 +0000 (10:20 +0100)
committerPaul Spooren <mail@aparcar.org>
Mon, 28 Feb 2022 22:52:13 +0000 (23:52 +0100)
If a image is bigger than the device can handle, an error message is
printed. This is usually silenced and silently ignored, making it harder
to debug. While it's possible to run the build in verbose mode (via
`make V=s`) and grep for *is too big*, it's more intuitive to print the
error message directly. For that use the newly unlocked `$(call
ERROR_MESSAGE,...)` definition which now also print in non-verbose mode.

Fixes: FS#50 (aka #7604)
Signed-off-by: Paul Spooren <mail@aparcar.org>
include/image-commands.mk

index 485d870f050a83db2fa7a264f600b99e31d1eece..939f5ef2db4db7afeab6f0009d926aef3055d906 100644 (file)
@@ -191,7 +191,7 @@ define Build/check-size
        @imagesize="$$(stat -c%s $@)"; \
        limitsize="$$(($(subst k,* 1024,$(subst m, * 1024k,$(if $(1),$(1),$(IMAGE_SIZE))))))"; \
        [ $$limitsize -ge $$imagesize ] || { \
-               echo "WARNING: Image file $@ is too big: $$imagesize > $$limitsize" >&2; \
+               $(call ERROR_MESSAGE,    WARNING: Image file $@ is too big: $$imagesize > $$limitsize); \
                rm -f $@; \
        }
 endef