brcm63xx: Add DT support for 963281TAN
authorJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:24:29 +0000 (12:24 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 2 Oct 2014 12:24:29 +0000 (12:24 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42727

36 files changed:
target/linux/brcm63xx/dts/bcm963281TAN.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/550-alice_gate2_leds.patch
target/linux/brcm63xx/patches-3.14/551-96348gw_a_leds.patch
target/linux/brcm63xx/patches-3.14/552-board_96348gw-10_reset_button.patch
target/linux/brcm63xx/patches-3.14/553-boards_probe_switch.patch
target/linux/brcm63xx/patches-3.14/554-board_DWVS0_leds_buttons.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/01-generic.mk

diff --git a/target/linux/brcm63xx/dts/bcm963281TAN.dts b/target/linux/brcm63xx/dts/bcm963281TAN.dts
new file mode 100644 (file)
index 0000000..be69997
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6328.dtsi"
+
+/ {
+       model = "Broadcom bcm963281TAN reference board";
+       compatible = "brcm,bcm963281TAN", "brcm,bcm6328";
+};
index a9d938f7a871e9a602d5bedb7a88f3ef43b8f4ee..0010e7d3e9dcd5370aa542dfbfa139eacb0fe22c 100755 (executable)
@@ -234,9 +234,6 @@ endef
 define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
        # Various routers
-       $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-4M-flash-generic,,--pad 2)
-       $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-8M-flash-generic,,--pad 4)
-       $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-16M-flash-generic,,--pad 8)
        $(call Image/Build/CFE,$(1),96345GW2,6345,96345GW2-generic)
        $(call Image/Build/CFE,$(1),96345GW2,6345,96348GW2-bc221,,--layoutver 5)
        $(call Image/Build/CFE,$(1),96345GW2,6345,92345GW2-rev,OpenWRT-$(REVISION))
@@ -337,6 +334,10 @@ define Image/Build
   endif
 endef
 
+# Generic 963281TAN
+$(eval $(call CfeImageDTB,963281TAN,bcm963281TAN,963281TAN,6328,963281TAN-4M-flash-generic,,--pad 2))
+$(eval $(call CfeImageDTB,963281TAN,bcm963281TAN,963281TAN,6328,963281TAN-8M-flash-generic,,--pad 4))
+$(eval $(call CfeImageDTB,963281TAN,bcm963281TAN,963281TAN,6328,963281TAN-16M-flash-generic,,--pad 8))
 # Generic 96328avng
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-4M-flash-generic,,--pad 2))
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-8M-flash-generic,,--pad 4))
index 665c71e3db0122ff0cae3c06f373563085dd1acb..46d52302dba761dae3460a428bdbc8052b0fadc7 100644 (file)
@@ -9,13 +9,14 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -156,6 +156,76 @@ static struct board_info __initdata boar
+@@ -156,6 +156,77 @@ static struct board_info __initdata boar
                },
        },
  };
 +
 +static struct board_info __initdata board_963281TAN = {
 +      .name                           = "963281TAN",
++      .of_board_id                    = "brcm,bcm963281TAN",
 +      .expected_cpu_id                = 0x6328,
 +
 +      .has_uart0                      = 1,
@@ -86,7 +87,7 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2121,6 +2191,7 @@ static const struct board_info __initcon
+@@ -2121,6 +2192,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 7b3fba3520987c32cfbd7c5cd42c45f30986cc50..d7a45ca5b79a20597ab4ab1fd9f8cb35e055a2ca 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -226,6 +226,111 @@ static struct board_info __initdata boar
+@@ -227,6 +227,111 @@ static struct board_info __initdata boar
  
        },
  };
@@ -122,7 +122,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2192,6 +2297,7 @@ static const struct board_info __initcon
+@@ -2193,6 +2298,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 72542c695d76c777e4f985f7601a4b5ac4ecb360..779582b0ad9b188a76a71154d1bd2003e53648f0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1175,6 +1175,59 @@ static struct board_info __initdata boar
+@@ -1176,6 +1176,59 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
  };
  
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348_D4PW = {
        .name                           = "D-4P-W",
        .expected_cpu_id                = 0x6348,
-@@ -2327,6 +2380,7 @@ static const struct board_info __initcon
+@@ -2328,6 +2381,7 @@ static const struct board_info __initcon
        &board_ct536_ct5621,
        &board_96348A_122,
        &board_CPVA502plus,
index 34a135dbf4c1cbf6ba55beab09718ca837f0e455..f0b80743aef53aa074e263760fbd280fe2f98ea8 100644 (file)
@@ -13,7 +13,7 @@
  /*
   * known 3368 boards
   */
-@@ -2050,6 +2056,125 @@ static struct board_info __initdata boar
+@@ -2051,6 +2057,125 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(nb4_spi_devices),
  };
  
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
-@@ -2392,6 +2517,7 @@ static const struct board_info __initcon
+@@ -2393,6 +2518,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index a245ca14d5bc56e5fe9f829671508cba1a67eb6d..20b8db41bae3c6542c37db43272d7e09511902f4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2318,6 +2318,74 @@ static struct board_info __initdata boar
+@@ -2319,6 +2319,74 @@ static struct board_info __initdata boar
                },
        }
  };
@@ -75,7 +75,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -2520,6 +2588,7 @@ static const struct board_info __initcon
+@@ -2521,6 +2589,7 @@ static const struct board_info __initcon
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
index 7c0c133266bcfc20a83542ecc372d38917a1d308..701ff35beb5d0434d6860fb4bf265f4e3d9d4c7a 100644 (file)
@@ -17,7 +17,7 @@
  
  #define CT6373_PID_OFFSET             0xff80
  #define CT6373_74X164_GPIO_BASE       64
-@@ -2388,6 +2391,105 @@ static struct board_info __initdata boar
+@@ -2389,6 +2392,105 @@ static struct board_info __initdata boar
  };
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
   * known 6368 boards
   */
-@@ -2591,6 +2693,10 @@ static const struct board_info __initcon
+@@ -2592,6 +2694,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
index a5053939d3989e3209699ffdb6ae3c507b9300a2..9dac9d5d3f926a263d1b9e59e1d603166181986d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1117,6 +1117,57 @@ static struct board_info __initdata boar
+@@ -1118,6 +1118,57 @@ static struct board_info __initdata boar
        .has_ehci0                      = 1,
  };
  
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2664,6 +2715,7 @@ static const struct board_info __initcon
+@@ -2665,6 +2716,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index b85b961587643d06996c1f4f48dc04cd8f84a07b..36a9dab0ee0924e9d7ff40c9dd74704f819dded6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -236,6 +236,134 @@ static struct board_info __initdata boar
+@@ -237,6 +237,134 @@ static struct board_info __initdata boar
        },
  };
  
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2696,6 +2824,7 @@ static const struct board_info __initcon
+@@ -2697,6 +2825,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 3194899e82decd828af0dd3f57e8dcc1b765ef8b..1efd27c7901ef29579434ef55263129e39b70214 100644 (file)
 +
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
-       .expected_cpu_id                = 0x6328,
-@@ -2823,6 +2933,7 @@ static const struct board_info __initcon
+       .of_board_id                    = "brcm,bcm963281TAN",
+@@ -2824,6 +2934,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index e80009a27f1c1358c90397582cfd89038879f597..6f6989fdd2486844ac9fdc5023ea2a12f7731cfb 100644 (file)
@@ -93,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2933,6 +3019,7 @@ static const struct board_info __initcon
+@@ -2934,6 +3020,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index e3fa82372fcd3c7e6722d63b920d90660c50cd18..141123659580ce4cfe68abf8251213f736f6ab46 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -841,6 +841,55 @@ static struct board_info __initdata boar
+@@ -842,6 +842,55 @@ static struct board_info __initdata boar
  
        .has_uart0                      = 1,
  };
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3033,6 +3082,7 @@ static const struct board_info __initcon
+@@ -3034,6 +3083,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index f6b39c403305e9b11391ff49b191baca2892ed95..d603287589fdc38fd95d703e284675f02f82c516 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2680,6 +2681,405 @@ static struct board_info __initdata boar
+@@ -2681,6 +2682,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3118,6 +3518,9 @@ static const struct board_info __initcon
+@@ -3119,6 +3519,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index 509e41ea3f9e38c931f4855facc4c9474813ac39..6bfa999655949a6d708e50b1a97055644c07756f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -891,6 +891,60 @@ static struct board_info __initdata boar
+@@ -892,6 +892,60 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3483,6 +3537,7 @@ static const struct board_info __initcon
+@@ -3484,6 +3538,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index cd0310003d05998d70afe53b8800eade5d7e448d..9fcab618d4f48df37e83e2277725ca624852b920 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -665,6 +665,122 @@ static struct board_info __initdata boar
+@@ -666,6 +666,122 @@ static struct board_info __initdata boar
                },
        },
  };
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3527,6 +3643,7 @@ static const struct board_info __initcon
+@@ -3528,6 +3644,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index cedeac803ed3ed64a864080b344cc7c875d897fa..31b2b9216614b869dc237fa0b042a865444c6a2b 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3482,6 +3482,96 @@ static struct board_info __initdata boar
+@@ -3483,6 +3483,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3699,6 +3789,7 @@ static const struct board_info __initcon
+@@ -3700,6 +3790,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index 10ac31648b0dd40ae9845e92e9d2b9df3c5bf876..5f6be3f639769ad9d33578803a2a258d1a7261da 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2306,6 +2306,99 @@ static struct board_info __initdata boar
+@@ -2307,6 +2307,99 @@ static struct board_info __initdata boar
  
        .has_ohci0 = 1,
        .has_ehci0 = 1,
index 7b1443bf1b1e335b307dd08c397e8cd36458826f..af8a39339aea5044ecfd6d4aa6fce8ccdf9e2c3a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1777,6 +1777,19 @@ static struct board_info __initdata boar
+@@ -1778,6 +1778,19 @@ static struct board_info __initdata boar
        },
  
        .has_ohci0 = 1,
index 5a249c5f822113e278a615f63c06846b13606a35..25c99f8088f78b0ee3fc13d47fd20cf5b9295950 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1173,6 +1173,17 @@ static struct board_info __initdata boar
+@@ -1174,6 +1174,17 @@ static struct board_info __initdata boar
                        .active_low     = 1,
                },
        },
index 4fa865d05aa7cf5e805186fea8a04897b031bfa6..019c47c93f20c14967b3a51b1959007377754f3b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -795,6 +795,8 @@ static struct board_info __initdata boar
+@@ -796,6 +796,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -9,7 +9,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -839,6 +841,8 @@ static struct board_info __initdata boar
+@@ -840,6 +842,8 @@ static struct board_info __initdata boar
        .has_uart0                      = 1,
        .has_enet0                      = 1,
        .enet0 = {
@@ -18,7 +18,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1129,6 +1133,8 @@ static struct board_info __initdata boar
+@@ -1130,6 +1134,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -27,7 +27,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1203,6 +1209,8 @@ static struct board_info __initdata boar
+@@ -1204,6 +1210,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -36,7 +36,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1484,6 +1492,8 @@ static struct board_info __initdata boar
+@@ -1485,6 +1493,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -45,7 +45,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1663,6 +1673,8 @@ static struct board_info __initdata boar
+@@ -1664,6 +1674,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -54,7 +54,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1739,6 +1751,8 @@ static struct board_info __initdata boar
+@@ -1740,6 +1752,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -63,7 +63,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1762,6 +1776,8 @@ static struct board_info __initdata boar
+@@ -1763,6 +1777,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -72,7 +72,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -1783,6 +1799,8 @@ static struct board_info __initdata boar
+@@ -1784,6 +1800,8 @@ static struct board_info __initdata boar
                .use_internal_phy       = 1,
        },
        .enet1 = {
@@ -81,7 +81,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2128,6 +2146,8 @@ static struct board_info __initdata boar
+@@ -2129,6 +2147,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -90,7 +90,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2182,6 +2202,8 @@ static struct board_info __initdata boar
+@@ -2183,6 +2203,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
@@ -99,7 +99,7 @@
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2324,6 +2346,8 @@ static struct board_info __initdata boar
+@@ -2325,6 +2347,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },
-@@ -2443,6 +2467,8 @@ static struct board_info __initdata boar
+@@ -2444,6 +2468,8 @@ static struct board_info __initdata boar
        },
  
        .enet1 = {
index 4ebe502967ec5594a65a5a5945cba32f7f1898a2..9409a5e5aca16c1bed17b7a1411ec5e4e68031ca 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2475,6 +2475,94 @@ static struct board_info __initdata boar
+@@ -2476,6 +2476,94 @@ static struct board_info __initdata boar
  
        .has_ohci0                      = 1,
        .has_ehci0                      = 1,
index 7b9fa914c0e3236823e1aa534d136b7e3790cb4c..ed857c33bf9ba039aeebbc6847c26c644fefa9df 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3957,6 +4044,9 @@ static const struct board_info __initcon
+@@ -3958,6 +4045,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 38fe7559fc7537ef45347d5df3d6927a3a6955d0..0b88dd0e9f377d26e78c282ae979c67c4a193098 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4046,6 +4134,7 @@ static const struct board_info __initcon
+@@ -4047,6 +4135,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 7a3cea57271efba2df84587c9ab2aed80db9f1ed..a2b134063d80a606b2150e66ebb7b557a8cc5b78 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4126,6 +4126,75 @@ static struct board_info __initdata boar
+@@ -4127,6 +4127,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4206,6 +4275,9 @@ static const struct board_info __initcon
+@@ -4207,6 +4276,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 1d485b6becce6a14e58ff7f8b294b8eb9cc08837..71bc7e26f2c1c0c14423feae79d1a0bbc00df1fd 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1435,6 +1435,52 @@ static struct board_info __initdata boar
+@@ -1436,6 +1436,52 @@ static struct board_info __initdata boar
        },
  };
  
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4246,6 +4292,7 @@ static const struct board_info __initcon
+@@ -4247,6 +4293,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index f92ce6f023b076964864a2941802d488281bbb42..dc7a724968af523674347eb9bf75b07f82b80c6c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4238,6 +4238,108 @@ static struct board_info __initdata boar
+@@ -4239,6 +4239,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4324,6 +4426,7 @@ static const struct board_info __initcon
+@@ -4325,6 +4427,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index d9a704f97ac129eb79b2b14ec218a94e0a7b7e91..21ea5eae2e7beacf05c689a91022fc9628d2d9da 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4175,6 +4175,131 @@ static struct board_info __initdata boar
+@@ -4176,6 +4176,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4425,6 +4550,7 @@ static const struct board_info __initcon
+@@ -4426,6 +4551,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index f48eaeb20eb9083116b0c0a0fd1bb6a1fefeeb0a..8700c99d62c24f87ab3bd781489ae7e609927e44 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4169,6 +4170,118 @@ static struct board_info __initdata boar
+@@ -4170,6 +4171,118 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4548,6 +4661,7 @@ static const struct board_info __initcon
+@@ -4549,6 +4662,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 61afff60c80c922d5dcb146716b69298d8c79694..a40c41f427c3b8a83a1f84435c292091394b4aac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4171,6 +4171,117 @@ static struct board_info __initdata boar
+@@ -4172,6 +4172,117 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4661,6 +4772,7 @@ static const struct board_info __initcon
+@@ -4662,6 +4773,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 7ef72ec5358bbc380a94c9427a83a66b80c11deb..9b6457c689f21219cea9253976a5dfded729e7f7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4282,6 +4282,117 @@ static struct board_info __initdata boar
+@@ -4283,6 +4283,117 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4773,6 +4884,7 @@ static const struct board_info __initcon
+@@ -4774,6 +4885,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 9ba2226498a2e7d8c862952f4cfccdd8ed389bab..410e7e8e4e9ef10f6ff108508f39177e3939faa9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4180,6 +4180,97 @@ static struct sprom_fixup __initdata vr3
+@@ -4181,6 +4181,97 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -98,7 +98,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4883,6 +4974,7 @@ static const struct board_info __initcon
+@@ -4884,6 +4975,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 98287999ffa1992bc6c0d5c883b1cd48b01f1837..09033ff2373f819ba85be83a7577f54783b39dfb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3226,6 +3226,57 @@ static struct board_info __initdata boar
+@@ -3227,6 +3227,57 @@ static struct board_info __initdata boar
        .num_spis = ARRAY_SIZE(ct6373_spi_devices),
  };
  
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .of_board_id                                    = "huawei,hg553",
-@@ -4958,6 +5009,7 @@ static const struct board_info __initcon
+@@ -4959,6 +5010,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 2b90ee1b3902d6d4ecc85d63d4a5eaace9f369cc..877b1ead7fafe69a68a117948adad89e3d9ddd55 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -609,6 +609,96 @@ static struct board_info __initdata boar
+@@ -610,6 +610,96 @@ static struct board_info __initdata boar
        },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .of_board_id                    = "adb,a4001n1",
-@@ -4960,6 +5050,7 @@ static const struct board_info __initcon
+@@ -4961,6 +5051,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 877d62651d39e9feb6da48326288813d8985c28d..4fa6709446e5f38db0e172c7abf8b0e28995d9c9 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5044,6 +5179,7 @@ static const struct board_info __initcon
+@@ -5045,6 +5180,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index b88e0fcf5402d73d29b14ae259663a78d8ec1732..db4a094f68153a47f55b116a9ef6057d34367520 100644 (file)
@@ -5,6 +5,15 @@
 # See /LICENSE for more information.
 #
 
+define Profile/963281TAN
+  NAME:=Generic 963281TAN
+  PACKAGES:=
+endef
+define Profile/963281TAN/Description
+  Package set optimized for 963281TAN.
+endef
+$(eval $(call Profile,963281TAN))
+
 define Profile/96328avng
   NAME:=Generic 96328avng
   PACKAGES:=