ncurses: Do not pass both -fPIC and -fpic
authorRosen Penev <rosenp@gmail.com>
Tue, 27 Aug 2019 22:49:21 +0000 (15:49 -0700)
committerJo-Philipp Wich <jo@mein.io>
Wed, 4 Sep 2019 11:45:21 +0000 (13:45 +0200)
The configure scripts matches Linux with -fPIC, which is not exactly what
is desired. Since we are already passing $(FPIC), added a CONFIGURE_VAR to
avoid passing -fPIC.

Removed PKG_BUILD_DIR as it is already the default value.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit e2ecf39e8e49e43b4d358853f9da51e3897d042c)

package/libs/ncurses/Makefile

index 8c961f30b23d863ef71bebd629c3c3f25741df91..e22eb2b8935dd9a24ecbe5736a51a9d66791f1d2 100644 (file)
@@ -9,9 +9,8 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncurses
 PKG_VERSION:=6.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
 PKG_HASH:=aa057eeeb4a14d470101eff4597d5833dcef5965331be3528c08d99cebaa0d17
@@ -76,6 +75,9 @@ CONFIGURE_ARGS += \
        --enable-widec \
        --with-build-cppflags=-D_GNU_SOURCE
 
+CONFIGURE_VARS += \
+       cf_try_fPIC=no
+
 HOST_CFLAGS += $(HOST_FPIC)
 
 HOST_CONFIGURE_ARGS += \