openssl: disable mips16, it makes the code slower
authorFelix Fietkau <nbd@openwrt.org>
Fri, 10 May 2013 00:18:27 +0000 (00:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 10 May 2013 00:18:27 +0000 (00:18 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 36602

package/libs/openssl/Makefile

index 049aad44a8cd9a8ee6d6740b9a9354a8b44b1234..0091579985529105a54f75c89cd4ec405c14a0b2 100644 (file)
@@ -111,7 +111,7 @@ define Build/Configure
        )
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS := $(filter-out -mips16 -minterlink-mips16,$(TARGET_CFLAGS)) $(FPIC)
 
 define Build/Compile
        # XXX: OpenSSL "make depend" will look for installed headers before its own,