at91: sama5d4: fix bad mkubifs options
authorJo-Philipp Wich <jo@mein.io>
Sun, 13 May 2018 16:33:47 +0000 (18:33 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sun, 13 May 2018 16:33:47 +0000 (18:33 +0200)
Drop the "-x lzo" compression type override from MKUBIFS_OPTS since we
do not support it in mkfs.ubifs. Attempting to use LZO compression results
in "Error: bad compressor name".

The build system also appends an explicit "--compr=zlib" to the mkfs command
line, turning the "-x" flag into a no-op anyway.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/at91/image/sama5d4.mk

index 554b9890df24555f43089468938d907bd1a2cae2..1140c3c4b29baf663e5be16ee8f14d903cae9199 100644 (file)
@@ -13,7 +13,7 @@ define Device/at91-sama5d4_xplained
   BLOCKSIZE := 256k
   PAGESIZE := 4096
   SUBPAGESIZE := 2048
-  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
   $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d4_xplained