kernel: bump kernel 4.4 to version 4.4.139
authorHauke Mehrtens <hauke@hauke-m.de>
Tue, 3 Jul 2018 17:37:55 +0000 (19:37 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 3 Jul 2018 17:38:47 +0000 (19:38 +0200)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/apm821xx/patches-4.4/040-backport_leds-convert-IDE-trigger-to-common-disk-trigger.patch
target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch
target/linux/brcm47xx/patches-4.4/830-huawei_e970_support.patch
target/linux/cns3xxx/patches-4.4/075-spi_support.patch
target/linux/generic/patches-4.4/080-spi-introduce-accelerated-read-support-for-spi-flash.patch
target/linux/generic/patches-4.4/099-0007-qmi_wwan-add-support-for-Quectel-EC21-and-EC25.patch
target/linux/generic/patches-4.4/490-ubi-auto-attach-mtd-device-named-ubi-or-data-on-boot.patch
target/linux/generic/patches-4.4/834-ledtrig-libata.patch
target/linux/oxnas/patches-4.4/999-libata-hacks.patch

index 16467c63250c3c3762f7e8eb54a67b6fdfd83bfb..6b2c76d71fddf5375c91231803a8ffe259da2504 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .138
+LINUX_VERSION-4.4 = .139
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.138 = e6f9c64e17e0ba353e12fe97974319d6b633cd91e4f98144752c91c9372cc4ee
+LINUX_KERNEL_HASH-4.4.139 = b66055d4208d4a6fbee73065cd2b576d095b98ea8618f9b4eb952e18d3d6ed45
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index d5eda621eae30ae962840db42959b598d1a088f5..8e1d4d2c9d144e2d43cfd8db75106f686ef5b239 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Jacek Anaszewski <j.anaszewski@samsung.com>
  #include <linux/pm_runtime.h>
  #include <linux/platform_device.h>
  
-@@ -4945,6 +4946,9 @@ void ata_qc_complete(struct ata_queued_c
+@@ -4942,6 +4943,9 @@ void ata_qc_complete(struct ata_queued_c
  {
        struct ata_port *ap = qc->ap;
  
index 75fd16d7f4fc8fe1295c35cc04774b04cd77a248..965a0505426a10e94687aad41870e70604a9aa5b 100644 (file)
@@ -659,7 +659,7 @@ dwc_otg: Remove duplicate gadget probe/unregister function
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4995,7 +4995,7 @@ static void port_event(struct usb_hub *h
+@@ -4997,7 +4997,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index f67c5dde1ccd09b6b390510a5f53f91e97d1df27..5b360133f23576982504484a8096fc6facc97e69 100644 (file)
@@ -8,7 +8,7 @@
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
  #include <asm/prom.h>
-@@ -262,6 +263,33 @@ static struct fixed_phy_status bcm47xx_f
+@@ -268,6 +269,33 @@ static struct fixed_phy_status bcm47xx_f
        .duplex = DUPLEX_FULL,
  };
  
@@ -42,7 +42,7 @@
  static int __init bcm47xx_register_bus_complete(void)
  {
        switch (bcm47xx_bus_type) {
-@@ -281,6 +309,7 @@ static int __init bcm47xx_register_bus_c
+@@ -287,6 +315,7 @@ static int __init bcm47xx_register_bus_c
        bcm47xx_workarounds();
  
        fixed_phy_add(PHY_POLL, 0, &bcm47xx_fixed_phy_status, -1);
index 9011073c51a3368b63ddab1b416e74faa63f431e..b575b1c84ddc93b7067f6a391cda14dcb5c270b0 100644 (file)
@@ -39,7 +39,7 @@
  /**
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -933,6 +933,9 @@ static int spi_transfer_one_message(stru
+@@ -939,6 +939,9 @@ static int spi_transfer_one_message(stru
        list_for_each_entry(xfer, &msg->transfers, transfer_list) {
                trace_spi_transfer_start(msg, xfer);
  
index 5e116b0bbf5fabc92911e3eb046916b709cb4ca8..a717f1cee2ff5b0328f3a313a37536626c1ca03f 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -1135,6 +1135,7 @@ static void __spi_pump_messages(struct s
+@@ -1141,6 +1141,7 @@ static void __spi_pump_messages(struct s
                }
        }
  
@@ -32,7 +32,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
        trace_spi_message_start(master->cur_msg);
  
        if (master->prepare_message) {
-@@ -1144,6 +1145,7 @@ static void __spi_pump_messages(struct s
+@@ -1150,6 +1151,7 @@ static void __spi_pump_messages(struct s
                                "failed to prepare message: %d\n", ret);
                        master->cur_msg->status = ret;
                        spi_finalize_current_message(master);
@@ -40,7 +40,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
                        return;
                }
                master->cur_msg_prepared = true;
-@@ -1153,6 +1155,7 @@ static void __spi_pump_messages(struct s
+@@ -1159,6 +1161,7 @@ static void __spi_pump_messages(struct s
        if (ret) {
                master->cur_msg->status = ret;
                spi_finalize_current_message(master);
@@ -48,7 +48,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
                return;
        }
  
-@@ -1160,8 +1163,10 @@ static void __spi_pump_messages(struct s
+@@ -1166,8 +1169,10 @@ static void __spi_pump_messages(struct s
        if (ret) {
                dev_err(&master->dev,
                        "failed to transfer one message from queue\n");
@@ -59,7 +59,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
  }
  
  /**
-@@ -2329,6 +2334,46 @@ int spi_async_locked(struct spi_device *
+@@ -2335,6 +2340,46 @@ int spi_async_locked(struct spi_device *
  EXPORT_SYMBOL_GPL(spi_async_locked);
  
  
index 5940ac4994fe49ee8d6f8268d95f1bca2997afa4..016d87671371de43a66b3e68322211f9c83ac34c 100644 (file)
@@ -82,7 +82,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  /* Gobi 1000 QMI/wwan interface number is 3 according to qcserial */
  #define QMI_GOBI1K_DEVICE(vend, prod) \
        QMI_FIXED_INTF(vend, prod, 3)
-@@ -914,6 +938,8 @@ static const struct usb_device_id produc
+@@ -915,6 +939,8 @@ static const struct usb_device_id produc
        {QMI_FIXED_INTF(0x03f0, 0x9d1d, 1)},    /* HP lt4120 Snapdragon X5 LTE */
        {QMI_FIXED_INTF(0x22de, 0x9061, 3)},    /* WeTelecom WPD-600N */
        {QMI_FIXED_INTF(0x1e0e, 0x9001, 5)},    /* SIMCom 7230E */
index 648baa61f1fb8c140e82bb58dd2e5a4b6b88f882..7fd9d9c1b437116c4e3836be53416806c26f1384 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
 
 --- a/drivers/mtd/ubi/build.c
 +++ b/drivers/mtd/ubi/build.c
-@@ -1214,6 +1214,49 @@ static struct mtd_info * __init open_mtd
+@@ -1217,6 +1217,49 @@ static struct mtd_info * __init open_mtd
        return mtd;
  }
  
@@ -61,7 +61,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  static int __init ubi_init(void)
  {
        int err, i, k;
-@@ -1297,6 +1340,12 @@ static int __init ubi_init(void)
+@@ -1300,6 +1343,12 @@ static int __init ubi_init(void)
                }
        }
  
index ddac711bbd0f0941c6978a908b68a6882e3cc10b..ee8fe6bc49a28fac5dcc787a0f31211037796e59 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4811,6 +4824,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4808,6 +4821,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -5707,6 +5723,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5704,6 +5720,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5728,6 +5747,12 @@ static void ata_host_release(struct devi
+@@ -5725,6 +5744,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6174,7 +6199,23 @@ int ata_host_register(struct ata_host *h
+@@ -6171,7 +6196,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index e529cd39b3a04ce77cbcfda872ac1243b8a1acb1..83899e6f2b30fc88563aa82e5ac588e4888df501 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -4818,6 +4826,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4815,6 +4823,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -4863,6 +4874,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -4860,6 +4871,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);