uClibc: add -Wno-unused-but-set-variable to get rid of unnecessary warning logspam
authorFelix Fietkau <nbd@openwrt.org>
Sat, 30 Jun 2012 21:44:09 +0000 (21:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 30 Jun 2012 21:44:09 +0000 (21:44 +0000)
SVN-Revision: 32558

toolchain/uClibc/common.mk

index e466b9d57fee8899b6bb582c11943ce3bf3f1025..5f3bd29444f2a5460e7620511f1582e74a4a7c4f 100644 (file)
@@ -47,6 +47,7 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
 CPU_CFLAGS = \
        -funsigned-char -fno-builtin -fno-asm \
        --std=gnu99 -ffunction-sections -fdata-sections \
+       -Wno-unused-but-set-variable \
        $(TARGET_CFLAGS)
 
 UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \