armvirt: package and select Rockchip DWMAC Ethernet driver
authorMathew McBride <matt@traverse.com.au>
Tue, 18 Apr 2023 03:34:23 +0000 (03:34 +0000)
committerPetr Štetiar <ynezz@true.cz>
Fri, 2 Jun 2023 09:36:33 +0000 (11:36 +0200)
For devices that implement the "rockchip,*-gmac" compatible controller,
including:
- RK3328
- RK3399
- RK3568
- RK3588
- PX30

Signed-off-by: Mathew McBride <matt@traverse.com.au>
target/linux/armvirt/image/Makefile
target/linux/armvirt/modules.mk

index 533a17b52297693fa13eefb0ac240be7012e67c4..8642c88a49908da66af9174555f14f792f3c7208 100644 (file)
@@ -109,8 +109,8 @@ define Device/generic
        kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
        kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
        kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
-       kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
-       kmod-sfp kmod-phy-marvell-10g kmod-atlantic
+       kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
+       kmod-phy-marvell kmod-phy-marvell-10g kmod-sfp kmod-atlantic
 endef
 TARGET_DEVICES += generic
 
index 5c863824d373f79707b965721e7b0095d0e12278..c59301aae7e3b7a1489fc20d8b0b7a79344fcf6b 100644 (file)
@@ -245,6 +245,17 @@ endef
 
 $(eval $(call KernelPackage,dwmac-sun8i))
 
+define KernelPackage/dwmac-rockchip
+  SUBMENU=$(NETWORK_DEVICES_MENU)
+  TITLE:=Rockchip RK3328/RK3399/RK3568 Ethernet
+  DEPENDS:=+kmod-stmmac-core +kmod-mdio-bus-mux
+  KCONFIG:=CONFIG_DWMAC_ROCKCHIP
+  FILES=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/dwmac-rk.ko
+  AUTOLOAD=$(call AutoLoad,45,dwmac-rk)
+endef
+
+$(eval $(call KernelPackage,dwmac-rockchip))
+
 define KernelPackage/thunderx-net
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Marvell (Cavium) ThunderX/2 network drivers