package/ifx-vmmc: move configuration in submenu
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:07:18 +0000 (11:07 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:07:18 +0000 (11:07 +0000)
SVN-Revision: 20917

package/ifx-vmmc/Config.in
package/ifx-vmmc/Makefile

index bd3c032d3a122aaac2ef8cdfc9ad7e5afd1b83e1..2a7894e7f0f1419ca2557bb5ab436af0be59245e 100644 (file)
@@ -1,3 +1,5 @@
+menu "Configuration"
+       depends on PACKAGE_kmod-ifx-vmmc
 choice
        prompt "device selection"
        default VOICE_CPE_VMMC_WITH_DEVICE_DANUBE_extract
@@ -47,3 +49,5 @@ config VOICE_CPE_VMMC_MPS_HISTORY_SIZE
                MPS history buffer (default=128 words, maximum=512 words, 0=disable)
                To opimize the memory footprint in RAM, you might want to set the
                buffer size to 0.
+
+endmenu
index 945d5ba7efa8558e73750d7da694ca4c594b43c9..0fa3649e9cafb66228d1a20449bb46f9eab137e6 100644 (file)
@@ -26,6 +26,7 @@ define KernelPackage/ifx-vmmc
   DEPENDS:=+kmod-ifx-tapi @BROKEN
   FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,25,drv_vmmc)
+  MENU:=1
 endef
 
 define KernelPackage/ifx-vmmc/description
@@ -33,9 +34,7 @@ define KernelPackage/ifx-vmmc/description
 endef
 
 define KernelPackage/ifx-vmmc/config
-       if PACKAGE_kmod-ifx-vmmc
-               source "$(SOURCE)/Config.in"
-       endif
+       source "$(SOURCE)/Config.in"
 endef
 
 CONFIGURE_ARGS += \