kernel: bump 4.14 to 4.14.112
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 18 Apr 2019 13:11:42 +0000 (15:11 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Apr 2019 19:16:53 +0000 (21:16 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/config-4.14
target/linux/mvebu/patches-4.14/408-sfp-move-module-eeprom-ethtool-access-into-netdev-co.patch

index 1ebd465b63920a17dadfff1a0a47aae86b5a27f0..d77dd15f368503fca2887f9590c78e4803ef2e9d 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .169
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .169
-LINUX_VERSION-4.14 = .111
+LINUX_VERSION-4.14 = .112
 
 LINUX_KERNEL_HASH-4.9.169 = b776636c63a555961cfe9f6f4a315e65ab0ff3376acdb3cf5ad654808ff8d6b0
 
 LINUX_KERNEL_HASH-4.9.169 = b776636c63a555961cfe9f6f4a315e65ab0ff3376acdb3cf5ad654808ff8d6b0
-LINUX_KERNEL_HASH-4.14.111 = f8197d56553f864d1d2e97abbe4fca50f8ab5e72089c292d22f0e4395340a6e8
+LINUX_KERNEL_HASH-4.14.112 = 326101e2cc80a0d7e643074fe9e63f0d6a9c8cf97033f8a07848de373203e472
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index ea5aeed90a4d76d3249c31098d5bf997983f8372..10aba65a72d06985f5db066556cfdccde111dddc 100644 (file)
@@ -2269,6 +2269,7 @@ CONFIG_LBDAF=y
 # CONFIG_LCD_S6E63M0 is not set
 # CONFIG_LCD_TDO24M is not set
 # CONFIG_LCD_VGG2432A4 is not set
 # CONFIG_LCD_S6E63M0 is not set
 # CONFIG_LCD_TDO24M is not set
 # CONFIG_LCD_VGG2432A4 is not set
+CONFIG_LDISC_AUTOLOAD=y
 # CONFIG_LDM_PARTITION is not set
 CONFIG_LD_DEAD_CODE_DATA_ELIMINATION=y
 # CONFIG_LEDS_BCM6328 is not set
 # CONFIG_LDM_PARTITION is not set
 CONFIG_LD_DEAD_CODE_DATA_ELIMINATION=y
 # CONFIG_LEDS_BCM6328 is not set
index 540ef51ba476028925d8bdbdab38b8d04f742df3..1de8caab8bdae7c3f9b6aea35460f6c7b3e45760 100644 (file)
@@ -159,7 +159,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  #include <linux/slab.h>
  #include <linux/rtnetlink.h>
  #include <linux/sched/signal.h>
  #include <linux/slab.h>
  #include <linux/rtnetlink.h>
  #include <linux/sched/signal.h>
-@@ -2190,6 +2191,9 @@ static int __ethtool_get_module_info(str
+@@ -2201,6 +2202,9 @@ static int __ethtool_get_module_info(str
        const struct ethtool_ops *ops = dev->ethtool_ops;
        struct phy_device *phydev = dev->phydev;
  
        const struct ethtool_ops *ops = dev->ethtool_ops;
        struct phy_device *phydev = dev->phydev;
  
@@ -169,7 +169,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
        if (phydev && phydev->drv && phydev->drv->module_info)
                return phydev->drv->module_info(phydev, modinfo);
  
        if (phydev && phydev->drv && phydev->drv->module_info)
                return phydev->drv->module_info(phydev, modinfo);
  
-@@ -2224,6 +2228,9 @@ static int __ethtool_get_module_eeprom(s
+@@ -2235,6 +2239,9 @@ static int __ethtool_get_module_eeprom(s
        const struct ethtool_ops *ops = dev->ethtool_ops;
        struct phy_device *phydev = dev->phydev;
  
        const struct ethtool_ops *ops = dev->ethtool_ops;
        struct phy_device *phydev = dev->phydev;