ar71xx: add profile and build image for the TL-WA701N/ND boards
authorGabor Juhos <juhosg@openwrt.org>
Wed, 4 Jan 2012 17:30:54 +0000 (17:30 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 4 Jan 2012 17:30:54 +0000 (17:30 +0000)
SVN-Revision: 29656

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index c9f0cacb1eb186d5cec0b77bf6a2668d42456322..2b9aa0e2186852bc09c06121166d24cb21e9522e 100644 (file)
@@ -50,6 +50,17 @@ endef
 $(eval $(call Profile,TLWR703))
 
 
+define Profile/TLWA701
+       NAME:=TP-LINK TL-WA701N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWA701/Description
+       Package set optimized for the TP-LINK TL-WA701N/ND.
+endef
+$(eval $(call Profile,TLWA701))
+
+
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
        PACKAGES:=
index 4b90429eddbac83f154adc636d58db7ae2d41a9e..0a52b63755617feb0f9324bc0941331aa701dbf5 100644 (file)
@@ -780,6 +780,11 @@ define Image/Build/Profile/TLMR3420
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-mr3420-v1,$(tlmr3420_cmdline),0x34200001,1,4M)
 endef
 
+tlwa701_cmdline=board=TL-WA901ND console=ttyS0,115200
+define Image/Build/Profile/TLWA701
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wa701n-v1,$(tlwa701_cmdline),0x07010001,1,4M)
+endef
+
 tlwa901_cmdline=board=TL-WA901ND console=ttyS0,115200
 tlwa901v2_cmdline=board=TL-WA901ND-v2 console=ttyS0,115200
 define Image/Build/Profile/TLWA901
@@ -941,6 +946,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLMR3020,$(1))
        $(call Image/Build/Profile/TLMR3220,$(1))
        $(call Image/Build/Profile/TLMR3420,$(1))
+       $(call Image/Build/Profile/TLWA701,$(1))
        $(call Image/Build/Profile/TLWA901,$(1))
        $(call Image/Build/Profile/TLWR703,$(1))
        $(call Image/Build/Profile/TLWR740,$(1))