tools: add expat library (to be used by gdb)
authorFelix Fietkau <nbd@openwrt.org>
Fri, 10 Jul 2015 19:42:05 +0000 (19:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 10 Jul 2015 19:42:05 +0000 (19:42 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 46297

tools/Makefile
tools/expat/Makefile [new file with mode: 0644]

index 2f516d2383e5f9ae5465adebd3d9fb3bd7674e68..8b5dd6c5207945826085a65636f3a30609e8eb79 100644 (file)
@@ -23,7 +23,7 @@ ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy)$(CONFIG_BRCMSM
   BUILD_B43_TOOLS = y
 endif
 
-tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf
+tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf expat
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
diff --git a/tools/expat/Makefile b/tools/expat/Makefile
new file mode 100644 (file)
index 0000000..dfd5f28
--- /dev/null
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=expat
+PKG_VERSION:=2.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=dd7dab7a5fea97d2a6a43f511449b7cd
+PKG_SOURCE_URL:=@SF/expat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+       $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+$(eval $(call HostBuild))