ath79: Add support for OpenMesh MR1750 v1
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 19 Jan 2021 20:41:26 +0000 (21:41 +0100)
Device specifications:
======================

* Qualcomm/Atheros QCA9558 ver 1 rev 0
* 720/600/240 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 3T3R 2.4 GHz Wi-Fi (11n)
* 3T3R 5 GHz Wi-Fi (11ac)
* 6x GPIO-LEDs (2x wifi, 2x status, 1x lan, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 1x ethernet
  - AR8035 ethernet PHY (RGMII)
  - 10/100/1000 Mbps Ethernet
  - 802.3af POE
  - used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[rebase, apply shared DTSI/device node, add LED migration]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 15994cec381d0658a33e340c5047e3ca465cebc4..dfb77112a7ea62c3bbaef0392f1bfb7b10c7d580 100644 (file)
@@ -52,6 +52,7 @@ openmesh,mr600-v1|\
 openmesh,mr600-v2|\
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
 openmesh,mr600-v2|\
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
+openmesh,mr1750-v1|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts b/target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts
new file mode 100644 (file)
index 0000000..11eb6df
--- /dev/null
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_mr.dtsi"
+
+/ {
+       compatible = "openmesh,mr1750-v1", "qca,qca9558";
+       model = "OpenMesh MR1750 v1";
+};
+
+&led_wifi2g {
+       linux,default-trigger = "phy1tpt";
+};
+
+&led_wifi5g {
+       linux,default-trigger = "phy0tpt";
+};
index 8fba9bc0e71b15a88cbc32e0bae2ad6fed887235..2cdad7dd7744937ae57986dadbbd7e254b8981a4 100755 (executable)
@@ -159,7 +159,8 @@ comfast,cf-wr752ac-v1|\
 engenius,eap300-v2|\
 enterasys,ws-ap3705i|\
 openmesh,mr900-v1|\
 engenius,eap300-v2|\
 enterasys,ws-ap3705i|\
 openmesh,mr900-v1|\
-openmesh,mr900-v2)
+openmesh,mr900-v2|\
+openmesh,mr1750-v1)
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
index 76bbd92c210d5a89b5a894b6e4782121b2549849..ef6b70c9023a8871616e704b963d10a2000b890e 100755 (executable)
@@ -50,6 +50,7 @@ ath79_setup_interfaces()
        openmesh,mr600-v2|\
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
        openmesh,mr600-v2|\
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
+       openmesh,mr1750-v1|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
index 99d2353ac163328082b34e5dfa973e1ad53d9fb3..d1a47676482759512ab46d3cb692d9f5ec839f03 100644 (file)
@@ -96,6 +96,10 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(mtd_get_mac_binary art 0xc)
                ;;
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(mtd_get_mac_binary art 0xc)
                ;;
+       openmesh,mr1750-v1)
+               caldata_extract "ART" 0x5000 0x844
+               ath10k_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
+               ;;
        openmesh,om5p-ac-v2)
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
        openmesh,om5p-ac-v2)
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
index 453bf3b9112fb8a806addedcc83fa6e0d37d6c5b..1d8909f688795fdcb3bb49d903f88fdd1acf9d67 100644 (file)
@@ -24,7 +24,8 @@ openmesh,mr600-v2)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
        ;;
 openmesh,mr900-v1|\
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
        ;;
 openmesh,mr900-v1|\
-openmesh,mr900-v2)
+openmesh,mr900-v2|\
+openmesh,mr1750-v1)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
        ;;
 pcs,cap324)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
        ;;
 pcs,cap324)
index 76512758b6746230b8bf5a67bfaf1848a420fdb5..01a9f619433c8861d9d0e04b798f8b4434d2d933 100644 (file)
@@ -54,6 +54,7 @@ platform_do_upgrade() {
        openmesh,mr600-v2|\
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
        openmesh,mr600-v2|\
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
+       openmesh,mr1750-v1|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
index 3d569c9532d557e91dbc2a86ab80eb448eaf5624..92e9458b378625b1bd72689bc57aa08c23385afb 100644 (file)
@@ -1590,6 +1590,17 @@ define Device/openmesh_mr900-v2
 endef
 TARGET_DEVICES += openmesh_mr900-v2
 
 endef
 TARGET_DEVICES += openmesh_mr900-v2
 
+define Device/openmesh_mr1750-v1
+  $(Device/openmesh_common_64k)
+  SOC := qca9558
+  DEVICE_MODEL := MR1750
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  OPENMESH_CE_TYPE := MR1750
+  SUPPORTED_DEVICES += mr1750
+endef
+TARGET_DEVICES += openmesh_mr1750-v1
+
 define Device/openmesh_om2p-v2
   $(Device/openmesh_common_256k)
   SOC := ar9330
 define Device/openmesh_om2p-v2
   $(Device/openmesh_common_256k)
   SOC := ar9330