kernel/modules: move ixp4xx hardware crypto module package into crypto.mk
authorGabor Juhos <juhosg@openwrt.org>
Tue, 18 Nov 2008 19:38:50 +0000 (19:38 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 18 Nov 2008 19:38:50 +0000 (19:38 +0000)
SVN-Revision: 13281

package/kernel/modules/crypto.mk
package/kernel/modules/other.mk

index 8bb57816c0b7d8f4c1e8756caa94dd93e3a3b4ac..a63f855d51ce03f6a0ba899ad6ab64d096dc4470 100644 (file)
@@ -30,7 +30,7 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.26)),1)
   SHA512_SUFFIX:=$(CRYPTO_GENERIC)
 endif
 
-# XXX: added CONFIG_CRYPTO_HMAC to KCONFIG so that CONFIG_CRYPTO_HASH is 
+# XXX: added CONFIG_CRYPTO_HMAC to KCONFIG so that CONFIG_CRYPTO_HASH is
 # always set, even if no hash modules are selected
 define KernelPackage/crypto-core
   SUBMENU:=$(CRYPTO_MENU)
@@ -116,6 +116,24 @@ endef
 $(eval $(call KernelPackage,crypto-hw-hifn-795x))
 
 
+define KernelPackage/crypto-hw-ixp4xx
+  SUBMENU:=$(CRYPTO_MENU)
+  TITLE:=Intel IXP4xx hardware crypto module
+  DEPENDS:= \
+       @TARGET_ixp4xx +kmod-crypto-core +kmod-crypto-des +kmod-crypto-aead \
+       +kmod-crypto-authenc
+  KCONFIG:= CONFIG_CRYPTO_DEV_IXP4XX
+  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+  Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))
+
+
 define KernelPackage/crypto-aes
   SUBMENU:=$(CRYPTO_MENU)
   TITLE:=AES cipher CryptoAPI module
index bcfb448544062344542356ae0c735d0acc42ce2c..513517d26cd62e79ecc39ad9a2c53f5f07babb16 100644 (file)
@@ -681,22 +681,3 @@ define KernelPackage/spi-dev/description
 endef
 
 $(eval $(call KernelPackage,spi-dev))
-
-define KernelPackage/crypto-dev-ixp4xx
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=IXP4xx crypto driver
-  DEPENDS:=\
-       @TARGET_ixp4xx +kmod-crypto-core +kmod-crypto-des +kmod-crypto-aead \
-       +kmod-crypto-authenc
-  KCONFIG:=\
-       CONFIG_CRYPTO_HW=y \
-       CONFIG_CRYPTO_DEV_IXP4XX
-  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
-endef
-
-define KernelPackage/crypto-dev-ixp4xx/description
- Kernel support for the IXP4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-dev-ixp4xx))