ar71xx: Fix build for dap-1330-a1 board
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 21 May 2018 13:22:00 +0000 (15:22 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 22 May 2018 05:20:26 +0000 (07:20 +0200)
Using a version number of 16 character causes a buffer overflow in the
version number overwriting the first bit of the signature in the
mkdapimg2 tool.
I am not sure if the version number should be null terminated or not.
This patch reduces the size of the version number by removing the number
of private commits from it.

This was the original version number which caused problems:
OpenWrt-r6727+10
Now it uses this version number:
OpenWrt-r6727

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ar71xx/image/generic.mk

index a0f6326145b55b46761fec7f224a9465c6b47459..020e01f85a08b5fe858845bd4a6085b3f8ebb647 100644 (file)
@@ -36,7 +36,7 @@ define Build/mkdapimg2
        $(STAGING_DIR_HOST)/bin/mkdapimg2 \
                -i $@ -o $@.new \
                -s $(DAP_SIGNATURE) \
-               -v $(VERSION_DIST)-$(firstword $(subst -, ,$(REVISION))) \
+               -v $(VERSION_DIST)-$(firstword $(subst +, ,$(firstword $(subst -, ,$(REVISION))))) \
                -r Default \
                $(if $(1),-k $(1))
        mv $@.new $@