lantiq: use wpad-basic for boards with enough storage
authorJohann Neuhauser <johann@it-neuhauser.de>
Mon, 29 Jul 2019 17:44:17 +0000 (19:44 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 11 Aug 2019 10:54:57 +0000 (12:54 +0200)
This commit selects wpad-basic for the FRITZ!Box 7312 and 7412 as
wpad-mini is only selected on boards with small flash.

Signed-off-by: Johann Neuhauser <johann@it-neuhauser.de>
[add short description]
Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit c3c3cd5e4a86acfc83449c47c5f87779a800bdc7)

target/linux/lantiq/image/Makefile

index fca3fce47c9b062431c7b8b3b6fb13d269e43715..2352cb6b5e42eeb8dd7752bd31da90cda6ca79e2 100644 (file)
@@ -490,7 +490,7 @@ define Device/avm_fritz7312
   DEVICE_DTS := FRITZ7312
   IMAGE_SIZE := 15744k
   DEVICE_TITLE := AVM FRITZ!Box 7312
-  DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-mini \
+  DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic \
        kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
        kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
        ltq-adsl-app ppp-mod-pppoa \
@@ -673,7 +673,7 @@ define Device/avm_fritz7412
   KERNEL_SIZE := 4096k
   IMAGE_SIZE := 49152k
   DEVICE_TITLE := AVM FRITZ!Box 7412
-  DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-mini kmod-ltq-tapi kmod-ltq-vmmc fritz-tffs-nand fritz-caldata
+  DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-ltq-tapi kmod-ltq-vmmc fritz-tffs-nand fritz-caldata
 endef
 TARGET_DEVICES += avm_fritz7412