ar71xx: add support for ALFA Network R36A
authorPiotr Dymacz <pepe2k@gmail.com>
Thu, 28 Dec 2017 10:07:54 +0000 (11:07 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Sun, 14 Jan 2018 23:12:13 +0000 (00:12 +0100)
ALFA Network R36A is a successor of the previous model, the R36 (Ralink
RT3050F based). New version is based on Qualcomm/Atheros QCA9531 v2.

Specification:

- 650/400/200 MHz (CPU/DDR/AHB)
- 64 MB of RAM (DDR2)
- 16 MB of FLASH (SPI NOR)
- 2x 10/100 Mbps Ethernet, with passive PoE support (24 V)
- 2T2R (QCA9531) 2.4 GHz, 2x u.fl connectors on PCB
- 1x USB 2.0 (power controlled by GPIO)
- 6x LED (5 of them are driven by GPIO)
- 2x button (reset, wifi/wps)
- external h/w watchdog (EM6324QYSP5B, disabled and not used)
- DC jack for main power input (12 V)
- UART header on PCB

Flash instruction:

You can use sysupgrade image directly in vendor firmware which is based
on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot:

1. Configure PC with static IP 192.168.1.2/24.
2. Connect PC with one of RJ45 ports, press the reset button, power up
   device, wait for first blink of all LEDs (indicates network setup),
   then keep button for 3 following blinks and release it.
3. Open 192.168.1.1 address in your browser and upload sysupgrade image.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
12 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-r36a.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/generic/config-default
target/linux/ar71xx/image/generic.mk

index 02f3ad911ac6e04b6dde1b89ca804d3f186b09d2..f39109af445738f6c329b81dee0bb392e691cbc9 100755 (executable)
@@ -580,6 +580,12 @@ pqi-air-pen)
 qihoo-c301)
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "qihoo:red:status" "phy1tpt"
        ;;
 qihoo-c301)
        ucidef_set_led_wlan "wlan2g" "WLAN2G" "qihoo:red:status" "phy1tpt"
        ;;
+r36a)
+       ucidef_set_led_netdev "lan" "LAN" "$board:blue:lan" "eth0"
+       ucidef_set_led_usbdev "usb" "USB" "$board:blue:usb" "1-1"
+       ucidef_set_led_netdev "wan" "WAN" "$board:blue:wan" "eth1"
+       ucidef_set_led_wlan "wlan" "WLAN" "$board:blue:wlan" "phy0tpt"
+       ;;
 r602n|\
 zbt-we1526)
        ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
 r602n|\
 zbt-we1526)
        ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
index 1dece96f8410e9216169981ec074d0d1267d5280..00ddeeac50695e3888e6175b9b4bdfc15de52c6f 100644 (file)
@@ -181,7 +181,8 @@ get_status_led() {
        oolite)
                status_led="$board:red:system"
                ;;
        oolite)
                status_led="$board:red:system"
                ;;
-       dw33d)
+       dw33d|\
+       r36a)
                status_led="$board:blue:status"
                ;;
        eap300v2)
                status_led="$board:blue:status"
                ;;
        eap300v2)
index 1419579d83107d905109531db14db26ad993aa87..d62dff593e9ab7a95266dbf8c38ebc31bf874a2a 100755 (executable)
@@ -847,6 +847,9 @@ ar71xx_board_detect() {
        *"Qihoo 360 C301")
                name="qihoo-c301"
                ;;
        *"Qihoo 360 C301")
                name="qihoo-c301"
                ;;
+       *"R36A")
+               name="r36a"
+               ;;
        *"R602N")
                name="r602n"
                ;;
        *"R602N")
                name="r602n"
                ;;
index 86d047679046ebeb1aadca9e4a0afe364f0d5d12..108c90b1fea22dafe079b3b0493a32517a829c40 100755 (executable)
@@ -257,6 +257,7 @@ platform_check_image() {
        nanostation-m-xw|\
        nbg460n_550n_550nh|\
        pqi-air-pen|\
        nanostation-m-xw|\
        nbg460n_550n_550nh|\
        pqi-air-pen|\
+       r36a|\
        r602n|\
        rocket-m|\
        rocket-m-ti|\
        r602n|\
        rocket-m|\
        rocket-m-ti|\
index 1dc7127bfbc7cfe9c6a4b9bb7c87744dd9bd7773..44303f1be03ed14955e7b9cbd271811f5dc14641 100644 (file)
@@ -153,6 +153,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_PB44 is not set
 # CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
 # CONFIG_ATH79_MACH_QIHOO_C301 is not set
 # CONFIG_ATH79_MACH_PB44 is not set
 # CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
 # CONFIG_ATH79_MACH_QIHOO_C301 is not set
+# CONFIG_ATH79_MACH_R36A is not set
 # CONFIG_ATH79_MACH_R602N is not set
 # CONFIG_ATH79_MACH_R6100 is not set
 # CONFIG_ATH79_MACH_RAMBUTAN is not set
 # CONFIG_ATH79_MACH_R602N is not set
 # CONFIG_ATH79_MACH_R6100 is not set
 # CONFIG_ATH79_MACH_RAMBUTAN is not set
index 78393b13f409a87f715eec89d6bcab2a101fa528..1e4b3ab87de6ab8830e76b4c44ecd086a0afd8d0 100644 (file)
@@ -151,6 +151,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_PB44 is not set
 # CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
 # CONFIG_ATH79_MACH_QIHOO_C301 is not set
 # CONFIG_ATH79_MACH_PB44 is not set
 # CONFIG_ATH79_MACH_PQI_AIR_PEN is not set
 # CONFIG_ATH79_MACH_QIHOO_C301 is not set
+# CONFIG_ATH79_MACH_R36A is not set
 # CONFIG_ATH79_MACH_R602N is not set
 # CONFIG_ATH79_MACH_R6100 is not set
 # CONFIG_ATH79_MACH_RAMBUTAN is not set
 # CONFIG_ATH79_MACH_R602N is not set
 # CONFIG_ATH79_MACH_R6100 is not set
 # CONFIG_ATH79_MACH_RAMBUTAN is not set
index 2b7e086e2c894e8ae839bfb8c28f06840d9698c4..dae68d0fb7dce2a3c109a334721575783c8e001c 100644 (file)
@@ -934,6 +934,16 @@ config ATH79_MACH_WRTNODE2Q
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_R36A
+       bool "ALFA Network R36A support"
+       select SOC_QCA953X
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_R602N
        bool "P&W R602N support"
        select SOC_QCA953X
 config ATH79_MACH_R602N
        bool "P&W R602N support"
        select SOC_QCA953X
index 4f3bb97e33653565d56b8d069fb8221a8a09ccca..b7caa5a77012c952b1ce99b6398355f1e034bee2 100644 (file)
@@ -162,6 +162,7 @@ obj-$(CONFIG_ATH79_MACH_PB42)                       += mach-pb42.o
 obj-$(CONFIG_ATH79_MACH_PB44)                  += mach-pb44.o
 obj-$(CONFIG_ATH79_MACH_PQI_AIR_PEN)           += mach-pqi-air-pen.o
 obj-$(CONFIG_ATH79_MACH_QIHOO_C301)            += mach-qihoo-c301.o
 obj-$(CONFIG_ATH79_MACH_PB44)                  += mach-pb44.o
 obj-$(CONFIG_ATH79_MACH_PQI_AIR_PEN)           += mach-pqi-air-pen.o
 obj-$(CONFIG_ATH79_MACH_QIHOO_C301)            += mach-qihoo-c301.o
+obj-$(CONFIG_ATH79_MACH_R36A)                  += mach-r36a.o
 obj-$(CONFIG_ATH79_MACH_R602N)                 += mach-r602n.o
 obj-$(CONFIG_ATH79_MACH_R6100)                 += mach-r6100.o
 obj-$(CONFIG_ATH79_MACH_RB2011)                        += mach-rb2011.o
 obj-$(CONFIG_ATH79_MACH_R602N)                 += mach-r602n.o
 obj-$(CONFIG_ATH79_MACH_R6100)                 += mach-r6100.o
 obj-$(CONFIG_ATH79_MACH_RB2011)                        += mach-rb2011.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-r36a.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-r36a.c
new file mode 100644 (file)
index 0000000..b3493e2
--- /dev/null
@@ -0,0 +1,140 @@
+/*
+ * ALFA Network R36A board support
+ *
+ * Copyright (C) 2018 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define R36A_GPIO_LED_LAN      4
+#define R36A_GPIO_LED_STATUS   14
+#define R36A_GPIO_LED_USB      12
+#define R36A_GPIO_LED_WAN      16
+#define R36A_GPIO_LED_WLAN     15
+
+#define R36A_GPIO_WDT_EN       1
+#define R36A_GPIO_WDT_IN       0
+#define R36A_GPIO_USB_PWR      3
+
+#define R36A_GPIO_BTN_RESET    2
+#define R36A_GPIO_BTN_RFKILL   17
+
+#define R36A_KEYS_POLL_INTERVAL                20
+#define R36A_KEYS_DEBOUNCE_INTERVAL    (3 * R36A_KEYS_POLL_INTERVAL)
+
+#define R36A_WMAC_CALDATA_OFFSET       0x1000
+
+static struct gpio_led r36a_leds_gpio[] __initdata = {
+       {
+               .name           = "r36a:blue:lan",
+               .gpio           = R36A_GPIO_LED_LAN,
+               .active_low     = 1,
+       }, {
+               .name           = "r36a:blue:status",
+               .gpio           = R36A_GPIO_LED_STATUS,
+               .active_low     = 1,
+       }, {
+               .name           = "r36a:blue:usb",
+               .gpio           = R36A_GPIO_LED_USB,
+               .active_low     = 1,
+       }, {
+               .name           = "r36a:blue:wan",
+               .gpio           = R36A_GPIO_LED_WAN,
+               .active_low     = 1,
+       }, {
+               .name           = "r36a:blue:wlan",
+               .gpio           = R36A_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button r36a_gpio_keys[] __initdata = {
+       {
+               .desc                   = "reset",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = R36A_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = R36A_GPIO_BTN_RESET,
+               .active_low             = 1,
+       }, {
+               .desc                   = "rfkill",
+               .type                   = EV_KEY,
+               .code                   = KEY_RFKILL,
+               .debounce_interval      = R36A_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = R36A_GPIO_BTN_RFKILL,
+               .active_low             = 1,
+       },
+};
+
+static void __init r36a_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1f070000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       ath79_register_mdio(0, 0x0);
+
+       ath79_switch_data.phy4_mii_en = 1;
+       ath79_switch_data.phy_poll_mask = 0xf7;
+
+       /* LAN */
+       ath79_eth0_data.duplex = DUPLEX_FULL;
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+       ath79_eth0_data.phy_mask = BIT(4);
+       ath79_eth0_data.speed = SPEED_100;
+       ath79_init_mac(ath79_eth0_data.mac_addr, art, 0);
+       ath79_register_eth(0);
+
+       /* WAN */
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_init_mac(ath79_eth1_data.mac_addr, art, 1);
+       ath79_register_eth(1);
+
+       /* Disable JTAG (enables GPIO0-3) */
+       ath79_gpio_function_enable(AR934X_GPIO_FUNC_JTAG_DISABLE);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(r36a_leds_gpio),
+                                r36a_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, R36A_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(r36a_gpio_keys),
+                                       r36a_gpio_keys);
+
+       gpio_request_one(R36A_GPIO_WDT_IN,
+                        GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+                        "WDT input");
+
+       gpio_request_one(R36A_GPIO_WDT_EN,
+                        GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+                        "WDT enable");
+
+       gpio_request_one(R36A_GPIO_USB_PWR,
+                        GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+                        "USB power");
+
+       ath79_register_wmac(art + R36A_WMAC_CALDATA_OFFSET, NULL);
+
+       ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_R36A, "R36A", "ALFA Network R36A", r36a_setup);
index 40ac0343887c00983640f3e547a90148896692c6..4afda05638f30a690fcecaf9a5d892590e9dd304 100644 (file)
@@ -166,6 +166,7 @@ enum ath79_mach_type {
        ATH79_MACH_PB44,                        /* Atheros PB44 reference board */
        ATH79_MACH_PQI_AIR_PEN,                 /* PQI Air Pen */
        ATH79_MACH_QIHOO_C301,                  /* Qihoo 360 C301 */
        ATH79_MACH_PB44,                        /* Atheros PB44 reference board */
        ATH79_MACH_PQI_AIR_PEN,                 /* PQI Air Pen */
        ATH79_MACH_QIHOO_C301,                  /* Qihoo 360 C301 */
+       ATH79_MACH_R36A,                        /* ALFA Network R36A */
        ATH79_MACH_R602N,                       /* P&W R602N */
        ATH79_MACH_R6100,                       /* NETGEAR R6100 */
        ATH79_MACH_RAMBUTAN,                    /* 8devices Rambutan */
        ATH79_MACH_R602N,                       /* P&W R602N */
        ATH79_MACH_R6100,                       /* NETGEAR R6100 */
        ATH79_MACH_RAMBUTAN,                    /* 8devices Rambutan */
index 15116f5500e3e5585666d6f6bd3c279d33da234a..06d5223d6cbbd74c66bc700813a9e709c2336066 100644 (file)
@@ -120,6 +120,7 @@ CONFIG_ATH79_MACH_PB42=y
 CONFIG_ATH79_MACH_PB44=y
 CONFIG_ATH79_MACH_PQI_AIR_PEN=y
 CONFIG_ATH79_MACH_QIHOO_C301=y
 CONFIG_ATH79_MACH_PB44=y
 CONFIG_ATH79_MACH_PQI_AIR_PEN=y
 CONFIG_ATH79_MACH_QIHOO_C301=y
+CONFIG_ATH79_MACH_R36A=y
 CONFIG_ATH79_MACH_R602N=y
 CONFIG_ATH79_MACH_RE450=y
 CONFIG_ATH79_MACH_RUT9XX=y
 CONFIG_ATH79_MACH_R602N=y
 CONFIG_ATH79_MACH_RE450=y
 CONFIG_ATH79_MACH_RUT9XX=y
index 3fbfca35e0cc510984d154092ade84d0d72778ef..b7956ff54e31813b26c937ad5b7da120361251f9 100644 (file)
@@ -631,6 +631,18 @@ define Device/jwap230
 endef
 TARGET_DEVICES += jwap230
 
 endef
 TARGET_DEVICES += jwap230
 
+define Device/r36a
+  DEVICE_TITLE := ALFA Network R36A
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport -swconfig
+  BOARDNAME := R36A
+  SUPPORTED_DEVICES := r36a
+  IMAGE_SIZE := 15872k
+  MTDPARTS := spi0.0:384k(u-boot)ro,64k(u-boot-env),64k(art)ro,-(firmware)
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += r36a
+
 define Device/r602n
   DEVICE_TITLE := P&W R602N
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
 define Device/r602n
   DEVICE_TITLE := P&W R602N
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2