comgt-ncm: add driver dependencies again
authorVincent Wiemann <vincent.wiemann@ironai.com>
Sun, 4 Aug 2019 23:42:45 +0000 (01:42 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 4 Sep 2019 11:36:59 +0000 (13:36 +0200)
In the commit 623716dd4318 ("comgt-ncm: Fix NCM protocol")
the dependencies to vendor NCM drivers were removed, because:

> comgt-ncm should not depend on the USB-serial-related kernel modules,
> as the cdc-wdm control device works without them. There is also no need
> to depend on kmod-huawei-cdc-ncm, since other manufacturers (like
> Ericsson and Samsung) which use other kernel modules should also be
> supported.

From a user-perspective this does not make sense, as installing comgt-ncm
(or luci-proto-ncm) should install all needed dependencies for using such
a device.

Furthermore depending on kmod-huawei-cdc-ncm does not mean that Ericsson
and Samsung devices can't be supported. By the way it seems that Ericsson
and Samsung devices never used NCM, but act as serial modems.

Thus this commit adds the dependencies again.

Signed-off-by: Vincent Wiemann <vincent.wiemann@ironai.com>
[fixed title capitalization, formatted commit message,
renamed Sony-Ericsson to Ericsson]
Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit ccb4b96b8a4990178512c7a785f998a5e6f74cc3)

package/network/utils/comgt/Makefile

index 58466f498c61c390b462f5ed927bf2f83c90cbee..64296c9852e492aeeee8c1bf6d6de5d39bfc811f 100644 (file)
@@ -47,7 +47,7 @@ endef
 define Package/comgt-ncm
 $(call Package/comgt/Default)
   TITLE+=NCM 3G/4G Support
-  DEPENDS:=+comgt +wwan
+  DEPENDS:=+comgt +wwan +kmod-usb-serial-option +kmod-usb-net-huawei-cdc-ncm
 endef
 
 define Package/comgt/description