kernel: ebtables depends on bridge
authorJonas Gorski <jogo@openwrt.org>
Tue, 23 Jul 2013 19:53:08 +0000 (19:53 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 23 Jul 2013 19:53:08 +0000 (19:53 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37520

package/kernel/linux/modules/netfilter.mk

index fb830fc25bdd9e146c914e27b867fecebd520d4a..496a9f9d4d21ddf1b41796d7a4b506d5c73a14f2 100644 (file)
@@ -425,7 +425,7 @@ $(eval $(call KernelPackage,arptables))
 define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
-  DEPENDS:=+kmod-ipt-core
+  DEPENDS:=+kmod-ipt-core +kmod-bridge
   FILES:=$(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).ko)
   KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
        $(KCONFIG_EBTABLES)