iwinfo: build with nl80211 backend only and make shared
authorJo-Philipp Wich <jo@mein.io>
Fri, 2 Jul 2021 16:04:17 +0000 (18:04 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 2 Jul 2021 16:51:26 +0000 (18:51 +0200)
Drop support for building the obsolete broadcom-wl backend and always
forcibly enable the nl82011 support. This allows us to make the package
shared again since no target specific compilation is happening anymore.

This will solve various repository coherency issues related to unavailable
libiwinfo versions in the long run.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 5a1065758b88b568a04a50189400321601904bdf)

package/network/utils/iwinfo/Makefile

index d8c1befc970bbde2b9e0b3d4553e0aa82ddbab0b..b3ef261369f5015f7edb3ad63f3e8e78c41c34ef 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/iwinfo.git
@@ -17,14 +17,6 @@ PKG_MIRROR_HASH:=24ad04791254a0523cd15a4fec6116d9ff121e006c93e5e41459f91347b33ec
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-2.0
 
-PKG_FLAGS := nonshared
-
-PKG_CONFIG_DEPENDS := \
-       CONFIG_PACKAGE_kmod-brcm-wl \
-       CONFIG_PACKAGE_kmod-brcm-wl-mini \
-       CONFIG_PACKAGE_kmod-brcm-wl-mimo \
-       CONFIG_PACKAGE_kmod-cfg80211
-
 IWINFO_ABI_VERSION:=20210430
 
 include $(INCLUDE_DIR)/package.mk
@@ -34,13 +26,13 @@ define Package/libiwinfo
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Generalized Wireless Information Library (iwinfo)
-  DEPENDS:=+PACKAGE_kmod-cfg80211:libnl-tiny +libuci +libubus
+  DEPENDS:=+libnl-tiny +libuci +libubus
   ABI_VERSION:=$(IWINFO_ABI_VERSION)
 endef
 
 define Package/libiwinfo/description
-  Wireless information library with consistent interface for proprietary Broadcom,
-  nl80211 and wext driver interfaces.
+  Wireless information library with simplified API for nl80211
+  and wext driver interfaces.
 endef
 
 
@@ -73,12 +65,6 @@ endef
 define Build/Configure
 endef
 
-IWINFO_BACKENDS := \
-       $(if $(CONFIG_PACKAGE_kmod-brcm-wl),wl) \
-       $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mini),wl) \
-       $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mimo),wl) \
-       $(if $(CONFIG_PACKAGE_kmod-cfg80211),nl80211)
-
 TARGET_CFLAGS += \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        -I$(STAGING_DIR)/usr/include \
@@ -88,7 +74,7 @@ MAKE_FLAGS += \
        FPIC="$(FPIC)" \
        CFLAGS="$(TARGET_CFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
-       BACKENDS="$(IWINFO_BACKENDS)" \
+       BACKENDS="nl80211" \
        SOVERSION="$(IWINFO_ABI_VERSION)"
 
 define Build/InstallDev