base-files: default_postinst() - create user:group first (resend)
authorJohn Crispin <john@openwrt.org>
Mon, 1 Dec 2014 16:15:13 +0000 (16:15 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 1 Dec 2014 16:15:13 +0000 (16:15 +0000)
create user:group before running postinst-pkg. the postinst hook might require
the user:group to already exist.

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
SVN-Revision: 43472

package/base-files/Makefile
package/base-files/files/lib/functions.sh

index aeba973879d7b5c087e1010309cbe4f1d4a95be1..3c453b54aab0949927182c26de3eb266c4b34f7d 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=156
+PKG_RELEASE:=157
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index d53be3edfe7a1dc02107771f12c106760ad4a283..9d98fb0fbe4260e687d71ffaa04f08c2fc748918 100755 (executable)
@@ -173,7 +173,6 @@ default_prerm() {
 default_postinst() {
        local name rusers
        name=$(echo $(basename $1) | cut -d. -f1)
-       [ -f ${IPKG_INSTROOT}/usr/lib/opkg/info/${name}.postinst-pkg ] && ( . ${IPKG_INSTROOT}/usr/lib/opkg/info/${name}.postinst-pkg )
        rusers=$(grep "Require-User:" ${IPKG_INSTROOT}/usr/lib/opkg/info/${name}.control)
        [ -n "$rusers" ] && {
                local user group uid gid
@@ -212,6 +211,10 @@ default_postinst() {
                        done
                done
        }
+
+       [ -f ${IPKG_INSTROOT}/usr/lib/opkg/info/${name}.postinst-pkg ] && ( . ${IPKG_INSTROOT}/usr/lib/opkg/info/${name}.postinst-pkg )
+       [ -n "${IPKG_INSTROOT}" ] || rm -f /tmp/luci-indexcache 2>/dev/null
+
        [ "$PKG_UPGRADE" = "1" ] || for i in `cat ${IPKG_INSTROOT}/usr/lib/opkg/info/${name}.list | grep "^/etc/init.d/"`; do
                [ -n "${IPKG_INSTROOT}" ] && $(which bash) ${IPKG_INSTROOT}/etc/rc.common ${IPKG_INSTROOT}$i enable; \
                [ -n "${IPKG_INSTROOT}" ] || {
@@ -219,7 +222,6 @@ default_postinst() {
                        $i start
                }
        done
-       [ -n "${IPKG_INSTROOT}" ] || rm -f /tmp/luci-indexcache 2>/dev/null
        return 0
 }