make sure that base-files is installed last, this allows per-target base-file overlay...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Jun 2011 19:38:25 +0000 (19:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Jun 2011 19:38:25 +0000 (19:38 +0000)
SVN-Revision: 27138

package/Makefile

index 4f2cbf106ebf2ac650d1b59a4202e1c27f28aef4..7d2c42d8b8cad5ff5afd81924eec044482acd0d7 100644 (file)
@@ -14,7 +14,7 @@ ifeq ($(SDK),1)
 else
   $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
   $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
-  $(curdir)/builddirs-install:=. $(sort $(package-y))
+  $(curdir)/builddirs-install:=. $(filter-out base-files,$(sort $(package-y))) $(filter base-files,$(package-y))
 endif
 ifneq ($(IGNORE_ERRORS),)
   $(curdir)/builddirs-ignore-compile:= $(if $(filter n m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(subst n,,$(m)))),$(package-m) $(package-))