integrate mklibs.py support into the build process
authorFelix Fietkau <nbd@openwrt.org>
Sat, 8 Aug 2009 02:25:03 +0000 (02:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 8 Aug 2009 02:25:03 +0000 (02:25 +0000)
SVN-Revision: 17173

Config.in
package/Makefile

index 18aafda3a735d94a7d866d714f3ae5ef808937a4..9879c7d9c099b5bb0418f3ee4867164be31e6db9 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -126,6 +126,14 @@ choice
 
 endchoice
 
 
 endchoice
 
+config USE_MKLIBS
+       bool "Strip unnecessary functions from libraries"
+       help
+         Reduces libraries to only those functions that are necessary for using all
+         selected packages (including those selected as <M>)
+         Note that this will make the system libraries incompatible with most of the packages
+         that are not selected during the build process
+
 comment "Package build options"
 
 config DEBUG
 comment "Package build options"
 
 config DEBUG
index b7337a68401b44c440192625f4db4b86fd6f14b7..362a63cc8e6658bd8395debad80a45704725fc1a 100644 (file)
@@ -25,6 +25,40 @@ $(curdir)/install:=$(curdir)/install-cleanup
 $(curdir)/cleanup: $(TMP_DIR)/.build
        rm -rf $(TARGET_DIR) $(STAGING_DIR_ROOT)
 
 $(curdir)/cleanup: $(TMP_DIR)/.build
        rm -rf $(TARGET_DIR) $(STAGING_DIR_ROOT)
 
+ifdef CONFIG_USE_MKLIBS
+  define mklibs
+       rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
+       # first find all programs and add them to the mklibs list
+       find $(STAGING_DIR_ROOT) -type f -perm +100 -exec \
+               file -r -N -F '' {} + | \
+               awk ' /executable.*dynamically/ { print $$1 }' > $(TMP_DIR)/mklibs-progs
+       # find all loadable objects that are not regular libraries and add them to the list as well
+       find $(STAGING_DIR_ROOT) -type f -name \*.so\* -exec \
+               file -r -N -F '' {} + | \
+               awk ' /shared object/ { print $$1 }' >> $(TMP_DIR)/mklibs-progs
+       mkdir -p $(TMP_DIR)/mklibs-out
+       $(STAGING_DIR_HOST)/bin/mklibs.py -D -v \
+               -d $(TMP_DIR)/mklibs-out \
+               --sysroot $(STAGING_DIR_ROOT) \
+               -L /lib \
+               -L /usr/lib \
+               --ldlib $(patsubst $(STAGING_DIR_ROOT)/%,/%,$(firstword $(wildcard \
+                       $(foreach name,ld-uClibc.so.* ld-linux.so.*, \
+                         $(STAGING_DIR_ROOT)/lib/$(name) \
+                       )))) \
+               --target $(REAL_GNU_TARGET_NAME) \
+               `cat $(TMP_DIR)/mklibs-progs` 2>&1
+       $(RSTRIP) $(TMP_DIR)/mklibs-out
+       for lib in `ls $(TMP_DIR)/mklibs-out/*.so.* 2>/dev/null`; do \
+               LIB="$${lib##*/}"; \
+               DEST="`ls "$(TARGET_DIR)/lib/$$LIB" "$(TARGET_DIR)/usr/lib/$$LIB" 2>/dev/null`"; \
+               [ -n "$$DEST" ] || continue; \
+               echo "Copying stripped library $$lib to $$DEST"; \
+               cp "$$lib" "$$DEST" || exit 1; \
+       done
+  endef
+endif
+
 $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-$(MAKE) package/preconfig
        @if [ -d $(TOPDIR)/files ]; then \
 $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-$(MAKE) package/preconfig
        @if [ -d $(TOPDIR)/files ]; then \
@@ -42,6 +76,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
        $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
        $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
+       $(call mklibs)
 
 $(curdir)/index: FORCE
        @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
 
 $(curdir)/index: FORCE
        @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \