ramips: add support for Wavlink WL-WN576A2
authorThomas Aldrian <dev.aldrian@gmail.com>
Tue, 2 Nov 2021 19:10:39 +0000 (19:10 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 20 Nov 2021 20:08:25 +0000 (21:08 +0100)
This commit adds support for the Wavlink WL-WN576A2 wall-plug wireles
repeater / router. It is also sold under the name SilverCrest SWV 733 B1.

Device specs:

- CPU: MediaTek MT7628AN
- Flash: 8MB
- RAM: 64MB
- Bootloader: U-Boot
- Ethernet: 1x 10/100 Mbps
- 2.4 GHz: b/g/n SoC
- 5 GHz: a/n/ac MT7610EN
- Buttons: WPS, reset, sliding switch (ap/repeater)
- LEDs: 5x wifi status, 1x LAN/WAN, 1x WPS

Flashing:

U-Boot launches a TFTP client if WPS button is held during boot.

- Server IP: 192.168.10.100
- Firmware file name: firmware.bin

Device will reboot automatically. First boot takes about 90s.

Coelner (waenger@gmail.com) is the original author, but I have made some
fixes. He does not wish to sign off using his real name.

Signed-off-by: Thomas Aldrian <dev.aldrian@gmail.com>
target/linux/ramips/dts/mt7628an_wavlink_wl-wn576a2.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7628an_wavlink_wl-wn576a2.dts b/target/linux/ramips/dts/mt7628an_wavlink_wl-wn576a2.dts
new file mode 100644 (file)
index 0000000..bb1ddd0
--- /dev/null
@@ -0,0 +1,184 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "wavlink,wl-wn576a2", "mediatek,mt7628an-soc";
+       model = "Wavlink WL-WN576A2";
+
+       aliases {
+               led-boot = &led_wps;
+               led-failsafe = &led_wps;
+               led-running = &led_wps;
+               led-upgrade = &led_wps;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               ap {
+                       label = "ap";
+                       gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_0>;
+                       linux,input-type = <EV_SW>;
+               };
+
+               repeater {
+                       label = "repeater";
+                       gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+                       linux,code = <BTN_1>;
+                       linux,input-type = <EV_SW>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wifi-high {
+                       label = "blue:wifi-high";
+                       gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-mediumhigh {
+                       label = "blue:wifi-mediumhigh";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-medium {
+                       label = "blue:wifi-medium";
+                       gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-mediumlow {
+                       label = "blue:wifi-mediumlow";
+                       gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-low {
+                       label = "blue:wifi-low";
+                       gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "blue:lan";
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               };
+
+               led_wps: wps {
+                       label = "blue:wps";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2c", "i2s", "wdt", "wled_an", "p0led_an", "p1led_an",
+                       "p2led_an", "p3led_an", "p4led_an", "refclk", "gpio";
+               function = "gpio";
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x7b0000>;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mediatek,mtd-eeprom = <&factory 0x0>;
+};
+
+&ethernet {
+       nvmem-cells = <&macaddr_factory_28>;
+       nvmem-cells-names = "max-address";
+};
+
+&esw {
+       mediatek,portmap = <0x3f>;
+};
+
+&usbphy {
+       status = "disabled";
+};
+
+&ehci {
+       status = "disabled";
+};
+
+&ohci {
+       status = "disabled";
+};
+
+&factory {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_factory_28: macaddr@28 {
+               reg = <0x28 0x6>;
+       };
+};
index 7d28cd62e8701fdc7275dca2321cc8646b712671..e9188e7405b772427c687ec4153f2ceba4cb74c6 100644 (file)
@@ -758,6 +758,16 @@ define Device/wavlink_wl-wn575a3
 endef
 TARGET_DEVICES += wavlink_wl-wn575a3
 
+define Device/wavlink_wl-wn576a2
+  IMAGE_SIZE := 7872k
+  DEVICE_VENDOR := Wavlink
+  DEVICE_MODEL := WL-WN576A2
+  DEVICE_ALT0_VENDOR := Silvercrest
+  DEVICE_ALT0_MODEL := SWV 733 B1
+  DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += wavlink_wl-wn576a2
+
 define Device/wavlink_wl-wn577a2
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Wavlink
index 98a693c2e93ed8654de002d1f4277034920098cf..0af01d4393272b2ea822184fe1e4c705c8b07276 100644 (file)
@@ -136,6 +136,9 @@ wavlink,wl-wn575a3)
        ucidef_set_led_rssi "wifi-med" "wifi-med" "green:wifi-med" "wlan1" "50" "84"
        ucidef_set_led_rssi "wifi-high" "wifi-high" "green:wifi-high" "wlan1" "85" "100"
        ;;
+wavlink,wl-wn576a2)
+       ucidef_set_led_switch "lan" "lan" "blue:lan" "switch0" "0x10"
+       ;;
 wavlink,wl-wn577a2|\
 wavlink,wl-wn578a2)
        ucidef_set_led_switch "lan" "lan" "green:lan" "switch0" "0x8"
index 12a29b3907c7470034890d8acada665e65ab30f2..d4e3027f4e70962c7dc48bcc0e9256ad06cf64e5 100644 (file)
@@ -129,7 +129,8 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:wan" "6@eth0"
                ;;
-       tplink,tl-wr902ac-v3)
+       tplink,tl-wr902ac-v3|\
+       wavlink,wl-wn576a2)
                ucidef_add_switch "switch0" \
                        "4:lan" "6@eth0"
                ;;
@@ -229,7 +230,8 @@ ramips_setup_macs()
        onion,omega2|\
        onion,omega2p|\
        vocore,vocore2|\
-       vocore,vocore2-lite)
+       vocore,vocore2-lite|\
+       wavlink,wl-wn576a2)
                label_mac=$(mtd_get_mac_binary factory 0x4)
                ;;
        rakwireless,rak633|\