ramips: mt7621: use lzma-loader for ZBT-WG3526
authorRustam Gaptulin <rascal6@gmail.com>
Sun, 23 Aug 2020 10:02:48 +0000 (15:02 +0500)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 23 Aug 2020 22:18:43 +0000 (00:18 +0200)
The wg3526 fails to boot if the kernel is large.
Enabling lzma-loader resolves the issue on both the wg3526-16m
and wg3526-32m.

Fixes: FS#3143
Signed-off-by: Rustam Gaptulin <rascal6@gmail.com>
[commit message facelift]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/image/mt7621.mk

index 9e481af98fefa308d7d6ef2cbb91341e37f2bc06..896a27324b0424a95ab165a0851e44b4a49127c4 100644 (file)
@@ -1286,6 +1286,7 @@ TARGET_DEVICES += zbtlink_zbt-wg2626
 
 define Device/zbtlink_zbt-wg3526-16m
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WG3526
@@ -1298,6 +1299,7 @@ TARGET_DEVICES += zbtlink_zbt-wg3526-16m
 
 define Device/zbtlink_zbt-wg3526-32m
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 32448k
   DEVICE_VENDOR := Zbtlink
   DEVICE_MODEL := ZBT-WG3526